summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-06-25 16:43:47 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-06-25 16:43:47 +0200
commit0ebdd558a60577558cf0aafb312b777204a1085b (patch)
tree12bf92752f7af0c42778908b3d1319d087bd58c0 /media-tv
parentgames-roguelike/scourge: Replaced freetype-config with pkg-config (diff)
downloadgentoo-0ebdd558a60577558cf0aafb312b777204a1085b.tar.gz
gentoo-0ebdd558a60577558cf0aafb312b777204a1085b.tar.bz2
gentoo-0ebdd558a60577558cf0aafb312b777204a1085b.zip
media-tv/mythtv: Replaced freetype-config with pkg-config
Bug: https://bugs.gentoo.org/658534 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/mythtv/files/mythtv-29.2-freetype_pkgconfig.patch28
-rw-r--r--media-tv/mythtv/mythtv-0.28.1-r4.ebuild1
2 files changed, 29 insertions, 0 deletions
diff --git a/media-tv/mythtv/files/mythtv-29.2-freetype_pkgconfig.patch b/media-tv/mythtv/files/mythtv-29.2-freetype_pkgconfig.patch
new file mode 100644
index 000000000000..fa248907f279
--- /dev/null
+++ b/media-tv/mythtv/files/mythtv-29.2-freetype_pkgconfig.patch
@@ -0,0 +1,28 @@
+From 8cbb51a829ca4602da75c359bc598130c19264c4 Mon Sep 17 00:00:00 2001
+From: Peter Bennett <pbennett@mythtv.org>
+Date: Wed, 9 May 2018 19:17:12 -0400
+Subject: [PATCH] configure: new version of freetype2 does not support
+ freetype-config
+
+freetype2 v2.9.1 uses only pkgconfig and removes support for freetype-config
+
+Fixes #13262
+---
+ mythtv/configure | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/mythtv/configure b/mythtv/configure
+index 8b55291685b..a378fc44dde 100755
+--- a/mythtv/configure
++++ b/mythtv/configure
+@@ -7406,8 +7406,8 @@ if enabled darwin_da; then
+ fi
+
+ if enabled freetype2; then
+- echo "FREETYPE_CFLAGS=`freetype-config --cflags`" >> $TMPMAK
+- echo "FREETYPE_LIBS=`freetype-config --libs`" >> $TMPMAK
++ echo "FREETYPE_CFLAGS=$($pkg_config --cflags $pkg_config_flags freetype2)" >> $TMPMAK
++ echo "FREETYPE_LIBS=$($pkg_config --libs $pkg_config_flags freetype2)" >> $TMPMAK
+ fi
+
+ if test $target_os = darwin; then
diff --git a/media-tv/mythtv/mythtv-0.28.1-r4.ebuild b/media-tv/mythtv/mythtv-0.28.1-r4.ebuild
index 50c45fc9e8bf..9faa120b8df6 100644
--- a/media-tv/mythtv/mythtv-0.28.1-r4.ebuild
+++ b/media-tv/mythtv/mythtv-0.28.1-r4.ebuild
@@ -175,6 +175,7 @@ src_prepare() {
echo "setting.extra -= -ldconfig" >> "${S}"/programs/mythfrontend/mythfrontend.pro
eapply "${FILESDIR}/${P}-glibc225.patch"
+ eapply -p2 "${FILESDIR}/${PN}-29.2-freetype_pkgconfig.patch" #658534
}
src_configure() {