summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Vasquez <fearedbliss@gentoo.org>2017-09-04 11:47:51 -0400
committerJonathan Vasquez <fearedbliss@gentoo.org>2017-09-04 11:48:12 -0400
commit41070cb736f3524a6d87d96a3cce9d931fe8b895 (patch)
tree1398204a3ed9679ef36c6a7b909de49338c5a5ca /media-tv
parentmedia-tv/plex-media-server: stabilizing 1.7.5 (diff)
downloadgentoo-41070cb736f3524a6d87d96a3cce9d931fe8b895.tar.gz
gentoo-41070cb736f3524a6d87d96a3cce9d931fe8b895.tar.bz2
gentoo-41070cb736f3524a6d87d96a3cce9d931fe8b895.zip
media-tv/plex-media-server: version bump to 1.8.1
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/plex-media-server/Manifest1
-rw-r--r--media-tv/plex-media-server/plex-media-server-1.8.1.ebuild135
2 files changed, 136 insertions, 0 deletions
diff --git a/media-tv/plex-media-server/Manifest b/media-tv/plex-media-server/Manifest
index be3aaf7454bf..46a0d23ff9e5 100644
--- a/media-tv/plex-media-server/Manifest
+++ b/media-tv/plex-media-server/Manifest
@@ -1,2 +1,3 @@
DIST plexmediaserver_1.5.6.3790-4613ce077_amd64.deb 105490284 SHA256 633a7fad995347fed1b22dd6983156d24ac95659d541ee4cf8eea505d4cc5575 SHA512 87173c290937706f05461b7ca3b217e09262ec02b0fa728580c18802e3b7246899f2840fdd6703256e32cd92adb71e3d5321c0a38569827f005eb1face9144f7 WHIRLPOOL d9de5e1a90e8644aa14702e034d1799cd1f1fab1c7c730a2334bdac6e1c90a44a0febdfdb42ab791a728bf6daf9baf655c3f2dd82ff9632a86340a9e9aef38e9
DIST plexmediaserver_1.7.5.4035-313f93718_amd64.deb 106646674 SHA256 a8c9d2961443c22c85b2795f267bafe576561d365a85d18a97627508a3515844 SHA512 033296004a57c0b7ded412298e7bb2c817ca5c4276683115e0bfb88ecb3445355745ef8216aa4ec92926a3f3ff5ae813470ad4a2edc7f85ed32386e363e76203 WHIRLPOOL 912b2057f71f51a3820a5e660f8726af000165a72ea36f480a62786057cf1e7c42f20741119cd7de14565360d45b6e6c6888ae2cc6ccdc67e7f1d7b8da54c530
+DIST plexmediaserver_1.8.1.4139-c789b3fbb_amd64.deb 107251412 SHA256 30b907c94d5b76991831fd3555e4447724683c4e01617a71d39bfe5be11af126 SHA512 17b6de15920013e74f0a634f004b9b599bebd266412f694963967c766e8879b54485a9b07178a575d246c6bc53b202e38da89e293fd7219d0cf993bf9e27afec WHIRLPOOL c907c627a8e693b5b029958e87b01b8c27e3f40ec6ddc04d9b95e67570260ac344bfad9aa35dfdd2ec13f492f7fed3817373c713b5163b7f9c22db1970b8091f
diff --git a/media-tv/plex-media-server/plex-media-server-1.8.1.ebuild b/media-tv/plex-media-server/plex-media-server-1.8.1.ebuild
new file mode 100644
index 000000000000..4511bd18b108
--- /dev/null
+++ b/media-tv/plex-media-server/plex-media-server-1.8.1.ebuild
@@ -0,0 +1,135 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+inherit eutils user systemd unpacker pax-utils python-single-r1
+
+MINOR_VERSION="4139-c789b3fbb"
+
+_APPNAME="plexmediaserver"
+_USERNAME="plex"
+_SHORTNAME="${_USERNAME}"
+_FULL_VERSION="${PV}.${MINOR_VERSION}"
+
+URI="https://downloads.plex.tv/plex-media-server"
+
+DESCRIPTION="A free media library that is intended for use with a plex client."
+HOMEPAGE="http://www.plex.tv/"
+SRC_URI="amd64? ( ${URI}/${_FULL_VERSION}/plexmediaserver_${_FULL_VERSION}_amd64.deb )"
+SLOT="0"
+LICENSE="Plex"
+RESTRICT="bindist strip"
+KEYWORDS="-* ~amd64"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ sys-apps/fix-gnustack
+ dev-python/virtualenv[${PYTHON_USEDEP}]"
+
+RDEPEND="
+ net-dns/avahi
+ ${PYTHON_DEPS}"
+
+QA_DESKTOP_FILE="usr/share/applications/plexmediamanager.desktop"
+QA_PREBUILT="*"
+QA_MULTILIB_PATHS=(
+ "usr/lib/${_APPNAME}/.*"
+ "usr/lib/${_APPNAME}/Resources/Python/lib/python2.7/.*"
+)
+
+EXECSTACKED_BINS=( "${ED%/}/usr/lib/plexmediaserver/libgnsdk_dsp.so*" )
+BINS_TO_PAX_MARK=( "${ED%/}/usr/lib/plexmediaserver/Plex Script Host" )
+
+S="${WORKDIR}"
+PATCHES=( "${FILESDIR}/virtualenv_start_pms.patch" )
+
+pkg_setup() {
+ enewgroup ${_USERNAME}
+ enewuser ${_USERNAME} -1 /bin/bash /var/lib/${_APPNAME} "${_USERNAME},video"
+ python-single-r1_pkg_setup
+}
+
+src_unpack() {
+ unpack_deb ${A}
+}
+
+src_install() {
+ # Move the config to the correct place
+ local CONFIG_VANILLA="/etc/default/plexmediaserver"
+ local CONFIG_PATH="/etc/${_SHORTNAME}"
+ dodir "${CONFIG_PATH}"
+ insinto "${CONFIG_PATH}"
+ doins "${CONFIG_VANILLA#/}"
+ sed -e "s#${CONFIG_VANILLA}#${CONFIG_PATH}/${_APPNAME}#g" -i "${S}"/usr/sbin/start_pms || die
+
+ # Remove Debian specific files
+ rm -rf "usr/share/doc" || die
+
+ # Copy main files over to image and preserve permissions so it is portable
+ cp -rp usr/ "${ED}" || die
+
+ # Make sure the logging directory is created
+ local LOGGING_DIR="/var/log/pms"
+ dodir "${LOGGING_DIR}"
+ chown "${_USERNAME}":"${_USERNAME}" "${ED%/}/${LOGGING_DIR}" || die
+
+ # Create default library folder with correct permissions
+ local DEFAULT_LIBRARY_DIR="/var/lib/${_APPNAME}"
+ dodir "${DEFAULT_LIBRARY_DIR}"
+ chown "${_USERNAME}":"${_USERNAME}" "${ED%/}/${DEFAULT_LIBRARY_DIR}" || die
+
+ # Install the OpenRC init/conf files
+ doinitd "${FILESDIR}/init.d/${PN}"
+ doconfd "${FILESDIR}/conf.d/${PN}"
+
+ _handle_multilib
+
+ # Install systemd service file
+ local INIT_NAME="${PN}.service"
+ local INIT="${FILESDIR}/systemd/${INIT_NAME}"
+ systemd_newunit "${INIT}" "${INIT_NAME}"
+
+ _remove_execstack_markings
+ _add_pax_markings
+
+ einfo "Configuring virtualenv"
+ virtualenv -v --no-pip --no-setuptools --no-wheel "${ED}"usr/lib/plexmediaserver/Resources/Python || die
+ pushd "${ED}"usr/lib/plexmediaserver/Resources/Python &>/dev/null || die
+ find . -type f -exec sed -i -e "s#${D}##g" {} + || die
+ popd &>/dev/null || die
+}
+
+pkg_postinst() {
+ einfo ""
+ elog "Plex Media Server is now installed. Please check the configuration file in /etc/${_SHORTNAME}/${_APPNAME} to verify the default settings."
+ elog "To start the Plex Server, run 'rc-config start plex-media-server', you will then be able to access your library at http://<ip>:32400/web/"
+}
+
+# Finds out where the library directory is for this system
+# and handles ldflags as to not break library dependencies
+# during rebuilds.
+_handle_multilib() {
+ # Prevent revdep-rebuild, @preserved-rebuild breakage
+ cat > "${T}"/66plex <<-EOF || die
+ LDPATH="${EPREFIX}/usr/$(get_libdir)/plexmediaserver"
+ EOF
+
+ doenvd "${T}"/66plex
+}
+
+# Remove execstack flags from some libraries/executables so that it works in hardened setups.
+_remove_execstack_markings() {
+ for f in "${EXECSTACKED_BINS[@]}"; do
+ # Unquoting 'f' so that expansion works.
+ fix-gnustack -f ${f} > /dev/null
+ done
+}
+
+# Add pax markings to some binaries so that they work on hardened setup.
+_add_pax_markings() {
+ for f in "${BINS_TO_PAX_MARK[@]}"; do
+ pax-mark m "${f}"
+ done
+}