summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Vasquez <fearedbliss@gentoo.org>2018-01-28 18:05:47 -0500
committerJonathan Vasquez <fearedbliss@gentoo.org>2018-01-28 18:09:53 -0500
commit45282acdcd2bfdb74d8d74ebc712b4cddeadd2e9 (patch)
tree21199bc61dc1ab08a5b062b9ea4d29d1cb8d4331 /media-tv
parentsys-boot/gnu-efi: fix linker script on .gnu.hash systems, bug #575300 (diff)
downloadgentoo-45282acdcd2bfdb74d8d74ebc712b4cddeadd2e9.tar.gz
gentoo-45282acdcd2bfdb74d8d74ebc712b4cddeadd2e9.tar.bz2
gentoo-45282acdcd2bfdb74d8d74ebc712b4cddeadd2e9.zip
media-tv/plex-media-server: Stabilizing 1.10.1 and Fixing #644694.
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/plex-media-server/Manifest1
-rw-r--r--media-tv/plex-media-server/plex-media-server-1.10.0.ebuild135
-rw-r--r--media-tv/plex-media-server/plex-media-server-1.10.1.ebuild9
3 files changed, 7 insertions, 138 deletions
diff --git a/media-tv/plex-media-server/Manifest b/media-tv/plex-media-server/Manifest
index 940fda1f2361..3731189161f1 100644
--- a/media-tv/plex-media-server/Manifest
+++ b/media-tv/plex-media-server/Manifest
@@ -1,2 +1 @@
-DIST plexmediaserver_1.10.0.4523-648bc61d4_amd64.deb 108257188 BLAKE2B 7b8ab929ef059ba7f2c6aea061348216361f0fa5af19a5e70fed134760e615f2bd28133a37337660711b3de4af883aede52e63e1a585b6ab15ca93d6ec7e8251 SHA512 8b4111c73ad04e28a2b8040fbd60b8272e2556d4a492442c25fab2b681eb7dc1477e5ec30261884a622eb9c6ab99836318c97cbb726ac07c31495c450258c0cc
DIST plexmediaserver_1.10.1.4602-f54242b6b_amd64.deb 108445778 BLAKE2B 8c71bbc7a90d5465aa23b4ddaddbec8ccc81f7e5f09e2e3b98a878c5375158381c5fc20fd6542a3a9e642007ab06045eb3afe210ef5f16a5f60f1d3abd8c3fe7 SHA512 16f3f28e1ba409b141c8f2f7ecb912bcf47485e68d8e813c4908465407d8e6e3c455e6358538445e06b73380f82c46a5b29e6d02d4b4576407dc8d7bc0644b38
diff --git a/media-tv/plex-media-server/plex-media-server-1.10.0.ebuild b/media-tv/plex-media-server/plex-media-server-1.10.0.ebuild
deleted file mode 100644
index b5a991388dc5..000000000000
--- a/media-tv/plex-media-server/plex-media-server-1.10.0.ebuild
+++ /dev/null
@@ -1,135 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-inherit eutils user systemd unpacker pax-utils python-single-r1
-
-MINOR_VERSION="4523-648bc61d4"
-
-_APPNAME="plexmediaserver"
-_USERNAME="plex"
-_SHORTNAME="${_USERNAME}"
-_FULL_VERSION="${PV}.${MINOR_VERSION}"
-
-URI="https://downloads.plex.tv/plex-media-server"
-
-DESCRIPTION="A free media library that is intended for use with a plex client."
-HOMEPAGE="http://www.plex.tv/"
-SRC_URI="amd64? ( ${URI}/${_FULL_VERSION}/plexmediaserver_${_FULL_VERSION}_amd64.deb )"
-SLOT="0"
-LICENSE="Plex"
-RESTRICT="bindist strip"
-KEYWORDS="-* amd64"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="
- sys-apps/fix-gnustack
- dev-python/virtualenv[${PYTHON_USEDEP}]"
-
-RDEPEND="
- net-dns/avahi
- ${PYTHON_DEPS}"
-
-QA_DESKTOP_FILE="usr/share/applications/plexmediamanager.desktop"
-QA_PREBUILT="*"
-QA_MULTILIB_PATHS=(
- "usr/lib/${_APPNAME}/.*"
- "usr/lib/${_APPNAME}/Resources/Python/lib/python2.7/.*"
-)
-
-EXECSTACKED_BINS=( "${ED%/}/usr/lib/plexmediaserver/libgnsdk_dsp.so*" )
-BINS_TO_PAX_MARK=( "${ED%/}/usr/lib/plexmediaserver/Plex Script Host" )
-
-S="${WORKDIR}"
-PATCHES=( "${FILESDIR}/virtualenv_start_pms.patch" )
-
-pkg_setup() {
- enewgroup ${_USERNAME}
- enewuser ${_USERNAME} -1 /bin/bash /var/lib/${_APPNAME} "${_USERNAME},video"
- python-single-r1_pkg_setup
-}
-
-src_unpack() {
- unpack_deb ${A}
-}
-
-src_install() {
- # Move the config to the correct place
- local CONFIG_VANILLA="/etc/default/plexmediaserver"
- local CONFIG_PATH="/etc/${_SHORTNAME}"
- dodir "${CONFIG_PATH}"
- insinto "${CONFIG_PATH}"
- doins "${CONFIG_VANILLA#/}"
- sed -e "s#${CONFIG_VANILLA}#${CONFIG_PATH}/${_APPNAME}#g" -i "${S}"/usr/sbin/start_pms || die
-
- # Remove Debian specific files
- rm -rf "usr/share/doc" || die
-
- # Copy main files over to image and preserve permissions so it is portable
- cp -rp usr/ "${ED}" || die
-
- # Make sure the logging directory is created
- local LOGGING_DIR="/var/log/pms"
- dodir "${LOGGING_DIR}"
- chown "${_USERNAME}":"${_USERNAME}" "${ED%/}/${LOGGING_DIR}" || die
-
- # Create default library folder with correct permissions
- local DEFAULT_LIBRARY_DIR="/var/lib/${_APPNAME}"
- dodir "${DEFAULT_LIBRARY_DIR}"
- chown "${_USERNAME}":"${_USERNAME}" "${ED%/}/${DEFAULT_LIBRARY_DIR}" || die
-
- # Install the OpenRC init/conf files
- doinitd "${FILESDIR}/init.d/${PN}"
- doconfd "${FILESDIR}/conf.d/${PN}"
-
- _handle_multilib
-
- # Install systemd service file
- local INIT_NAME="${PN}.service"
- local INIT="${FILESDIR}/systemd/${INIT_NAME}"
- systemd_newunit "${INIT}" "${INIT_NAME}"
-
- _remove_execstack_markings
- _add_pax_markings
-
- einfo "Configuring virtualenv"
- virtualenv -v --no-pip --no-setuptools --no-wheel "${ED}"usr/lib/plexmediaserver/Resources/Python || die
- pushd "${ED}"usr/lib/plexmediaserver/Resources/Python &>/dev/null || die
- find . -type f -exec sed -i -e "s#${D}##g" {} + || die
- popd &>/dev/null || die
-}
-
-pkg_postinst() {
- einfo ""
- elog "Plex Media Server is now installed. Please check the configuration file in /etc/${_SHORTNAME}/${_APPNAME} to verify the default settings."
- elog "To start the Plex Server, run 'rc-config start plex-media-server', you will then be able to access your library at http://<ip>:32400/web/"
-}
-
-# Finds out where the library directory is for this system
-# and handles ldflags as to not break library dependencies
-# during rebuilds.
-_handle_multilib() {
- # Prevent revdep-rebuild, @preserved-rebuild breakage
- cat > "${T}"/66plex <<-EOF || die
- LDPATH="${EPREFIX}/usr/$(get_libdir)/plexmediaserver"
- EOF
-
- doenvd "${T}"/66plex
-}
-
-# Remove execstack flags from some libraries/executables so that it works in hardened setups.
-_remove_execstack_markings() {
- for f in "${EXECSTACKED_BINS[@]}"; do
- # Unquoting 'f' so that expansion works.
- fix-gnustack -f ${f} > /dev/null
- done
-}
-
-# Add pax markings to some binaries so that they work on hardened setup.
-_add_pax_markings() {
- for f in "${BINS_TO_PAX_MARK[@]}"; do
- pax-mark m "${f}"
- done
-}
diff --git a/media-tv/plex-media-server/plex-media-server-1.10.1.ebuild b/media-tv/plex-media-server/plex-media-server-1.10.1.ebuild
index 760f6bd70b88..7941b222c814 100644
--- a/media-tv/plex-media-server/plex-media-server-1.10.1.ebuild
+++ b/media-tv/plex-media-server/plex-media-server-1.10.1.ebuild
@@ -21,7 +21,7 @@ SRC_URI="amd64? ( ${URI}/${_FULL_VERSION}/plexmediaserver_${_FULL_VERSION}_amd64
SLOT="0"
LICENSE="Plex"
RESTRICT="bindist strip"
-KEYWORDS="-* ~amd64"
+KEYWORDS="-* amd64"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
DEPEND="
@@ -84,7 +84,8 @@ src_install() {
doinitd "${FILESDIR}/init.d/${PN}"
doconfd "${FILESDIR}/conf.d/${PN}"
- _handle_multilib
+ # Disabling due to Bug 644694
+ #_handle_multilib
# Install systemd service file
local INIT_NAME="${PN}.service"
@@ -107,6 +108,10 @@ pkg_postinst() {
elog "To start the Plex Server, run 'rc-config start plex-media-server', you will then be able to access your library at http://<ip>:32400/web/"
}
+# Bug 644694. We shouldn't register plex libraries in global
+# library path since this will cause other packages on the system
+# to break.
+
# Finds out where the library directory is for this system
# and handles ldflags as to not break library dependencies
# during rebuilds.