summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilson Michaels <thebitpit@earthlink.net>2020-03-02 12:57:57 -0600
committerJoonas Niilola <juippis@gentoo.org>2020-03-03 16:53:42 +0200
commitb5b50c406032fba9eec57eaac78b814774671dd5 (patch)
tree253f611f881ff6a5e7dd6b15dd880626fa2bdaae /media-tv
parentsys-power/powerstat: update live ebuild (diff)
downloadgentoo-b5b50c406032fba9eec57eaac78b814774671dd5.tar.gz
gentoo-b5b50c406032fba9eec57eaac78b814774671dd5.tar.bz2
gentoo-b5b50c406032fba9eec57eaac78b814774671dd5.zip
media-tv/mythtv: Fix fail when USE = -python
Closes: https://bugs.gentoo.org/711172 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Wilson Michaels <thebitpit@earthlink.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/mythtv/mythtv-29.1-r2.ebuild3
-rw-r--r--media-tv/mythtv/mythtv-30.0_p20190808-r2.ebuild4
2 files changed, 4 insertions, 3 deletions
diff --git a/media-tv/mythtv/mythtv-29.1-r2.ebuild b/media-tv/mythtv/mythtv-29.1-r2.ebuild
index c386ea2be4ff..4f6a3c212b50 100644
--- a/media-tv/mythtv/mythtv-29.1-r2.ebuild
+++ b/media-tv/mythtv/mythtv-29.1-r2.ebuild
@@ -285,6 +285,7 @@ src_configure() {
src_install() {
emake STRIP="true" INSTALL_ROOT="${D}" install
dodoc AUTHORS UPGRADING README
+ use python && python_optimize # does all packages by default
readme.gentoo_create_doc
insinto /usr/share/mythtv/database
@@ -336,7 +337,7 @@ src_install() {
done
# Ensure that Python scripts are executed by Python 2
- python_fix_shebang "${ED}/usr/share/mythtv"
+ use python && python_fix_shebang "${ED}/usr/share/mythtv"
# Make shell & perl scripts executable
find "${ED}" -type f -name '*.sh' -o -type f -name '*.pl' | \
diff --git a/media-tv/mythtv/mythtv-30.0_p20190808-r2.ebuild b/media-tv/mythtv/mythtv-30.0_p20190808-r2.ebuild
index b09dc0235f97..67f54fca3c2b 100644
--- a/media-tv/mythtv/mythtv-30.0_p20190808-r2.ebuild
+++ b/media-tv/mythtv/mythtv-30.0_p20190808-r2.ebuild
@@ -357,7 +357,7 @@ src_configure() {
src_install() {
emake STRIP="true" INSTALL_ROOT="${D}" install
- python_optimize # does all packages by default
+ use python && python_optimize # does all packages by default
dodoc AUTHORS UPGRADING README
readme.gentoo_create_doc
@@ -408,7 +408,7 @@ src_install() {
-exec chmod a+x {} \; || die "Failed to make python file $(basename ${file}) executable"
# Ensure that Python scripts are executed by Python 2
- python_fix_shebang "${ED}/usr/share/mythtv"
+ use python && python_fix_shebang "${ED}/usr/share/mythtv"
# Make shell & perl scripts executable
find "${ED}" -type f \( -name '*.sh' -o -name '*.pl' \) -exec chmod a+x {} \; || die "Failed to make script executable"