summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/acidrip/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/acidrip/files')
-rw-r--r--media-video/acidrip/files/acidrip-0.14-makefile.patch50
-rw-r--r--media-video/acidrip/files/acidrip-mplayer.patch22
2 files changed, 72 insertions, 0 deletions
diff --git a/media-video/acidrip/files/acidrip-0.14-makefile.patch b/media-video/acidrip/files/acidrip-0.14-makefile.patch
new file mode 100644
index 000000000000..bbaf340799c3
--- /dev/null
+++ b/media-video/acidrip/files/acidrip-0.14-makefile.patch
@@ -0,0 +1,50 @@
+--- acidrip-0.14/Makefile.PL.orig 2014-08-22 09:38:46.179128473 -0600
++++ acidrip-0.14/Makefile.PL 2014-08-22 09:40:33.045103299 -0600
+@@ -36,47 +36,7 @@
+ $_;
+ }
+
+-print "\nRunning additional test to be sure acidrip will work\n";
+-
+-print "test for lsdvd: ";
+-my $lsdvd = `lsdvd -V 2>&1`;
+-if ( $lsdvd !~ /0.(\d+)\s/ ) {
+-die "Not Found!\n\n***************\n" .
+- "AcidRip needs my little app \"lsdvd\" in order to see what is on your dvd\'s\n" .
+- "Download it and install it (and libdvdread) before trying to use AcidRip.\n" .
+- "If it\'s simply not on your path then set the full path inside AcidRip.\n" .
+- "***************\n\n"
+-}
+-if ( $1 < 9 ) {
+-die "Too old!\n\n***************\n" .
+- "AcidRip needs at least version 0.9 of lsdvd, but version 0.$1 was found\n" .
+- "Download it and install it (and libdvdread) before trying to use AcidRip.\n" .
+- "***************\n\n"
+-}
+-print "found\n";
+-
+-print "test for MPlayer: "; die "Not Found!\n\n***************\n" .
+- "AcidRip is based around the MPlayer video player. it has not been found on\n" .
+- "your current path. Install it from http://mplayerhq/hu see INSTALL.html or\n" .
+- "INSTALL for installation instructions.\n" .
+- "***************\n\n" if ( system "mplayer 2&>1 > /dev/null" ); print "found\n";
+-
+-print "test for MEncoder: "; die "Not Found!\n\n***************\n" .
+- "AcidRip uses MEncoder, which is part of MPlayer video player package. This\n" .
+- "was not found. Install it from http://mplayerhq/hu see INSTALL.html or\n" .
+- "INSTALL for installation instructions.\n" .
+- "***************\n\n" if ( system "mencoder -ovc help 2> /dev/null | grep MEncoder > /dev/null" ); print "found\n";
+-
+-print "test for MP3 support in mencoder: "; die "Not Found!\n\n***************\n" .
+- "MEncoder was found, however it does not have MP3 support built into it.\n" .
+- "If you DO want MP3 support you'll need to recompile mplayer with mp3 support\n" .
+- "See INSTALL or INSTALL.html for more information\n" .
+- "***************\n\n" if ( system "mencoder -oac help 2> /dev/null | grep mp3lame > /dev/null" ); print "found\n";
+-
+-print "Everything looks good here...\n";
+-
+ print "\nPlease send any feedback to me, I actually do want to know what you think of it.";
+ print "\nMaybe then I can make it suck less. acid_kewpie\@users.sourceforge.net\n\n";
+
+ exit(0);
+-
diff --git a/media-video/acidrip/files/acidrip-mplayer.patch b/media-video/acidrip/files/acidrip-mplayer.patch
new file mode 100644
index 000000000000..5d9c84701d5e
--- /dev/null
+++ b/media-video/acidrip/files/acidrip-mplayer.patch
@@ -0,0 +1,22 @@
+http://bugs.gentoo.org/168012
+
+--- AcidRip/acidrip.pm
++++ AcidRip/acidrip.pm
+@@ -680,7 +680,7 @@
+ message( "Running " . get_command("cropdetect") );
+ open( CROP, get_command("cropdetect") . " 2>&1 |" );
+ while (<CROP>) {
+- if ( $_ =~ /crop area.*\s(crop=\d*:\d*:\d*:\d*)/ ) { $crop{$1}++ }
++ if ( $_ =~ /Crop area.*\s(crop=\d*:\d*:\d*:\d*)/ ) { $crop{$1}++ }
+ $crop_output .= $_;
+ gui_check($_);
+ }
+@@ -863,7 +863,7 @@
+ if ( $::settings->{'mencoder_pid'} = open( MENCODER, "$menc 2>&1 |" ) ) {
+ $/ = "\r";
+ while (<MENCODER>) {
+- if (/^Pos:\s*(\d+).\ds\s+(\d+)f\s+\(\s*(\d+)%\)\s+(\d+fps)\sTrem:\s+(\d+min)\s+(\d+mb).+\[([\d:]+)\]/) {
++ if (/^Pos:\s*(\d+).\ds\s+(\d+)f\s+\(\s*(\d+)%\)\s+(\d+.\d+fps)\sTrem:\s+(\d+min)\s+(\d+mb).+\[([\d:]+)\]/) {
+ if ( $1 ne $sec ) { $sec = $1; $::widgets->{'menc_seconds'}->set_text( hhmmss($1) ) }
+ if ( $4 ne $fps ) { $fps = $4; $::widgets->{'menc_fps'}->set_text($4) }
+ if ( $6 ne $size ) { $size = $6; $::widgets->{'menc_filesize'}->set_text($6) }