summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2016-06-04 21:14:04 +0300
committerPatrice Clement <monsieurp@gentoo.org>2016-06-28 17:38:28 +0000
commit9b67e059e10ded2f3f0e562c2c9c6457ae31f8c1 (patch)
tree485d68f5784f2938561e63f527ed6a6178f7e7a4 /media-video/aegisub
parentmedia-video/aegisub: verbump to 3.2.2_p20160518 (diff)
downloadgentoo-9b67e059e10ded2f3f0e562c2c9c6457ae31f8c1.tar.gz
gentoo-9b67e059e10ded2f3f0e562c2c9c6457ae31f8c1.tar.bz2
gentoo-9b67e059e10ded2f3f0e562c2c9c6457ae31f8c1.zip
media-video/aegisub: sync 9999 with the latest snapshot ebuild
Package-Manager: portage-2.3.0_rc1 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'media-video/aegisub')
-rw-r--r--media-video/aegisub/aegisub-9999.ebuild77
1 files changed, 44 insertions, 33 deletions
diff --git a/media-video/aegisub/aegisub-9999.ebuild b/media-video/aegisub/aegisub-9999.ebuild
index d8665bb5e540..cca360224995 100644
--- a/media-video/aegisub/aegisub-9999.ebuild
+++ b/media-video/aegisub/aegisub-9999.ebuild
@@ -2,69 +2,65 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-AUTOTOOLS_AUTORECONF=1
-AUTOTOOLS_IN_SOURCE_BUILD=1
-PLOCALES="ar bg ca cs da de el es eu fa fi fr_FR gl hu id it ja ko nl pl pt_BR pt_PT ru sr_RS@latin sr_RS uk_UA vi zh_CN zh_TW"
-WX_GTK_VER="3.0"
+WX_GTK_VER=3.0
+PLOCALES="ar bg ca cs da de el es eu fa fi fr_FR gl hu id it ja ko nl pl pt_BR pt_PT ru sr_RS sr_RS@latin uk_UA vi zh_CN zh_TW"
-inherit autotools-utils fdo-mime flag-o-matic gnome2-utils l10n wxwidgets git-r3
+inherit autotools fdo-mime flag-o-matic gnome2-utils l10n wxwidgets git-r3
DESCRIPTION="Advanced subtitle editor"
-HOMEPAGE="http://www.aegisub.org/"
+HOMEPAGE="http://www.aegisub.org/ https://github.com/Aegisub/Aegisub"
EGIT_REPO_URI="git://github.com/Aegisub/Aegisub.git"
+# Submodules are used to pull bundled libraries.
+EGIT_SUBMODULES=()
-LICENSE="BSD"
+LICENSE="BSD MIT"
SLOT="0"
KEYWORDS=""
-IUSE="alsa debug +ffmpeg +fftw openal oss portaudio pulseaudio spell +uchardet"
+IUSE="alsa debug +fftw openal oss portaudio pulseaudio spell test +uchardet"
-# configure.ac specifies minimal versions for some of the dependencies below.
-# However, most of these minimal versions date back to 2006-2012 yy.
-# Such version specifiers are meaningless nowadays, so they are omitted.
-#
# aegisub bundles luabins (https://github.com/agladysh/luabins).
# Unfortunately, luabins upstream is practically dead since 2010.
-# Thus unbundling luabins is not worth the effort.
+# Thus unbundling luabins isn't worth the effort.
RDEPEND="
+ x11-libs/wxGTK:${WX_GTK_VER}[X,opengl,debug?]
dev-lang/luajit:2[lua52compat]
dev-libs/boost:=[icu,nls,threads]
dev-libs/icu:=
+ media-libs/ffmpegsource:=
media-libs/fontconfig
media-libs/freetype
media-libs/libass:=[fontconfig]
+ sys-libs/zlib
virtual/libiconv
virtual/opengl
- x11-libs/wxGTK:${WX_GTK_VER}[X,opengl,debug?]
-
alsa? ( media-libs/alsa-lib )
+ fftw? ( >=sci-libs/fftw-3.3:= )
openal? ( media-libs/openal )
portaudio? ( =media-libs/portaudio-19* )
pulseaudio? ( media-sound/pulseaudio )
-
- ffmpeg? ( media-libs/ffmpegsource:= )
- fftw? ( >=sci-libs/fftw-3.3:= )
-
spell? ( app-text/hunspell )
uchardet? ( dev-libs/uchardet )
"
DEPEND="${RDEPEND}
- oss? ( virtual/os-headers )
dev-util/intltool
sys-devel/gettext
virtual/pkgconfig
-"
-REQUIRED_USE="
- || ( alsa openal oss portaudio pulseaudio )
+ oss? ( virtual/os-headers )
+ test? (
+ ~dev-cpp/gtest-1.7.0
+ dev-lua/busted
+ dev-lua/luarocks
+ )
"
-# submodules are used to pull in bundled libraries
-EGIT_SUBMODULES=()
+REQUIRED_USE="|| ( alsa openal oss portaudio pulseaudio )"
PATCHES=(
- "${FILESDIR}/${PN}-3.2.2_p20160306-fix-luajit-unbundling.patch"
- "${FILESDIR}/${PN}-3.2.2_p20160306-respect-user-compiler-flags.patch"
+ "${FILESDIR}/3.2.2_p20160518/${PN}-3.2.2_p20160518-fix-system-luajit-build.patch"
+ "${FILESDIR}/3.2.2_p20160518/${PN}-3.2.2_p20160518-respect-compiler-flags.patch"
+ "${FILESDIR}/3.2.2_p20160518/${PN}-3.2.2_p20160518-support-system-gtest.patch"
)
pkg_pretend() {
@@ -74,6 +70,11 @@ pkg_pretend() {
}
src_prepare() {
+ default_src_prepare
+
+ # Remove tests that require unavailable uuid Lua module.
+ rm automation/tests/modules/lfs.moon || die
+
remove_locale() {
rm "po/${1}.po" || die
}
@@ -82,20 +83,21 @@ src_prepare() {
l10n_for_each_disabled_locale_do remove_locale
# See http://devel.aegisub.org/ticket/1914
- config_rpath_update "${S}/config.rpath"
+ config_rpath_update "${S}"/config.rpath
- autotools-utils_src_prepare
+ eautoreconf
}
src_configure() {
- # Prevent sandbox violation from OpenAL detection. Gentoo bug #508184.
+ # Prevent access violations from OpenAL detection. See Gentoo bug 508184.
use openal && export agi_cv_with_openal="yes"
+
local myeconfargs=(
--disable-update-checker
+ --with-ffms2
--with-system-luajit
$(use_enable debug)
$(use_with alsa)
- $(use_with ffmpeg ffms2)
$(use_with fftw fftw3)
$(use_with openal)
$(use_with oss)
@@ -104,7 +106,16 @@ src_configure() {
$(use_with spell hunspell)
$(use_with uchardet)
)
- autotools-utils_src_configure
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake WITH_SYSTEM_GTEST=$(usex test)
+}
+
+src_test() {
+ emake test-automation
+ emake test-libaegisub
}
pkg_preinst() {