summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-13 14:20:33 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-13 14:20:33 +0100
commiteb72148f88dcde91858b0db9b95ad7d7b1e61256 (patch)
tree9e30604b0339499a45e7edf9adb4344cc58d5438 /media-video/alevt/files
parentmedia-video/chaplin: Port to EAPI 7 (diff)
downloadgentoo-eb72148f88dcde91858b0db9b95ad7d7b1e61256.tar.gz
gentoo-eb72148f88dcde91858b0db9b95ad7d7b1e61256.tar.bz2
gentoo-eb72148f88dcde91858b0db9b95ad7d7b1e61256.zip
media-video/alevt: Port to EAPI 7
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-video/alevt/files')
-rw-r--r--media-video/alevt/files/alevt-1.6.2-libpng15.patch4
-rw-r--r--media-video/alevt/files/alevt-1.6.2-respectflags.patch23
2 files changed, 20 insertions, 7 deletions
diff --git a/media-video/alevt/files/alevt-1.6.2-libpng15.patch b/media-video/alevt/files/alevt-1.6.2-libpng15.patch
index 337a6f7c709f..a134fd014051 100644
--- a/media-video/alevt/files/alevt-1.6.2-libpng15.patch
+++ b/media-video/alevt/files/alevt-1.6.2-libpng15.patch
@@ -1,5 +1,5 @@
---- exp-gfx.c
-+++ exp-gfx.c
+--- a/exp-gfx.c
++++ b/exp-gfx.c
@@ -4,6 +4,8 @@
#include <stdlib.h>
#include <string.h>
diff --git a/media-video/alevt/files/alevt-1.6.2-respectflags.patch b/media-video/alevt/files/alevt-1.6.2-respectflags.patch
index 368b0ff614cd..62716d0e8f43 100644
--- a/media-video/alevt/files/alevt-1.6.2-respectflags.patch
+++ b/media-video/alevt/files/alevt-1.6.2-respectflags.patch
@@ -1,21 +1,25 @@
---- alevt-1.6.2/Makefile.orig 2007-12-03 06:19:54.000000000 +0100
-+++ alevt-1.6.2/Makefile 2009-05-14 10:17:39.000000000 +0200
+--- a/Makefile
++++ b/Makefile
@@ -1,5 +1,4 @@
VER=1.6.2
-OPT=-O2 -s -w
#OPT=-O -g
DEFS=-DWITH_PNG
FONT=vtxt
-@@ -11,7 +10,7 @@
+@@ -7,11 +6,10 @@
+ #USR_X11R6=/usr
+ MAN_DIR=man
+ #MAN_DIR=share/man
+-HOSTCC=$(CC)
# a smaller and thinner font
#FONT=neep9
-CFLAGS=$(OPT) -DVERSION=\"$(VER)\" $(DEFS) -I$(USR_X11R6)/include
-+CFLAGS += -DVERSION=\"$(VER)\" $(DEFS) -I$(USR_X11R6)/include
++CPPFLAGS += -DVERSION=\"$(VER)\" $(DEFS) -I$(USR_X11R6)/include
EXPOBJS=export.o exp-txt.o exp-html.o exp-gfx.o font.o
OBJS=main.o ui.o xio.o fdset.o vbi.o cache.o help.o edline.o search.o edit.o misc.o hamm.o lang.o $(EXPOBJS)
-@@ -25,13 +24,13 @@
+@@ -25,13 +23,13 @@
all: alevt alevt-date alevt-cap alevt.1x alevt-date.1 alevt-cap.1
alevt: $(OBJS)
@@ -32,3 +36,12 @@
font.o: font1.xbm font2.xbm
fontsize.h: font1.xbm font2.xbm
+@@ -44,7 +42,7 @@
+ ./bdf2xbm font2 <$(FONT)-latin-2.bdf >font2.xbm
+
+ bdf2xbm: bdf2xbm.c
+- $(HOSTCC) bdf2xbm.c -o bdf2xbm
++ $(BUILD_CC) bdf2xbm.c -o bdf2xbm
+
+ alevt.1x: alevt.1x.in
+ sed s/VERSION/$(VER)/g <alevt.1x.in >alevt.1x