summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-08-26 09:26:51 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-08-26 10:51:25 +0200
commit2bd95e189e829f2282bea13b6d7b67c2b256ed6a (patch)
tree69108ddf8ce1a8744899dfa82fc8fd80a1a34094 /media-video/ccextractor
parentapp-portage/repo-commit: Remove support for non-existent deps (diff)
downloadgentoo-2bd95e189e829f2282bea13b6d7b67c2b256ed6a.tar.gz
gentoo-2bd95e189e829f2282bea13b6d7b67c2b256ed6a.tar.bz2
gentoo-2bd95e189e829f2282bea13b6d7b67c2b256ed6a.zip
media-video/ccextractor: EAPI-6 bump, HOMEPAGE, cleanup
Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'media-video/ccextractor')
-rw-r--r--media-video/ccextractor/ccextractor-0.85-r1.ebuild16
-rw-r--r--media-video/ccextractor/files/ccextractor-0.85-cmake.patch (renamed from media-video/ccextractor/files/ccextractor-0.85-makefile.patch)8
2 files changed, 9 insertions, 15 deletions
diff --git a/media-video/ccextractor/ccextractor-0.85-r1.ebuild b/media-video/ccextractor/ccextractor-0.85-r1.ebuild
index 35c0f63e14fe..aad1f505d1f3 100644
--- a/media-video/ccextractor/ccextractor-0.85-r1.ebuild
+++ b/media-video/ccextractor/ccextractor-0.85-r1.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-inherit eutils toolchain-funcs cmake-utils
+inherit cmake-utils toolchain-funcs
DESCRIPTION="Extract closed captioning subtitles from video to SRT"
-HOMEPAGE="http://ccextractor.sourceforge.net/"
+HOMEPAGE="https://www.ccextractor.org/"
SRC_URI="mirror://sourceforge/ccextractor/${PN}-src-nowin.${PV}.zip"
LICENSE="GPL-2"
@@ -24,10 +24,4 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${PN}/src"
-PATCHES=(
- "${FILESDIR}/${P}-makefile.patch"
-)
-
-src_prepare() {
- cmake-utils_src_prepare
-}
+PATCHES=( "${FILESDIR}/${P}-cmake.patch" )
diff --git a/media-video/ccextractor/files/ccextractor-0.85-makefile.patch b/media-video/ccextractor/files/ccextractor-0.85-cmake.patch
index 6937869180de..2fcf6cfee4b0 100644
--- a/media-video/ccextractor/files/ccextractor-0.85-makefile.patch
+++ b/media-video/ccextractor/files/ccextractor-0.85-cmake.patch
@@ -1,5 +1,5 @@
---- ccextractor/src/CMakeLists.txt.orig 2017-07-25 12:22:29.294144514 -0600
-+++ ccextractor/src/CMakeLists.txt 2017-07-25 12:23:33.979149436 -0600
+--- a/CMakeLists.txt 2017-07-25 12:22:29.294144514 -0600
++++ b/CMakeLists.txt 2017-07-25 12:23:33.979149436 -0600
@@ -25,14 +25,13 @@
include_directories ("${PROJECT_SOURCE_DIR}/protobuf-c/")
include_directories ("${PROJECT_SOURCE_DIR}/zvbi")
@@ -43,8 +43,8 @@
########################################################
# Build using FFmpeg libraries
---- ccextractor/src/lib_ccx/CMakeLists.txt.orig 2017-07-25 12:32:32.803190443 -0600
-+++ ccextractor/src/lib_ccx/CMakeLists.txt 2017-07-25 12:25:40.819159089 -0600
+--- a/lib_ccx/CMakeLists.txt 2017-07-25 12:32:32.803190443 -0600
++++ b/lib_ccx/CMakeLists.txt 2017-07-25 12:25:40.819159089 -0600
@@ -1,6 +1,6 @@
cmake_policy (SET CMP0037 NEW)