summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-13 14:20:30 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-13 14:20:30 +0100
commita897cac662882061932a1a48a9c6de465fea15f5 (patch)
tree4da4f854b829be34344e54ac8e85df2f406d246d /media-video/chaplin
parentmedia-tv/ivtv-utils: Port to EAPI 7 (diff)
downloadgentoo-a897cac662882061932a1a48a9c6de465fea15f5.tar.gz
gentoo-a897cac662882061932a1a48a9c6de465fea15f5.tar.bz2
gentoo-a897cac662882061932a1a48a9c6de465fea15f5.zip
media-video/chaplin: Port to EAPI 7
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-video/chaplin')
-rw-r--r--media-video/chaplin/chaplin-1.10-r2.ebuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/media-video/chaplin/chaplin-1.10-r2.ebuild b/media-video/chaplin/chaplin-1.10-r2.ebuild
index 452d808b53e7..0e12d020955d 100644
--- a/media-video/chaplin/chaplin-1.10-r2.ebuild
+++ b/media-video/chaplin/chaplin-1.10-r2.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-inherit eutils toolchain-funcs
+EAPI=7
+
+inherit toolchain-funcs
DESCRIPTION="This is a program to raw copy chapters from a dvd using libdvdread"
HOMEPAGE="http://www.lallafa.de/bp/chaplin.html"
@@ -17,15 +18,15 @@ DEPEND=">=media-libs/libdvdread-0.9.4"
RDEPEND="${DEPEND}
virtual/imagemagick-tools
media-video/mjpegtools
- transcode? ( >=media-video/transcode-0.6.2 )
- vcd? ( >=media-video/vcdimager-0.7.2 )"
+ transcode? ( media-video/transcode )
+ vcd? ( media-video/vcdimager )"
S=${WORKDIR}/${PN}
-src_prepare() {
- epatch "${FILESDIR}"/${P}-libdvdread-0.9.6.patch \
- "${FILESDIR}"/${P}-asneeded.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-libdvdread-0.9.6.patch
+ "${FILESDIR}"/${P}-asneeded.patch
+)
src_compile() {
emake CC="$(tc-getCC)"