summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2017-08-13 10:07:40 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2017-08-13 11:50:56 +0200
commit885cc1b620dd333e403815eddde273de88399dbe (patch)
treed320191fe1f7e5b1b513f0929db59d5a18e7091a /media-video/cheese/cheese-3.24.0.ebuild
parentdev-perl/WWW-Form-UrlEncoded: keyworded 0.240.0 for ppc, bug #613376 (diff)
downloadgentoo-885cc1b620dd333e403815eddde273de88399dbe.tar.gz
gentoo-885cc1b620dd333e403815eddde273de88399dbe.tar.bz2
gentoo-885cc1b620dd333e403815eddde273de88399dbe.zip
media-video/cheese: version bump 3.22.1 → 3.24.0
Do not hardcode video format, negotiate best one. Translation updates. Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'media-video/cheese/cheese-3.24.0.ebuild')
-rw-r--r--media-video/cheese/cheese-3.24.0.ebuild76
1 files changed, 76 insertions, 0 deletions
diff --git a/media-video/cheese/cheese-3.24.0.ebuild b/media-video/cheese/cheese-3.24.0.ebuild
new file mode 100644
index 000000000000..3fade1b47ba0
--- /dev/null
+++ b/media-video/cheese/cheese-3.24.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+VALA_MIN_API_VERSION="0.26"
+
+inherit gnome2 vala virtualx
+
+DESCRIPTION="A cheesy program to take pictures and videos from your webcam"
+HOMEPAGE="https://wiki.gnome.org/Apps/Cheese"
+
+LICENSE="GPL-2+"
+SLOT="0/8" # subslot = libcheese soname version
+IUSE="+introspection test"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.39.90:2
+ >=x11-libs/gtk+-3.13.4:3[introspection?]
+ >=gnome-base/gnome-desktop-2.91.6:3=
+ >=media-libs/libcanberra-0.26[gtk3]
+ >=media-libs/clutter-1.13.2:1.0[introspection?]
+ >=media-libs/clutter-gtk-0.91.8:1.0
+ media-libs/clutter-gst:3.0
+ media-libs/cogl:1.0=[introspection?]
+
+ media-video/gnome-video-effects
+ x11-libs/gdk-pixbuf:2[jpeg,introspection?]
+ x11-libs/libX11
+ x11-libs/libXtst
+
+ >=media-libs/gstreamer-1.4:1.0[introspection?]
+ >=media-libs/gst-plugins-base-1.4:1.0[introspection?,ogg,pango,theora,vorbis,X]
+
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=media-libs/gst-plugins-bad-1.4:1.0
+ >=media-libs/gst-plugins-good-1.4:1.0
+
+ >=media-plugins/gst-plugins-jpeg-1.4:1.0
+ >=media-plugins/gst-plugins-v4l2-1.4:1.0
+ >=media-plugins/gst-plugins-vpx-1.4:1.0
+"
+DEPEND="${COMMON_DEPEND}
+ $(vala_depend)
+ app-text/docbook-xml-dtd:4.3
+ app-text/yelp-tools
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ dev-util/gdbus-codegen
+ >=dev-util/gtk-doc-am-1.14
+ >=dev-util/intltool-0.50
+ dev-util/itstool
+ virtual/pkgconfig
+ x11-proto/xf86vidmodeproto
+ test? ( dev-libs/glib:2[utils] )
+"
+
+src_prepare() {
+ vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ GST_INSPECT=$(type -P true) \
+ $(use_enable introspection) \
+ --disable-lcov \
+ --disable-static
+}
+
+src_test() {
+ virtx emake check
+}