summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-08-03 14:13:02 +0300
committerMart Raudsepp <leio@gentoo.org>2018-08-03 14:45:30 +0300
commit8a7a6747ba0b55f7d32088ffc9e29bf1043d5e42 (patch)
tree08c41930812e437401023bfc7b6809b65d145be8 /media-video/cheese
parentapp-misc/bijiben: bump to 3.26.1 (diff)
downloadgentoo-8a7a6747ba0b55f7d32088ffc9e29bf1043d5e42.tar.gz
gentoo-8a7a6747ba0b55f7d32088ffc9e29bf1043d5e42.tar.bz2
gentoo-8a7a6747ba0b55f7d32088ffc9e29bf1043d5e42.zip
media-video/cheese: bump to 3.28.0, remove unnecessary vala dep
Remove unnecessary vala dep; tarball comes with pregenerated C and does not even use valac as we build it (as C code is present and regeneration with system vala version is not triggered). Also workaround unnecessary glib[utils] requirement: upstream configure checks for gtester-report and disables tests as a whole when not found, when actually the default "make check" target doesn't use it; thus just make the configure check be happy without gtester-report present and remove the USE dep. Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'media-video/cheese')
-rw-r--r--media-video/cheese/Manifest1
-rw-r--r--media-video/cheese/cheese-3.28.0.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/media-video/cheese/Manifest b/media-video/cheese/Manifest
index 2ed89583559a..f12a10ba1e4b 100644
--- a/media-video/cheese/Manifest
+++ b/media-video/cheese/Manifest
@@ -1 +1,2 @@
DIST cheese-3.24.0.tar.xz 1846412 BLAKE2B bc18ee7009f4297df232c0ffdc40f5783891f721efe137e4127c7ea61595dcb033e98b415ea31e5918d93c408355e6534ddd95687a570b5abcc1c5ce0603d262 SHA512 c81d2f3038970f735960a2cbcec3a074ac2e9835d3f1fa6aae83d65299692d0464fed274e71caa59831a105430ce5db56557ea0cda27c72cdb050a59331b3107
+DIST cheese-3.28.0.tar.xz 1544904 BLAKE2B cdad63b4175bb52c3a77ee5ed0058afdd8b5d509ef17b5931d2f01457b9ff327d3ad270ad963e3185c928ddc7203b00163137a789683669d3f8c39d5a9926da8 SHA512 c52b083b132a8c885df55def3d6bf96180fc93c8b7368f48412c8dd63e073a268ff0e86959a977bd8bf372a53e127419b96046d92cb3a96674f86cfb3477ceea
diff --git a/media-video/cheese/cheese-3.28.0.ebuild b/media-video/cheese/cheese-3.28.0.ebuild
new file mode 100644
index 000000000000..8b870aafa450
--- /dev/null
+++ b/media-video/cheese/cheese-3.28.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2 virtualx
+
+DESCRIPTION="A cheesy program to take pictures and videos from your webcam"
+HOMEPAGE="https://wiki.gnome.org/Apps/Cheese"
+
+LICENSE="GPL-2+"
+SLOT="0/8" # subslot = libcheese soname version
+IUSE="+introspection"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.39.90:2
+ >=x11-libs/gtk+-3.13.4:3[introspection?]
+ >=gnome-base/gnome-desktop-2.91.6:3=
+ >=media-libs/libcanberra-0.26[gtk3]
+ >=media-libs/clutter-1.13.2:1.0[introspection?]
+ >=media-libs/clutter-gtk-0.91.8:1.0
+ media-libs/clutter-gst:3.0
+ media-libs/cogl:1.0=[introspection?]
+
+ media-video/gnome-video-effects
+ x11-libs/gdk-pixbuf:2[jpeg,introspection?]
+ x11-libs/libX11
+ x11-libs/libXtst
+
+ >=media-libs/gstreamer-1.4:1.0[introspection?]
+ >=media-libs/gst-plugins-base-1.4:1.0[introspection?,ogg,pango,theora,vorbis,X]
+
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=media-libs/gst-plugins-bad-1.4:1.0
+ >=media-libs/gst-plugins-good-1.4:1.0
+
+ >=media-plugins/gst-plugins-jpeg-1.4:1.0
+ >=media-plugins/gst-plugins-v4l2-1.4:1.0
+ >=media-plugins/gst-plugins-vpx-1.4:1.0
+"
+# libxml2+gdk-pixbuf required for glib-compile-resources
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.3
+ app-text/yelp-tools
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ >=dev-util/gtk-doc-am-1.14
+ >=dev-util/intltool-0.50
+ dev-util/itstool
+ virtual/pkgconfig
+ x11-base/xorg-proto
+"
+
+src_configure() {
+ gnome2_src_configure \
+ GST_INSPECT=$(type -P true) \
+ GTESTER_REPORT=$(type -P true) \
+ VALAC=$(type -P true) \
+ $(use_enable introspection) \
+ --disable-lcov \
+ --disable-static
+}
+
+src_test() {
+ "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
+ GSETTINGS_SCHEMA_DIR="${S}/data" virtx emake check
+}