summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/devede
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/devede')
-rw-r--r--media-video/devede/Manifest4
-rw-r--r--media-video/devede/devede-3.16.9.ebuild53
-rw-r--r--media-video/devede/devede-3.21.0.ebuild56
-rw-r--r--media-video/devede/devede-3.22.0.ebuild56
-rw-r--r--media-video/devede/devede-3.23.0.ebuild54
-rw-r--r--media-video/devede/metadata.xml14
6 files changed, 237 insertions, 0 deletions
diff --git a/media-video/devede/Manifest b/media-video/devede/Manifest
new file mode 100644
index 000000000000..e779a33d2579
--- /dev/null
+++ b/media-video/devede/Manifest
@@ -0,0 +1,4 @@
+DIST devede-3.16.9.tar.bz2 2368434 SHA256 eccaba86893935ff898e7b26d772214403362a6c8d729645778146560c1ac0c1
+DIST devede-3.21.0.tar.bz2 2536646 SHA256 a892f257ac284dc6f3b0fcfe56813e26a8c86c627747a27046991892c19704ac
+DIST devede-3.22.0.tar.bz2 2559428 SHA256 7966e46c76f6c180ead33ec57844ef2efb7a8139123da59e0cc3044c8ebb4572 SHA512 5212545bc8a16987bfd4894e65c66cff1259012f529097b13ced32d54e833e7e9e4a2f500ebbca37a4c174c6507ca99575038cb4fe53e15693fca78beda883b4 WHIRLPOOL 507d69ff04d703bd05145ce289526a0cfd33279eabeece2bf07697ecf1bdde3766bd090f01d93b352df1e767cf5ef2f73e838175e77200d51034fcf73ac221c6
+DIST devede-3.23.0.tar.bz2 2680546 SHA256 9e217ca46f5f275cb0c3cadbe8c830fa1fde774c004bd95a343d1255be6f25e1 SHA512 a1b634ca8d546b56db11a9d61c9086a822d415e0fa4f77ea702aaad20254afb70ca719595b7b6ba783797bd2335ccedca9b80288e8d0fdd6beb7b1b7ad3f85d5 WHIRLPOOL 6473d4a0f0bc0acabe7d269df2b62034648e5bcd3f5cedd3403faaae8dba078b5c5ead3ea93de9bca0d0e551fe08fb15a568000cff8c1f94896d606760768c8d
diff --git a/media-video/devede/devede-3.16.9.ebuild b/media-video/devede/devede-3.16.9.ebuild
new file mode 100644
index 000000000000..4a3c13210d92
--- /dev/null
+++ b/media-video/devede/devede-3.16.9.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+PYTHON_DEPEND=2
+
+inherit multilib python
+
+DESCRIPTION="Program to create video CDs and DVDs, suitable to be played in home DVD players"
+HOMEPAGE="http://www.rastersoft.com/programas/devede.html"
+SRC_URI="http://www.rastersoft.com/descargas/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.16:2
+ >=dev-python/pygtk-2.16
+ >=media-video/mplayer-1.0_rc1
+ media-video/dvdauthor
+ media-video/vcdimager
+ virtual/cdrtools"
+DEPEND=""
+
+S=${WORKDIR}/${P%*b}
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ python_convert_shebangs -r 2 .
+}
+
+src_install() {
+ ./install.sh prefix="/usr" libdir="/usr/$(get_libdir)" \
+ pkgdocdir="/usr/share/doc/${PF}" DESTDIR="${D}" \
+ || die "install.sh failed."
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/$(get_libdir)/${PN}
+ elog "To create DIVX/MPEG4 files, be sure that MPlayer is compiled with LAME support."
+ elog "In this case you want to check for both the encode and mp3 USE flags."
+ elog "To change the font used to render the subtitles, choose a TrueType font you like"
+ elog "and copy it in \$HOME/.spumux directory, renaming it to devedesans.ttf."
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/${PN}
+}
diff --git a/media-video/devede/devede-3.21.0.ebuild b/media-video/devede/devede-3.21.0.ebuild
new file mode 100644
index 000000000000..b853f24a18de
--- /dev/null
+++ b/media-video/devede/devede-3.21.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.7"
+
+inherit multilib python
+
+DESCRIPTION="Program to create video CDs and DVDs, suitable to be played in home DVD players"
+HOMEPAGE="http://www.rastersoft.com/programas/devede.html"
+SRC_URI="http://www.rastersoft.com/descargas/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+# from upstream ChangeLog in 3.21.0: Now uses FFMpeg as the default backend
+IUSE="+ffmpeg"
+
+RDEPEND="dev-python/dbus-python
+ dev-python/pycairo
+ dev-python/pygobject:2
+ >=dev-python/pygtk-2.16
+ media-video/dvdauthor
+ media-video/mplayer
+ media-video/vcdimager
+ virtual/cdrtools
+ ffmpeg? ( virtual/ffmpeg[mp3] )"
+DEPEND=""
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_convert_shebangs -r 2 .
+}
+
+src_install() {
+ ./install.sh DESTDIR="${D}" libdir="/usr/$(get_libdir)" \
+ pkgdocdir=/usr/share/doc/${PF} prefix=/usr || die
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/$(get_libdir)/${PN}
+ elog "To create DIVX/MPEG4 files, be sure that MPlayer is compiled with LAME support."
+ elog "In this case you want to check for both the encode and mp3 USE flags."
+ elog "To change the font used to render the subtitles, choose a TrueType font you like"
+ elog "and copy it in \$HOME/.spumux directory, renaming it to devedesans.ttf."
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/${PN}
+}
diff --git a/media-video/devede/devede-3.22.0.ebuild b/media-video/devede/devede-3.22.0.ebuild
new file mode 100644
index 000000000000..d1dbe3e9d932
--- /dev/null
+++ b/media-video/devede/devede-3.22.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.7"
+
+inherit multilib python
+
+DESCRIPTION="Program to create video CDs and DVDs, suitable to be played in home DVD players"
+HOMEPAGE="http://www.rastersoft.com/programas/devede.html"
+SRC_URI="http://www.rastersoft.com/descargas/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# from upstream ChangeLog in 3.21.0: Now uses FFMpeg as the default backend
+IUSE="+ffmpeg"
+
+RDEPEND="dev-python/dbus-python
+ dev-python/pycairo
+ dev-python/pygobject:2
+ >=dev-python/pygtk-2.16
+ media-video/dvdauthor
+ media-video/mplayer
+ media-video/vcdimager
+ virtual/cdrtools
+ ffmpeg? ( virtual/ffmpeg[mp3] )"
+DEPEND=""
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_convert_shebangs -r 2 .
+}
+
+src_install() {
+ ./install.sh DESTDIR="${D}" libdir="/usr/$(get_libdir)" \
+ pkgdocdir=/usr/share/doc/${PF} prefix=/usr || die
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/$(get_libdir)/${PN}
+ elog "To create DIVX/MPEG4 files, be sure that MPlayer is compiled with LAME support."
+ elog "In this case you want to check for both the encode and mp3 USE flags."
+ elog "To change the font used to render the subtitles, choose a TrueType font you like"
+ elog "and copy it in \$HOME/.spumux directory, renaming it to devedesans.ttf."
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/${PN}
+}
diff --git a/media-video/devede/devede-3.23.0.ebuild b/media-video/devede/devede-3.23.0.ebuild
new file mode 100644
index 000000000000..3ad27065281c
--- /dev/null
+++ b/media-video/devede/devede-3.23.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.7"
+
+inherit multilib python
+
+DESCRIPTION="Program to create video CDs and DVDs, suitable to be played in home DVD players"
+HOMEPAGE="http://www.rastersoft.com/programas/devede.html"
+SRC_URI="http://www.rastersoft.com/descargas/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="-mencoder"
+
+RDEPEND="dev-python/dbus-python
+ dev-python/pycairo
+ dev-python/pygobject:2
+ >=dev-python/pygtk-2.16
+ media-video/dvdauthor
+ mencoder? ( media-video/mplayer[mp3,encode] )
+ media-video/vcdimager
+ virtual/cdrtools
+ !mencoder? ( virtual/ffmpeg[mp3,encode]
+ || ( media-video/mplayer2[symlink] media-video/mplayer ) )"
+DEPEND=""
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_convert_shebangs -r 2 .
+}
+
+src_install() {
+ ./install.sh DESTDIR="${D}" libdir="/usr/$(get_libdir)" \
+ pkgdocdir=/usr/share/doc/${PF} prefix=/usr || die
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/$(get_libdir)/${PN}
+ elog "To change the font used to render the subtitles, choose a TrueType font you like"
+ elog "and copy it in \$HOME/.spumux directory, renaming it to devedesans.ttf."
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/${PN}
+}
diff --git a/media-video/devede/metadata.xml b/media-video/devede/metadata.xml
new file mode 100644
index 000000000000..d893518b9d6b
--- /dev/null
+++ b/media-video/devede/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+ <maintainer>
+ <email>media-video@gentoo.org</email>
+ </maintainer>
+
+ <use>
+ <flag name="mencoder">
+ Prefer MPlayer mencoder over Libav avconv or FFmpeg ffmpeg for encoding.
+ </flag>
+ </use>
+</pkgmetadata>