summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/dvdimagecmp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/dvdimagecmp')
-rw-r--r--media-video/dvdimagecmp/Manifest1
-rw-r--r--media-video/dvdimagecmp/dvdimagecmp-0.3-r1.ebuild31
-rw-r--r--media-video/dvdimagecmp/files/dvdimagecmp-0.3.diff23
-rw-r--r--media-video/dvdimagecmp/metadata.xml8
4 files changed, 63 insertions, 0 deletions
diff --git a/media-video/dvdimagecmp/Manifest b/media-video/dvdimagecmp/Manifest
new file mode 100644
index 000000000000..d3cb2b047c3f
--- /dev/null
+++ b/media-video/dvdimagecmp/Manifest
@@ -0,0 +1 @@
+DIST dvdimagecmp-0.3.tgz 10483 RMD160 19ae3eff959e3367f5e31db6e004441476647f1d SHA1 56c63ea845ad85e77f693c6765a6ca40d7ec1388 SHA256 453df95038dfa7cf5de679323d82963f62adbf39b72cc863542a05ae1dba25a1
diff --git a/media-video/dvdimagecmp/dvdimagecmp-0.3-r1.ebuild b/media-video/dvdimagecmp/dvdimagecmp-0.3-r1.ebuild
new file mode 100644
index 000000000000..002e11a4f4e8
--- /dev/null
+++ b/media-video/dvdimagecmp/dvdimagecmp-0.3-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs flag-o-matic
+
+IUSE=""
+
+DESCRIPTION="Tool to compare a burned DVD with an image to check for errors"
+HOMEPAGE="http://panteltje.com/panteltje/dvd/"
+SRC_URI="http://panteltje.com/panteltje/dvd/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}.diff"
+}
+
+src_compile() {
+ append-flags -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dobin dvdimagecmp
+ dodoc CHANGES README
+}
diff --git a/media-video/dvdimagecmp/files/dvdimagecmp-0.3.diff b/media-video/dvdimagecmp/files/dvdimagecmp-0.3.diff
new file mode 100644
index 000000000000..95917293c130
--- /dev/null
+++ b/media-video/dvdimagecmp/files/dvdimagecmp-0.3.diff
@@ -0,0 +1,23 @@
+diff -Naur dvdimagecmp-0.3.orig/dvdimagecmp.c dvdimagecmp-0.3/dvdimagecmp.c
+--- dvdimagecmp-0.3.orig/dvdimagecmp.c 2005-01-04 14:54:52.000000000 +0100
++++ dvdimagecmp-0.3/dvdimagecmp.c 2007-10-06 15:36:34.000000000 +0200
+@@ -33,6 +33,7 @@
+ #include <errno.h>
+ #include <ctype.h>
+ #include <time.h>
++#include <string.h>
+
+ #define MAX_RETRIES 1
+ #define BUFFER_SIZE 2048*16
+diff -Naur dvdimagecmp-0.3.orig/Makefile dvdimagecmp-0.3/Makefile
+--- dvdimagecmp-0.3.orig/Makefile 2005-01-04 14:54:52.000000000 +0100
++++ dvdimagecmp-0.3/Makefile 2007-10-06 15:36:59.000000000 +0200
+@@ -13,7 +13,7 @@
+ # -ltermcap
+
+ a.out : $(OBJECT)
+- $(CC) -o dvdimagecmp $(OBJECT)
++ $(CC) $(LDFLAGS) -o dvdimagecmp $(OBJECT)
+
+ # DEPENDENCIES
+
diff --git a/media-video/dvdimagecmp/metadata.xml b/media-video/dvdimagecmp/metadata.xml
new file mode 100644
index 000000000000..edccfe5754d2
--- /dev/null
+++ b/media-video/dvdimagecmp/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>video</herd>
+<maintainer>
+<email>media-video@gentoo.org</email>
+</maintainer>
+</pkgmetadata>