summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorfhlfibh <fhlfibh@gmail.com>2017-01-26 23:45:01 +0300
committerAlexis Ballier <aballier@gentoo.org>2017-01-26 22:36:48 +0100
commit46498555ce3361f0fd0bae5c3cc9736ee54f8396 (patch)
tree467d57244c0ff64085498a2fd2ab957b0cb60de9 /media-video/ffmpeg
parentmail-client/thunderbird: Fix keywords on thunderbird-45.7.0 (diff)
downloadgentoo-46498555ce3361f0fd0bae5c3cc9736ee54f8396.tar.gz
gentoo-46498555ce3361f0fd0bae5c3cc9736ee54f8396.tar.bz2
gentoo-46498555ce3361f0fd0bae5c3cc9736ee54f8396.zip
media-video/ffmpeg: Add USE flag for sofalizer filter
Diffstat (limited to 'media-video/ffmpeg')
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild6
-rw-r--r--media-video/ffmpeg/metadata.xml1
2 files changed, 6 insertions, 1 deletions
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index f0e33df2665e..72c5f07d5b57 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -81,7 +81,7 @@ FFMPEG_FLAG_MAP=(
# libavfilter options
bs2b:libbs2b chromaprint flite:libflite frei0r
fribidi:libfribidi fontconfig ladspa libass truetype:libfreetype
- rubberband:librubberband zimg:libzimg
+ rubberband:librubberband sofalizer:netcdf zimg:libzimg
# libswresample options
libsoxr
# Threads; we only support pthread for now but ffmpeg supports more
@@ -220,6 +220,10 @@ RDEPEND="
samba? ( >=net-fs/samba-3.6.23-r1[${MULTILIB_USEDEP}] )
schroedinger? ( >=media-libs/schroedinger-1.0.11-r1[${MULTILIB_USEDEP}] )
sdl? ( media-libs/libsdl2[sound,video,${MULTILIB_USEDEP}] )
+ sofalizer? (
+ >=sci-libs/netcdf-4.3.2-r1[hdf5,${MULTILIB_USEDEP}]
+ >=sci-libs/hdf5-1.8.18[hl,${MULTILIB_USEDEP}]
+ )
speex? ( >=media-libs/speex-1.2_rc1-r1[${MULTILIB_USEDEP}] )
ssh? ( >=net-libs/libssh-0.5.5[${MULTILIB_USEDEP}] )
truetype? ( >=media-libs/freetype-2.5.0.1:2[${MULTILIB_USEDEP}] )
diff --git a/media-video/ffmpeg/metadata.xml b/media-video/ffmpeg/metadata.xml
index bb1498966a29..85766b4b87da 100644
--- a/media-video/ffmpeg/metadata.xml
+++ b/media-video/ffmpeg/metadata.xml
@@ -49,6 +49,7 @@
<flag name="rubberband">Adds time-stretching and pitch-shifting audio filter based on <pkg>media-libs/rubberband</pkg>.</flag>
<flag name="schroedinger">Enable Dirac video support (an advanced royalty-free video compression format) via libschroedinger (high-speed implementation in C of the Dirac codec).</flag>
<flag name="snappy">Enable <pkg>app-arch/snappy</pkg> support. Required for e.g. Vidvox Hap encoder.</flag>
+ <flag name="sofalizer">Enables Sofalizer filter</flag>
<flag name="ssh">Enable SSH/sftp support via <pkg>net-libs/libssh</pkg>.</flag>
<flag name="twolame">Enables MP2 encoding via <pkg>media-sound/twolame</pkg> as an alternative to the internal encoder.</flag>
<flag name="vpx">Enables vp8 codec support using libvpx: Decoding vp8 does not require this to be enabled but libvpx can also be used for decoding; encoding vp8 requires this useflag to be enabled though.</flag>