summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-01-06 11:18:15 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-01-06 11:18:15 +0100
commit5072324b32ed1d584560f027ba1491d126224f4a (patch)
tree08acd91f73cb56816a877ad278945afdbad0f9a9 /media-video/ffmpeg
parentmedia-sound/sonic-visualiser: bump to 2.5, bug #568674 (diff)
downloadgentoo-5072324b32ed1d584560f027ba1491d126224f4a.tar.gz
gentoo-5072324b32ed1d584560f027ba1491d126224f4a.tar.bz2
gentoo-5072324b32ed1d584560f027ba1491d126224f4a.zip
media-video/ffmpeg: set optflags to CFLAGS.
Avoids e.g. having -march detection override user settings. Bug #567776. Package-Manager: portage-2.2.26 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'media-video/ffmpeg')
-rw-r--r--media-video/ffmpeg/ffmpeg-2.8.4.ebuild2
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild2
2 files changed, 2 insertions, 2 deletions
diff --git a/media-video/ffmpeg/ffmpeg-2.8.4.ebuild b/media-video/ffmpeg/ffmpeg-2.8.4.ebuild
index efc3bc99680f..3cb20b46457f 100644
--- a/media-video/ffmpeg/ffmpeg-2.8.4.ebuild
+++ b/media-video/ffmpeg/ffmpeg-2.8.4.ebuild
@@ -411,7 +411,7 @@ multilib_src_configure() {
--cc="$(tc-getCC)" \
--cxx="$(tc-getCXX)" \
--ar="$(tc-getAR)" \
- --optflags=" " \
+ --optflags="${CFLAGS}" \
$(use_enable static-libs static) \
"${myconf[@]}"
echo "${@}"
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index 2918e4bd7cab..ef2f4d1d8b35 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -427,7 +427,7 @@ multilib_src_configure() {
--cc="$(tc-getCC)" \
--cxx="$(tc-getCXX)" \
--ar="$(tc-getAR)" \
- --optflags=" " \
+ --optflags="${CFLAGS}" \
$(use_enable static-libs static) \
"${myconf[@]}"
echo "${@}"