summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-24 16:36:12 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-24 16:36:12 +0100
commit50945bef89ecf1f9602071f2e8a7a05a1bcf5988 (patch)
treea9b2102a683a4667896fb79ebaa4d6de8131c7ff /media-video/ffmpeg
parentmedia-libs/libilbc: update to new upstream and add multilib support (diff)
downloadgentoo-50945bef89ecf1f9602071f2e8a7a05a1bcf5988.tar.gz
gentoo-50945bef89ecf1f9602071f2e8a7a05a1bcf5988.tar.bz2
gentoo-50945bef89ecf1f9602071f2e8a7a05a1bcf5988.zip
media-video/ffmpeg: add libilbc useflag
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'media-video/ffmpeg')
-rw-r--r--media-video/ffmpeg/ffmpeg-3.0.ebuild3
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild3
-rw-r--r--media-video/ffmpeg/metadata.xml1
3 files changed, 5 insertions, 2 deletions
diff --git a/media-video/ffmpeg/ffmpeg-3.0.ebuild b/media-video/ffmpeg/ffmpeg-3.0.ebuild
index 1bd22e07850c..9fbf3efe29b6 100644
--- a/media-video/ffmpeg/ffmpeg-3.0.ebuild
+++ b/media-video/ffmpeg/ffmpeg-3.0.ebuild
@@ -75,7 +75,7 @@ FFMPEG_FLAG_MAP=(
# decoders
amr:libopencore-amrwb amr:libopencore-amrnb dcadec:libdcadec fdk:libfdk-aac
jpeg2k:libopenjpeg bluray:libbluray celt:libcelt gme:libgme gsm:libgsm
- mmal modplug:libmodplug opus:libopus librtmp ssh:libssh
+ mmal modplug:libmodplug opus:libopus libilbc librtmp ssh:libssh
schroedinger:libschroedinger speex:libspeex vorbis:libvorbis vpx:libvpx
zvbi:libzvbi
# libavfilter options
@@ -206,6 +206,7 @@ RDEPEND="
jpeg2k? ( >=media-libs/openjpeg-2:2[${MULTILIB_USEDEP}] )
libass? ( >=media-libs/libass-0.10.2[${MULTILIB_USEDEP}] )
libcaca? ( >=media-libs/libcaca-0.99_beta18-r1[${MULTILIB_USEDEP}] )
+ libilbc? ( >=media-libs/libilbc-2[${MULTILIB_USEDEP}] )
libsoxr? ( >=media-libs/soxr-0.1.0[${MULTILIB_USEDEP}] )
libv4l? ( >=media-libs/libv4l-0.9.5[${MULTILIB_USEDEP}] )
lzma? ( >=app-arch/xz-utils-5.0.5-r1[${MULTILIB_USEDEP}] )
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index caeb806b5979..31e83554f745 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -75,7 +75,7 @@ FFMPEG_FLAG_MAP=(
# decoders
amr:libopencore-amrwb amr:libopencore-amrnb dcadec:libdcadec fdk:libfdk-aac
jpeg2k:libopenjpeg bluray:libbluray celt:libcelt gme:libgme gsm:libgsm
- mmal modplug:libmodplug opus:libopus librtmp ssh:libssh
+ mmal modplug:libmodplug opus:libopus libilbc librtmp ssh:libssh
schroedinger:libschroedinger speex:libspeex vorbis:libvorbis vpx:libvpx
zvbi:libzvbi
# libavfilter options
@@ -206,6 +206,7 @@ RDEPEND="
jpeg2k? ( >=media-libs/openjpeg-2:2[${MULTILIB_USEDEP}] )
libass? ( >=media-libs/libass-0.10.2[${MULTILIB_USEDEP}] )
libcaca? ( >=media-libs/libcaca-0.99_beta18-r1[${MULTILIB_USEDEP}] )
+ libilbc? ( >=media-libs/libilbc-2[${MULTILIB_USEDEP}] )
libsoxr? ( >=media-libs/soxr-0.1.0[${MULTILIB_USEDEP}] )
libv4l? ( >=media-libs/libv4l-0.9.5[${MULTILIB_USEDEP}] )
lzma? ( >=app-arch/xz-utils-5.0.5-r1[${MULTILIB_USEDEP}] )
diff --git a/media-video/ffmpeg/metadata.xml b/media-video/ffmpeg/metadata.xml
index 4bcf02a3b269..ce057a06b6a6 100644
--- a/media-video/ffmpeg/metadata.xml
+++ b/media-video/ffmpeg/metadata.xml
@@ -30,6 +30,7 @@
<flag name="hardcoded-tables">Use pre-calculated tables rather than calculating them on the fly.</flag>
<flag name="iec61883"> Support for FireWire DV/HDV input device using <pkg>media-libs/libiec61883</pkg>.</flag>
<flag name="kvazaar">Enables <pkg>media-libs/kvazaar</pkg> based HEVC encoder.</flag>
+ <flag name="libilbc">Enables iLBC de/encoding via <pkg>media-libs/libilbc</pkg>.</flag>
<flag name="librtmp">Enables Real Time Messaging Protocol using librtmp (<pkg>media-video/rtmpdump</pkg>) in addition to FFmpeg's native implementation.</flag>
<flag name="libsoxr">Enables audio resampling through <pkg>media-libs/soxr</pkg>.</flag>
<flag name="libv4l">Uses <pkg>media-libs/libv4l</pkg> for video4linux instead of direct calls. Adds support for more devices via the userspace library.</flag>