summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-11-30 11:50:53 +0100
committerAlexis Ballier <aballier@gentoo.org>2015-11-30 13:00:46 +0100
commit7d5df743aa40b812ceaed2627f3a9547af546d2f (patch)
tree2b67847a2361a38fd1e243aa40c5fe962a9226b5 /media-video/ffmpeg
parentx11-wm/twm: amd64 stable wrt bug #559062 (diff)
downloadgentoo-7d5df743aa40b812ceaed2627f3a9547af546d2f.tar.gz
gentoo-7d5df743aa40b812ceaed2627f3a9547af546d2f.tar.bz2
gentoo-7d5df743aa40b812ceaed2627f3a9547af546d2f.zip
media-video/ffmpeg: Add gmp/gcrypt useflags.
Package-Manager: portage-2.2.26 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'media-video/ffmpeg')
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild11
-rw-r--r--media-video/ffmpeg/metadata.xml1
2 files changed, 10 insertions, 2 deletions
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index 464caa298670..0db4f1fa72c9 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -42,6 +42,10 @@ LICENSE="
gpl? ( GPL-3 )
!gpl? ( LGPL-3 )
)
+ gmp? (
+ gpl? ( GPL-3 )
+ !gpl? ( LGPL-3 )
+ )
encode? (
aac? (
gpl? ( GPL-3 )
@@ -63,8 +67,8 @@ fi
# or $(use_enable foo foo) if no :bar is set.
# foo is added to IUSE.
FFMPEG_FLAG_MAP=(
- +bzip2:bzlib cpudetection:runtime-cpudetect debug doc gnutls +gpl
- +hardcoded-tables +iconv lzma +network openssl +postproc
+ +bzip2:bzlib cpudetection:runtime-cpudetect debug doc gcrypt gnutls gmp
+ +gpl +hardcoded-tables +iconv lzma +network openssl +postproc
samba:libsmbclient sdl:ffplay sdl vaapi vdpau X:xlib xcb:libxcb
xcb:libxcb-shm xcb:libxcb-xfixes +zlib
# libavdevice options
@@ -188,7 +192,9 @@ RDEPEND="
fontconfig? ( >=media-libs/fontconfig-2.10.92[${MULTILIB_USEDEP}] )
frei0r? ( media-plugins/frei0r-plugins )
fribidi? ( >=dev-libs/fribidi-0.19.6[${MULTILIB_USEDEP}] )
+ gcrypt? ( >=dev-libs/libgcrypt-1.6:0=[${MULTILIB_USEDEP}] )
gme? ( >=media-libs/game-music-emu-0.6.0[${MULTILIB_USEDEP}] )
+ gmp? ( >=dev-libs/gmp-6:0=[${MULTILIB_USEDEP}] )
gnutls? ( >=net-libs/gnutls-2.12.23-r6[${MULTILIB_USEDEP}] )
gsm? ( >=media-sound/gsm-1.0.13-r1[${MULTILIB_USEDEP}] )
iconv? ( >=virtual/libiconv-0-r1[${MULTILIB_USEDEP}] )
@@ -342,6 +348,7 @@ multilib_src_configure() {
# Decoders
use amr && myconf+=( --enable-version3 )
+ use gmp && myconf+=( --enable-version3 )
use fdk && use gpl && myconf+=( --enable-nonfree )
for i in "${ffuse[@]#+}" ; do
diff --git a/media-video/ffmpeg/metadata.xml b/media-video/ffmpeg/metadata.xml
index 1bb06e4ba6d4..c39cb9715f75 100644
--- a/media-video/ffmpeg/metadata.xml
+++ b/media-video/ffmpeg/metadata.xml
@@ -24,6 +24,7 @@
<flag name="flite">Adds a text-to-speech filter based on <pkg>app-accessibility/flite</pkg>.</flag>
<flag name="frei0r">Enable frei0r wrapping in libavfilter</flag>
<flag name="fribidi">Enables fribidi support in the drawtext filter.</flag>
+ <flag name="gcrypt">Enables gcrypt support: Needed for rtmp(t)e support if openssl, librtmp or gmp is not used.</flag>
<flag name="gme">Enables support for <pkg>media-libs/game-music-emu</pkg> for playing various video game music formats.</flag>
<flag name="gpl">Build GPL code. Should be enabled unless you require LGPL binaries.</flag>
<flag name="hardcoded-tables">Use pre-calculated tables rather than calculating them on the fly.</flag>