summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-04-22 13:20:07 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-04-22 13:21:31 +0200
commitcf8243a06e4515818977969d03c8d089e42ec0a3 (patch)
tree2985cc93fcee17684a890ae7685763b31e011850 /media-video/ffmpeg
parentmedia-libs/codec2: initial import (diff)
downloadgentoo-cf8243a06e4515818977969d03c8d089e42ec0a3.tar.gz
gentoo-cf8243a06e4515818977969d03c8d089e42ec0a3.tar.bz2
gentoo-cf8243a06e4515818977969d03c8d089e42ec0a3.zip
media-video/ffmpeg: add codec2 useflag
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'media-video/ffmpeg')
-rw-r--r--media-video/ffmpeg/ffmpeg-4.0.ebuild7
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild7
-rw-r--r--media-video/ffmpeg/metadata.xml1
3 files changed, 9 insertions, 6 deletions
diff --git a/media-video/ffmpeg/ffmpeg-4.0.ebuild b/media-video/ffmpeg/ffmpeg-4.0.ebuild
index 6bd43cd27f3a..22e4cd2f2d14 100644
--- a/media-video/ffmpeg/ffmpeg-4.0.ebuild
+++ b/media-video/ffmpeg/ffmpeg-4.0.ebuild
@@ -73,11 +73,11 @@ FFMPEG_FLAG_MAP=(
# indevs
libv4l:libv4l2 pulseaudio:libpulse libdrm
# decoders
- amr:libopencore-amrwb amr:libopencore-amrnb fdk:libfdk-aac video_cards_nvidia:ffnvcodec
+ amr:libopencore-amrwb amr:libopencore-amrnb codec2:libcodec2 fdk:libfdk-aac
jpeg2k:libopenjpeg bluray:libbluray celt:libcelt gme:libgme gsm:libgsm
mmal modplug:libmodplug opus:libopus libilbc librtmp ssh:libssh
- speex:libspeex svg:librsvg vorbis:libvorbis
- vpx:libvpx zvbi:libzvbi
+ speex:libspeex svg:librsvg video_cards_nvidia:ffnvcodec
+ vorbis:libvorbis vpx:libvpx zvbi:libzvbi
# libavfilter options
appkit
bs2b:libbs2b chromaprint flite:libflite frei0r
@@ -170,6 +170,7 @@ RDEPEND="
cdio? ( >=dev-libs/libcdio-paranoia-0.90_p1-r1[${MULTILIB_USEDEP}] )
celt? ( >=media-libs/celt-0.11.1-r1[${MULTILIB_USEDEP}] )
chromaprint? ( >=media-libs/chromaprint-1.2-r1[${MULTILIB_USEDEP}] )
+ codec2? ( media-libs/codec2[${MULTILIB_USEDEP}] )
encode? (
amrenc? ( >=media-libs/vo-amrwbenc-0.1.2-r1[${MULTILIB_USEDEP}] )
kvazaar? ( media-libs/kvazaar[${MULTILIB_USEDEP}] )
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index 378feaea8318..40d7a117ea58 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -73,11 +73,11 @@ FFMPEG_FLAG_MAP=(
# indevs
libv4l:libv4l2 pulseaudio:libpulse libdrm
# decoders
- amr:libopencore-amrwb amr:libopencore-amrnb fdk:libfdk-aac video_cards_nvidia:ffnvcodec
+ amr:libopencore-amrwb amr:libopencore-amrnb codec2:libcodec2 fdk:libfdk-aac
jpeg2k:libopenjpeg bluray:libbluray celt:libcelt gme:libgme gsm:libgsm
mmal modplug:libmodplug opus:libopus libilbc librtmp ssh:libssh
- speex:libspeex svg:librsvg vorbis:libvorbis
- vpx:libvpx zvbi:libzvbi
+ speex:libspeex svg:librsvg video_cards_nvidia:ffnvcodec
+ vorbis:libvorbis vpx:libvpx zvbi:libzvbi
# libavfilter options
appkit
bs2b:libbs2b chromaprint flite:libflite frei0r
@@ -170,6 +170,7 @@ RDEPEND="
cdio? ( >=dev-libs/libcdio-paranoia-0.90_p1-r1[${MULTILIB_USEDEP}] )
celt? ( >=media-libs/celt-0.11.1-r1[${MULTILIB_USEDEP}] )
chromaprint? ( >=media-libs/chromaprint-1.2-r1[${MULTILIB_USEDEP}] )
+ codec2? ( media-libs/codec2[${MULTILIB_USEDEP}] )
encode? (
amrenc? ( >=media-libs/vo-amrwbenc-0.1.2-r1[${MULTILIB_USEDEP}] )
kvazaar? ( media-libs/kvazaar[${MULTILIB_USEDEP}] )
diff --git a/media-video/ffmpeg/metadata.xml b/media-video/ffmpeg/metadata.xml
index e72693241814..24bfa8b7c4ab 100644
--- a/media-video/ffmpeg/metadata.xml
+++ b/media-video/ffmpeg/metadata.xml
@@ -18,6 +18,7 @@
<flag name="celt">Adds Xiph CELT audio decoding support via <pkg>media-libs/celt</pkg></flag>
<flag name="chromaprint">Enables audio fingerprinting support with <pkg>media-libs/chromaprint</pkg>.</flag>
<flag name="chromium">Builds libffmpeg.so to enable media playback in Chromium-based browsers like Opera and Vivaldi.</flag>
+ <flag name="codec2">Enables codec2 low bit rate speech codec support via <pkg>media-libs/codec2</pkg>.</flag>
<flag name="cpudetection">Enables runtime CPU detection (useful for bindist, compatibility on other CPUs)</flag>
<flag name="ebur128">Enables EBU R128 loudness normalization filter via <pkg>media-libs/libebur128</pkg></flag>
<flag name="fdk">Use external fdk-aac library for AAC encoding</flag>