summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/flumotion/flumotion-0.10.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/flumotion/flumotion-0.10.1.ebuild')
-rw-r--r--media-video/flumotion/flumotion-0.10.1.ebuild124
1 files changed, 124 insertions, 0 deletions
diff --git a/media-video/flumotion/flumotion-0.10.1.ebuild b/media-video/flumotion/flumotion-0.10.1.ebuild
new file mode 100644
index 000000000000..52222970c1f4
--- /dev/null
+++ b/media-video/flumotion/flumotion-0.10.1.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils fdo-mime flag-o-matic multilib python-single-r1 toolchain-funcs user virtualx # AC_CHECK_PROG for Xvfb
+
+DESCRIPTION="Flumotion Streaming server"
+HOMEPAGE="http://www.flumotion.net/"
+SRC_URI="http://www.flumotion.net/src/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1" # LICENSE.LGPL
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# TODO:
+
+# These would be from 0.6.2's ebuild
+# media-plugins/gst-plugins-libpng:0.10
+# dev-python/twisted-web
+# dev-python/twisted-names
+# dev-python/imaging
+
+# These are from README
+RDEPEND="
+ dev-python/gst-python:0.10[${PYTHON_USEDEP}]
+ dev-python/kiwi[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ dev-python/twisted-core[${PYTHON_USEDEP}]
+ media-libs/gstreamer:0.10
+ media-libs/gst-plugins-base:0.10
+ media-libs/gst-plugins-good:0.10
+ media-plugins/gst-plugins-ogg:0.10
+ media-plugins/gst-plugins-theora:0.10
+ media-plugins/gst-plugins-vorbis:0.10
+"
+# These are from README and error and trial FEATURES="test" Import's
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ doc? ( dev-python/epydoc[${PYTHON_USEDEP}] )
+ test? ( dev-python/icalendar[${PYTHON_USEDEP}]
+ dev-python/pychecker[${PYTHON_USEDEP}]
+ dev-python/twisted-conch[${PYTHON_USEDEP}] )"
+
+src_prepare() {
+ # Fix .desktop file
+ sed -e 's/.png//' -i data/flumotion-admin.desktop.in || die
+
+ # Fix shebangs
+ sed -e '1 s:.*:#!/usr/bin/env python:' \
+ -i bin/flu*.in bin/runtest.in misc/flu*.in || die
+ python_fix_shebang bin/flu*.in bin/runtest.in misc/flu*.in
+}
+
+src_configure() {
+ append-cflags -fno-strict-aliasing
+
+ econf \
+ --localstatedir=/var \
+ $(use_enable doc docs)
+}
+
+src_compile() {
+ emake -j1 fdpass_so_LINK="$(tc-getCC) ${LDFLAGS} -shared -o fdpass.so"
+}
+
+src_test() {
+ # FIXME: restrict unittests to flumotion source folder
+ # other tests are failing in weird ways and does not seem to test much of flumotion
+ Xemake -j1 check -C flumotion
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+ einstalldocs
+ dodoc RELEASE
+
+ keepdir /var/log/flumotion
+
+ newinitd "${FILESDIR}"/flumotion-init-3 flumotion
+
+ # /usr/share/hal/fdi/policy/20thirdparty/91-flumotion-device-policy.fdi
+ rm -rf "${D}"/usr/share/hal || die
+
+ dodir /etc/flumotion
+ dodir /etc/flumotion/managers
+ dodir /etc/flumotion/managers/default
+ dodir /etc/flumotion/managers/default/flows
+ dodir /etc/flumotion/workers
+
+ pushd conf
+ insinto /etc/flumotion/managers/default
+ doins managers/default/planet.xml
+ insinto /etc/flumotion/workers
+ doins workers/default.xml
+ insinto /etc/flumotion
+ doins default.pem
+ popd
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+
+ if ! enewgroup flumotion || ! enewuser flumotion -1 -1 /usr/share/flumotion flumotion,audio,video,sys; then
+ die "Unable to add flumotion user and flumotion group."
+ fi
+
+ for dir in /usr/share/flumotion /var/log/flumotion ; do
+ chown -R flumotion:flumotion "${dir}"
+ chmod -R 755 "${dir}"
+ done
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}