summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2018-07-13 00:04:41 +0200
committerLouis Sautier <sbraz@gentoo.org>2018-07-13 00:04:41 +0200
commit9fa6fa71b451d7088b7e95638b30175b21b085b9 (patch)
tree9aa1556406ea2153b07f61ef3cccb76e60996269 /media-video/gaupol
parentnet-misc/gns3-server: add upstream info to metadata.xml (diff)
downloadgentoo-9fa6fa71b451d7088b7e95638b30175b21b085b9.tar.gz
gentoo-9fa6fa71b451d7088b7e95638b30175b21b085b9.tar.bz2
gentoo-9fa6fa71b451d7088b7e95638b30175b21b085b9.zip
media-video/gaupol: bump to 1.4.1, remove pytest-runner dep
Package-Manager: Portage-2.3.42, Repoman-2.3.9
Diffstat (limited to 'media-video/gaupol')
-rw-r--r--media-video/gaupol/Manifest1
-rw-r--r--media-video/gaupol/gaupol-1.4.1.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/media-video/gaupol/Manifest b/media-video/gaupol/Manifest
index 8b60f1a0111f..f8e815d2857b 100644
--- a/media-video/gaupol/Manifest
+++ b/media-video/gaupol/Manifest
@@ -1,2 +1,3 @@
DIST gaupol-0.91.tar.gz 518493 BLAKE2B 76a01579c12084e5b7b25f9582126c33070a1df1ce230adfdea66d698830888065c8ea160da70e39550f02dc28f61d8c529aa50c2e75768ed7a2ff3e6165919f SHA512 92459ec0a7d77c8e4a34f44489ae8fc01feeb2d34f6fd152c8bfeaf72b8235c680155698c55e7f9d46ce82bee8274b14313b6a43167f65f784511e583d4858fb
+DIST gaupol-1.4.1.tar.gz 524816 BLAKE2B 677f1ee0e3b523f97d4b0f6491547d07a658c41c3c2c0f76732589592b542176761df28e13735af58371594043ef234f7987988deacd4d8f73554a87f555d001 SHA512 464e71390ba13f1da11bd40ecb4683d146acb6e547204231a2e78c24719b4ad9ba188210d1bf2108924bcfa0df89c0296f428cba693d3b6d4366e98950cb072a
DIST gaupol-1.4.tar.gz 524369 BLAKE2B 6f27ce3328339fc2f6248bb58d80965a5a26fed220ddf9c989a5029b4322ea790f768cb9e0472bb2c5eae4e4da3abd4b0f808e785273ff9fb787ff5b7df5d137 SHA512 da9256dd8dafeaff012226a8ff09807c7cb7609c293bde7d90b05b4f75c47751e65181f1bf47dff1c8e979f48186996253141ff18e849786bf2cff5ed5555148
diff --git a/media-video/gaupol/gaupol-1.4.1.ebuild b/media-video/gaupol/gaupol-1.4.1.ebuild
new file mode 100644
index 000000000000..25d3dea5fb47
--- /dev/null
+++ b/media-video/gaupol/gaupol-1.4.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1 gnome2-utils virtualx xdg-utils
+
+DESCRIPTION="A subtitle editor for text-based subtitles"
+HOMEPAGE="https://otsaloma.io/gaupol/"
+SRC_URI="https://github.com/otsaloma/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="spell test"
+
+RDEPEND="
+ app-text/iso-codes
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ spell? (
+ app-text/gtkspell:3
+ >=dev-python/pyenchant-1.4[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="
+ sys-devel/gettext
+ test? (
+ ${RDEPEND}
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( AUTHORS.md NEWS.md TODO.md README.md README.aeidon.md )
+
+python_test() {
+ virtx py.test
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "Previewing support needs MPV, MPlayer or VLC."
+
+ if use spell; then
+ elog "Additionally, spell-checking requires a dictionary, any of"
+ elog "Aspell/Pspell, Ispell, MySpell, Uspell, Hspell or AppleSpell."
+ fi
+ fi
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+}