summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-01-07 11:08:21 +0100
committerDavid Seifert <soap@gentoo.org>2021-01-07 11:08:21 +0100
commitdf7f71485a7a8c730799e7cdedf490d432a76f2b (patch)
treeed0d58d9ff527ebcb6f03d7871d9d036fd2ce184 /media-video/gxine/gxine-0.5.909-r1.ebuild
parentsys-apps/xdg-desktop-portal-gtk: Stabilize 1.8.0 arm64, #764203 (diff)
downloadgentoo-df7f71485a7a8c730799e7cdedf490d432a76f2b.tar.gz
gentoo-df7f71485a7a8c730799e7cdedf490d432a76f2b.tar.bz2
gentoo-df7f71485a7a8c730799e7cdedf490d432a76f2b.zip
media-video/gxine: Port to EAPI 7
Closes: https://bugs.gentoo.org/709306 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-video/gxine/gxine-0.5.909-r1.ebuild')
-rw-r--r--media-video/gxine/gxine-0.5.909-r1.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/media-video/gxine/gxine-0.5.909-r1.ebuild b/media-video/gxine/gxine-0.5.909-r1.ebuild
new file mode 100644
index 000000000000..5c5965807691
--- /dev/null
+++ b/media-video/gxine/gxine-0.5.909-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools xdg
+
+DESCRIPTION="GTK+ Front-End for libxine"
+HOMEPAGE="http://xine.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xine/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="l10n_cs l10n_de lirc nls udev xinerama"
+
+DEPEND="
+ media-libs/xine-lib[gtk]
+ x11-libs/gtk+:2
+ dev-lang/spidermonkey:0
+ dev-libs/glib
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrender
+ x11-libs/libxcb
+ lirc? ( app-misc/lirc )
+ nls? ( virtual/libintl )
+ udev? ( dev-libs/libgudev:= )
+ xinerama? ( x11-libs/libXinerama )"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
+
+src_prepare() {
+ default
+ # need to disable calling of xine-list when running without
+ # userpriv, otherwise we get sandbox violations (bug #233847)
+ if [[ ${EUID} == 0 ]]; then
+ sed -i -e 's:^XINE_LIST=.*$:XINE_LIST=:' configure.ac || die
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-watchdog \
+ --with-xcb \
+ --without-browser-plugin \
+ --without-dbus \
+ --without-hal \
+ $(use_enable nls) \
+ $(use_enable lirc) \
+ $(use_with udev gudev) \
+ $(use_with xinerama)
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ docsdir="${EPREFIX}"/usr/share/doc/${PF} \
+ install
+
+ dodoc AUTHORS BUGS ChangeLog README{,_l10n} TODO
+
+ use l10n_cs && dodoc README.cs
+ use l10n_de && dodoc README.de
+}