summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2020-04-24 12:48:00 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-04-24 12:53:17 +0300
commit76999c3af402fc309fc4038d357012e5e3d0b635 (patch)
treea8abae5513282039defc6bcc3ba2829fa22b0bfe /media-video/h264enc
parentsys-kernel/gentoo-kernel-bin: Restore 5.4.32 as stable target (diff)
downloadgentoo-76999c3af402fc309fc4038d357012e5e3d0b635.tar.gz
gentoo-76999c3af402fc309fc4038d357012e5e3d0b635.tar.bz2
gentoo-76999c3af402fc309fc4038d357012e5e3d0b635.zip
media-video/h264enc: EAPI-7, fix aac support
Closes: https://github.com/gentoo/gentoo/pull/14027 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-video/h264enc')
-rw-r--r--media-video/h264enc/files/h264enc-10.4.7-libaacplusenc.patch12
-rw-r--r--media-video/h264enc/h264enc-10.4.7-r1.ebuild42
2 files changed, 54 insertions, 0 deletions
diff --git a/media-video/h264enc/files/h264enc-10.4.7-libaacplusenc.patch b/media-video/h264enc/files/h264enc-10.4.7-libaacplusenc.patch
new file mode 100644
index 000000000000..993cbb1efd4a
--- /dev/null
+++ b/media-video/h264enc/files/h264enc-10.4.7-libaacplusenc.patch
@@ -0,0 +1,12 @@
+diff -Naur a/h264enc b/h264enc
+--- a/h264enc 2016-01-19 20:15:59.000000000 +0100
++++ b/h264enc 2019-12-17 14:14:45.321115770 +0100
+@@ -7525,7 +7525,7 @@
+ MPL[i]="$MPLAYER \"$AUDINPUT\" $MPLAYEROPTS ${channels[i]} ${audfilters[i]} -really-quiet -vc dummy -vo null -nocache -ao pcm:fast:file=\"$AUDPIPE\""
+ NERO[i]="$NEROAACENC -ignorelength ${neroaacbr[i]} -if \"$AUDPIPE\" -of \"$TEMPDIR/audio$i.aac\" &"
+ FDKAAC[i]="$FDKAACENC ${fdkaacbr[i]} \"$AUDPIPE\" \"$TEMPDIR/audio$i.aac\" &"
+- AACPLUS[i]="$AACPLUSENC \"$AUDPIPE\" \"$TEMPDIR/audio$i.aac\" ${aacplusbr[i]} &"
++ AACPLUS[i]="$AACPLUSENC \"$AUDPIPE\" \"$TEMPDIR/audio$i.aac\" $(( ${aacplusbr[i]} * 1000 )) s &"
+ OGG[i]="$OGGENC ${vorbq[i]} \"$AUDPIPE\" -o \"$TEMPDIR/audio$i.ogg\" &"
+ OPUS[i]="$OPUSENC ${opusopts[i]} \"$AUDPIPE\" \"$TEMPDIR/audio$i.opus\" &"
+ FLACENC[i]="$FLAC ${flacq[i]} \"$AUDPIPE\" -o \"$TEMPDIR/audio$i.flac\" &"
diff --git a/media-video/h264enc/h264enc-10.4.7-r1.ebuild b/media-video/h264enc/h264enc-10.4.7-r1.ebuild
new file mode 100644
index 000000000000..51adbd9620cd
--- /dev/null
+++ b/media-video/h264enc/h264enc-10.4.7-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils
+
+DESCRIPTION="Script to encode H.264/AVC/MPEG-4 Part 10 formats"
+HOMEPAGE="https://h264enc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="media-video/mplayer[encode,x264]
+ sys-apps/coreutils
+ sys-apps/pv
+ sys-devel/bc
+ sys-process/time"
+
+PATCHES=( "${FILESDIR}/${P}-libaacplusenc.patch" )
+
+src_install() {
+ dobin ${PN}
+ doman man/${PN}.1
+ dodoc doc/*
+ docinto matrices
+ dodoc matrices/*
+}
+
+pkg_postinst() {
+ elog "Optional encoders:"
+ optfeature "aac support" "media-libs/faac media-libs/libaacplus"
+ optfeature "dvd support" media-video/lsdvd
+ optfeature "flac support" media-libs/flac
+ optfeature "lame (mp3) support" media-sound/lame
+ optfeature "matroska (mkv) support" media-video/mkvtoolnix
+ optfeature "mp4 support" media-video/gpac[a52]
+ optfeature "ogm support" media-sound/ogmtools
+ optfeature "vorbis support" media-sound/vorbis-tools
+}