summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Whyman <thev00d00@gentoo.org>2019-11-16 21:50:22 +0000
committerIan Whyman <thev00d00@gentoo.org>2019-11-16 21:50:37 +0000
commitd09b96ef52113113a42c3b7b51ed8dd858bec4c7 (patch)
treeff5a77352d30b1469f1e40bb4a8a371ce0871a74 /media-video/handbrake/files
parentsys-libs/glibc: expose errors in sync primitives checks (diff)
downloadgentoo-d09b96ef52113113a42c3b7b51ed8dd858bec4c7.tar.gz
gentoo-d09b96ef52113113a42c3b7b51ed8dd858bec4c7.tar.bz2
gentoo-d09b96ef52113113a42c3b7b51ed8dd858bec4c7.zip
media-video/handbrake: 1.3.0: Fix x265, Add numa
Closes: https://bugs.gentoo.org/700098 Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Ian Whyman <thev00d00@gentoo.org>
Diffstat (limited to 'media-video/handbrake/files')
-rw-r--r--media-video/handbrake/files/handbrake-1.3.0-missing-linker-flags.patch27
-rw-r--r--media-video/handbrake/files/handbrake-9999-fix-missing-x265-link-flag.patch13
2 files changed, 27 insertions, 13 deletions
diff --git a/media-video/handbrake/files/handbrake-1.3.0-missing-linker-flags.patch b/media-video/handbrake/files/handbrake-1.3.0-missing-linker-flags.patch
new file mode 100644
index 000000000000..598fc7c6efaa
--- /dev/null
+++ b/media-video/handbrake/files/handbrake-1.3.0-missing-linker-flags.patch
@@ -0,0 +1,27 @@
+diff --git a/gtk/configure.ac b/gtk/configure.ac
+index 92aabcbe8..1f4a1df95 100644
+--- a/gtk/configure.ac
++++ b/gtk/configure.ac
+@@ -199,7 +199,7 @@ PKG_CHECK_MODULES(GHB, [$GHB_PACKAGES])
+
+ GHB_CFLAGS="$HBINC $GHB_CFLAGS"
+
+-HB_LIBS="-lhandbrake -lavformat -lavfilter -lavcodec -lavutil -ldav1d -lswresample -lpostproc -ldvdnav -ldvdread -lmp3lame -lvorbis -lvorbisenc -logg -lx264 -lswscale -ltheoraenc -ltheoradec -lvpx -lz -lbz2 -lbluray -lass -lfontconfig -lfreetype -lxml2 -ljansson -lopus -lspeex -llzma"
++HB_LIBS="-lhandbrake -lavformat -lavfilter -lavcodec -lavutil -ldav1d -lswresample -lpostproc -ldvdnav -ldvdread -lmp3lame -lvorbis -lvorbisenc -logg -lx264 -lswscale -ltheoraenc -ltheoradec -lvpx -lz -lbz2 -lbluray -lass -lfontconfig -lfreetype -lxml2 -ljansson -lopus -lspeex -llzma -ldl"
+
+ if test "x$use_fdk_aac" = "xyes" ; then
+ HB_LIBS="$HB_LIBS -lfdk-aac"
+diff --git a/test/module.defs b/test/module.defs
+index ffc00a8b2..62b01ffd5 100644
+--- a/test/module.defs
++++ b/test/module.defs
+@@ -69,6 +69,9 @@ else ifeq ($(HOST.system),linux)
+ ifeq (1, $(FEATURE.numa))
+ TEST.GCC.l += numa
+ endif
++ifeq (1, $(FEATURE.x265))
++ TEST.GCC.l += x265
++endif
+ else ifeq ($(HOST.system),kfreebsd)
+ TEST.GCC.l += pthread dl m
+ else ifeq ($(HOST.system),freebsd)
diff --git a/media-video/handbrake/files/handbrake-9999-fix-missing-x265-link-flag.patch b/media-video/handbrake/files/handbrake-9999-fix-missing-x265-link-flag.patch
deleted file mode 100644
index a963fe0af216..000000000000
--- a/media-video/handbrake/files/handbrake-9999-fix-missing-x265-link-flag.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Written by: Peter Foley <pefoley2@pefoley.com>
-Gentoo Bug: #552792
-
---- a/test/module.defs
-+++ b/test/module.defs
-@@ -25,6 +25,7 @@
-
- ifeq (1,$(FEATURE.x265))
- TEST.GCC.D += USE_X265
-+ TEST.GCC.l += x265
- endif
-
- TEST.GCC.l += $(foreach m,$(MODULES.NAMES),$($m.OSL.libs))