summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-20 03:33:49 +0100
committerSam James <sam@gentoo.org>2022-06-20 03:33:53 +0100
commit2763e5cb78e38d7e0315aa78ea287be8e15ab9d3 (patch)
tree215143c7034ec79f4abf4df77e022a99d1a11e46 /media-video/handbrake
parentmedia-video/handbrake: fix missing dep on cmake required by custom configure ... (diff)
downloadgentoo-2763e5cb78e38d7e0315aa78ea287be8e15ab9d3.tar.gz
gentoo-2763e5cb78e38d7e0315aa78ea287be8e15ab9d3.tar.bz2
gentoo-2763e5cb78e38d7e0315aa78ea287be8e15ab9d3.zip
media-video/handbrake: fixup BDEPEND; sync live
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-video/handbrake')
-rw-r--r--media-video/handbrake/handbrake-1.5.1.ebuild8
-rw-r--r--media-video/handbrake/handbrake-9999.ebuild8
2 files changed, 9 insertions, 7 deletions
diff --git a/media-video/handbrake/handbrake-1.5.1.ebuild b/media-video/handbrake/handbrake-1.5.1.ebuild
index ef06b33b19dd..5401dffd7c51 100644
--- a/media-video/handbrake/handbrake-1.5.1.ebuild
+++ b/media-video/handbrake/handbrake-1.5.1.ebuild
@@ -73,14 +73,14 @@ RDEPEND="
nvenc? ( media-libs/nv-codec-headers )
x265? ( >=media-libs/x265-3.2:0=[10bit,12bit,numa?] )
"
-DEPEND="
+DEPEND="${RDEPEND}"
+# cmake needed for custom script: bug #852701
+BDEPEND="
${PYTHON_DEPS}
- ${RDEPEND}
dev-lang/nasm
+ dev-util/cmake
dev-util/intltool
"
-# Needed for custom script: bug #852701
-BDEPEND="dev-util/cmake"
PATCHES=(
# Remove libdvdnav duplication and call it on the original instead.
diff --git a/media-video/handbrake/handbrake-9999.ebuild b/media-video/handbrake/handbrake-9999.ebuild
index ab3d4b77a810..eb1f331a43f3 100644
--- a/media-video/handbrake/handbrake-9999.ebuild
+++ b/media-video/handbrake/handbrake-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -73,10 +73,12 @@ RDEPEND="
nvenc? ( media-libs/nv-codec-headers )
x265? ( >=media-libs/x265-3.2:0=[10bit,12bit,numa?] )
"
-DEPEND="
+DEPEND="${RDEPEND}"
+# cmake needed for custom script: bug #852701
+BDEPEND="
${PYTHON_DEPS}
- ${RDEPEND}
dev-lang/nasm
+ dev-util/cmake
dev-util/intltool
"