summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-09-23 17:33:35 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-09-23 17:33:35 +0200
commit3eddcfe618b6803a990267f367ca74efc1fc41f0 (patch)
tree9d58abc4bca2056a06ba980e17f5faa55aa54c23 /media-video/harvid/harvid-0.8.1.ebuild
parentapp-text/lcdf-typetools: remove old (diff)
downloadgentoo-3eddcfe618b6803a990267f367ca74efc1fc41f0.tar.gz
gentoo-3eddcfe618b6803a990267f367ca74efc1fc41f0.tar.bz2
gentoo-3eddcfe618b6803a990267f367ca74efc1fc41f0.zip
media-video/harvid: bump to 0.8.1; bug #594268
Package-Manager: portage-2.3.1
Diffstat (limited to 'media-video/harvid/harvid-0.8.1.ebuild')
-rw-r--r--media-video/harvid/harvid-0.8.1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/media-video/harvid/harvid-0.8.1.ebuild b/media-video/harvid/harvid-0.8.1.ebuild
new file mode 100644
index 000000000000..8afaf5126d6d
--- /dev/null
+++ b/media-video/harvid/harvid-0.8.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs multilib eutils
+
+DESCRIPTION="HTTP Ardour Video Daemon"
+HOMEPAGE="http://x42.github.io/harvid/"
+SRC_URI="https://github.com/x42/harvid/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="libav"
+
+RDEPEND="
+ !libav? ( >=media-video/ffmpeg-2.6:0= )
+ libav? ( >=media-video/libav-9:0= )
+ media-libs/libpng:0=
+ virtual/jpeg:0
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+hv_make() {
+ emake \
+ CC="$(tc-getCC)" \
+ RANLIB="$(tc-getRANLIB)" \
+ STRIP="true" \
+ NM="$(tc-getNM) -B" \
+ LD="$(tc-getLD)" \
+ AR="$(tc-getAR)" \
+ PREFIX="${EPREFIX:-/}usr" \
+ libdir="${EPREFIX:-/}usr/$(get_libdir)" \
+ hdocdir="${EPREFIX:-/}usr/share/doc/${PF}" \
+ "${@}"
+}
+
+src_compile() {
+ hv_make -C libharvid
+ hv_make -C src
+ hv_make
+}
+
+src_install() {
+ hv_make DESTDIR="${D}" install
+ dodoc ChangeLog README.md
+}