summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-02-15 06:46:25 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-02-15 06:46:25 +0100
commit15efc43e8805fee3cc688c15c2907f28185453f1 (patch)
treea570ff547918e44a3ce3df7b886eb9ee7e42b6b2 /media-video/libva-utils/libva-utils-2.1.0.ebuild
parentmedia-video/libva-utils: Remove old (diff)
downloadgentoo-15efc43e8805fee3cc688c15c2907f28185453f1.tar.gz
gentoo-15efc43e8805fee3cc688c15c2907f28185453f1.tar.bz2
gentoo-15efc43e8805fee3cc688c15c2907f28185453f1.zip
media-video/libva-utils: bump to 2.1.0
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'media-video/libva-utils/libva-utils-2.1.0.ebuild')
-rw-r--r--media-video/libva-utils/libva-utils-2.1.0.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/media-video/libva-utils/libva-utils-2.1.0.ebuild b/media-video/libva-utils/libva-utils-2.1.0.ebuild
new file mode 100644
index 000000000000..6c7521ce0786
--- /dev/null
+++ b/media-video/libva-utils/libva-utils-2.1.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+SCM=""
+if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
+ SCM=git-r3
+ EGIT_BRANCH=master
+ EGIT_REPO_URI="https://github.com/intel/libva-utils"
+fi
+
+AUTOTOOLS_AUTORECONF="yes"
+inherit autotools-utils ${SCM} multilib
+
+DESCRIPTION="Collection of utilities and tests for VA-API"
+HOMEPAGE="https://01.org/linuxmedia/vaapi"
+if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/intel/libva-utils/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+if [ "${PV%9999}" = "${PV}" ] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+else
+ KEYWORDS=""
+fi
+IUSE="+drm test wayland X"
+
+RDEPEND="
+ >=x11-libs/libva-2.0.0:=[drm?,wayland?,X?]
+ drm? ( >=x11-libs/libdrm-2.4 )
+ X? (
+ >=x11-libs/libX11-1.6.2
+ >=x11-libs/libXext-1.3.2
+ >=x11-libs/libXfixes-5.0.1
+ )
+ wayland? ( >=dev-libs/wayland-1.0.6 )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+REQUIRED_USE="|| ( drm wayland X )"
+
+DOCS=( CONTRIBUTING.md README.md )
+
+src_prepare() {
+ sed -e 's/-Werror//' -i test/Makefile.am || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable X x11)
+ $(use_enable wayland)
+ $(use_enable drm)
+ $(use_enable test tests)
+ )
+ autotools-utils_src_configure
+}