summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Heidelberg <david@ixit.cz>2019-02-04 16:13:19 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-21 17:05:45 +0100
commit86416ab9c30de7d6c451032a6afb57494f94dbd5 (patch)
tree33ce0095bacd96166d730c85d10ac73645bb57e2 /media-video/libva-utils/libva-utils-2.3.0.ebuild
parentx11-libs/libva: bump to 2.4.0 (diff)
downloadgentoo-86416ab9c30de7d6c451032a6afb57494f94dbd5.tar.gz
gentoo-86416ab9c30de7d6c451032a6afb57494f94dbd5.tar.bz2
gentoo-86416ab9c30de7d6c451032a6afb57494f94dbd5.zip
media-video/libva-utils: bump to 2.3.0
Signed-off-by: David Heidelberg <david@ixit.cz> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-video/libva-utils/libva-utils-2.3.0.ebuild')
-rw-r--r--media-video/libva-utils/libva-utils-2.3.0.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/media-video/libva-utils/libva-utils-2.3.0.ebuild b/media-video/libva-utils/libva-utils-2.3.0.ebuild
new file mode 100644
index 000000000000..45318abddb59
--- /dev/null
+++ b/media-video/libva-utils/libva-utils-2.3.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+SCM=""
+if [[ "${PV%9999}" != "${PV}" ]] ; then # Live ebuild
+ SCM=git-r3
+ EGIT_BRANCH=master
+ EGIT_REPO_URI="https://github.com/intel/libva-utils"
+fi
+
+AUTOTOOLS_AUTORECONF="yes"
+inherit autotools-utils ${SCM} multilib
+
+DESCRIPTION="Collection of utilities and tests for VA-API"
+HOMEPAGE="https://01.org/linuxmedia/vaapi"
+if [[ "${PV%9999}" != "${PV}" ]] ; then # Live ebuild
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/intel/libva-utils/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+drm test wayland X"
+
+RDEPEND="
+ >=x11-libs/libva-2.0.0:=[drm?,wayland?,X?]
+ drm? ( >=x11-libs/libdrm-2.4 )
+ X? (
+ >=x11-libs/libX11-1.6.2
+ >=x11-libs/libXext-1.3.2
+ >=x11-libs/libXfixes-5.0.1
+ )
+ wayland? ( >=dev-libs/wayland-1.0.6 )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+REQUIRED_USE="|| ( drm wayland X )"
+
+DOCS=( CONTRIBUTING.md README.md )
+
+src_prepare() {
+ sed -e 's/-Werror//' -i test/Makefile.am || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable X x11)
+ $(use_enable wayland)
+ $(use_enable drm)
+ $(use_enable test tests)
+ )
+ autotools-utils_src_configure
+}