summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-02-21 16:50:02 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-21 17:05:45 +0100
commit55442aa2f84df48dc307f97672bbcf41faf1fb8f (patch)
tree4a853fdf94afd9832daf954c8205df3a896dacb9 /media-video/libva-utils
parentx11-libs/libva-intel-driver: Switch to release tarball (diff)
downloadgentoo-55442aa2f84df48dc307f97672bbcf41faf1fb8f.tar.gz
gentoo-55442aa2f84df48dc307f97672bbcf41faf1fb8f.tar.bz2
gentoo-55442aa2f84df48dc307f97672bbcf41faf1fb8f.zip
media-video/libva-utils: EAPI-7 bump
Sort DEPENDs Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-video/libva-utils')
-rw-r--r--media-video/libva-utils/libva-utils-9999.ebuild53
1 files changed, 23 insertions, 30 deletions
diff --git a/media-video/libva-utils/libva-utils-9999.ebuild b/media-video/libva-utils/libva-utils-9999.ebuild
index 6c7521ce0786..6388f612168d 100644
--- a/media-video/libva-utils/libva-utils-9999.ebuild
+++ b/media-video/libva-utils/libva-utils-9999.ebuild
@@ -1,63 +1,56 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-SCM=""
-if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
- SCM=git-r3
- EGIT_BRANCH=master
+if [[ ${PV} = *9999* ]] ; then # Live ebuild
+ inherit git-r3
EGIT_REPO_URI="https://github.com/intel/libva-utils"
fi
-
-AUTOTOOLS_AUTORECONF="yes"
-inherit autotools-utils ${SCM} multilib
+inherit autotools
DESCRIPTION="Collection of utilities and tests for VA-API"
HOMEPAGE="https://01.org/linuxmedia/vaapi"
-if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
- SRC_URI=""
-else
- SRC_URI="https://github.com/intel/libva-utils/archive/${PV}.tar.gz -> ${P}.tar.gz"
+if [[ ${PV} != *9999* ]] ; then
+ SRC_URI="https://github.com/intel/libva-utils/releases/download/${PV}/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
fi
LICENSE="MIT"
SLOT="0"
-if [ "${PV%9999}" = "${PV}" ] ; then
- KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
-else
- KEYWORDS=""
-fi
IUSE="+drm test wayland X"
-RDEPEND="
+REQUIRED_USE="|| ( drm wayland X )"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+DEPEND="
>=x11-libs/libva-2.0.0:=[drm?,wayland?,X?]
drm? ( >=x11-libs/libdrm-2.4 )
+ wayland? ( >=dev-libs/wayland-1.0.6 )
X? (
>=x11-libs/libX11-1.6.2
>=x11-libs/libXext-1.3.2
>=x11-libs/libXfixes-5.0.1
)
- wayland? ( >=dev-libs/wayland-1.0.6 )"
+"
+RDEPEND="${DEPEND}"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-REQUIRED_USE="|| ( drm wayland X )"
-
-DOCS=( CONTRIBUTING.md README.md )
+DOCS=( CONTRIBUTING.md NEWS README.md )
src_prepare() {
+ default
sed -e 's/-Werror//' -i test/Makefile.am || die
- autotools-utils_src_prepare
+ eautoreconf
}
src_configure() {
local myeconfargs=(
- $(use_enable X x11)
- $(use_enable wayland)
$(use_enable drm)
$(use_enable test tests)
+ $(use_enable wayland)
+ $(use_enable X x11)
)
- autotools-utils_src_configure
+ econf "${myeconfargs[@]}"
}