summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2021-03-17 16:33:10 +0100
committerDaniel Pielmeier <billie@gentoo.org>2021-03-17 16:33:10 +0100
commit2885902718af322e4634879cd67394e01a61c416 (patch)
treeff55466b4def16ab7e0e34cf431a582381c02fbb /media-video/mjpegtools
parentapp-admin/conky: Version bump. (diff)
downloadgentoo-2885902718af322e4634879cd67394e01a61c416.tar.gz
gentoo-2885902718af322e4634879cd67394e01a61c416.tar.bz2
gentoo-2885902718af322e4634879cd67394e01a61c416.zip
media-video/mjpegtools: Version bump.
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Daniel Pielmeier <billie@gentoo.org>
Diffstat (limited to 'media-video/mjpegtools')
-rw-r--r--media-video/mjpegtools/Manifest1
-rw-r--r--media-video/mjpegtools/mjpegtools-2.2.0.ebuild111
2 files changed, 112 insertions, 0 deletions
diff --git a/media-video/mjpegtools/Manifest b/media-video/mjpegtools/Manifest
index 4c58d5c4dda2..27ec35868cfd 100644
--- a/media-video/mjpegtools/Manifest
+++ b/media-video/mjpegtools/Manifest
@@ -1 +1,2 @@
DIST mjpegtools-2.1.0.tar.gz 1844336 BLAKE2B 90ae51c81e18708132f26c1fb002128193168366542cadc15060ad52f664a5f90770b3039ada2a1777eab5fec9743fb24c65083de913ebd72b23dd55f6b25741 SHA512 10d3288f47d7cc4de87fa63f65e0fd4bd0a9af95db77155eecccecae7a7e60ebab83eaec44cf7a2c3d9e627f0cc086eda208abee1a7a74cbf3f85e87bb979ac5
+DIST mjpegtools-2.2.0.tar.bz2 1542088 BLAKE2B 61736ea0782ef098110370ab75feac2d344709a849326acc366cc1dedfabe0aaec797292f09de9d0da8a2ce94506dc2c8749212b49f99ffa8775f347eae94b46 SHA512 d645c0004bf20cab67d2e09cde709f05e32ab755b773c93f75ab65bf6d4ab23d80addf3f8b98e1ce59cc05efc0776b11ca0c71568acb81fab6a0f15e60bce71f
diff --git a/media-video/mjpegtools/mjpegtools-2.2.0.ebuild b/media-video/mjpegtools/mjpegtools-2.2.0.ebuild
new file mode 100644
index 000000000000..9dd316d8a9c1
--- /dev/null
+++ b/media-video/mjpegtools/mjpegtools-2.2.0.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic multilib-minimal toolchain-funcs
+
+DESCRIPTION="Tools for MJPEG video"
+HOMEPAGE="http://mjpeg.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mjpeg/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="cpu_flags_x86_mmx dv gtk png quicktime sdl sdlgfx static-libs"
+REQUIRED_USE="sdlgfx? ( sdl )"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+RDEPEND="
+ virtual/jpeg:0=[${MULTILIB_USEDEP}]
+ dv? ( >=media-libs/libdv-1.0.0-r3[${MULTILIB_USEDEP}] )
+ gtk? ( x11-libs/gtk+:2 )
+ png? ( media-libs/libpng:0= )
+ quicktime? ( >=media-libs/libquicktime-1.2.4-r1[${MULTILIB_USEDEP}] )
+ sdl? (
+ >=media-libs/libsdl-1.2.15-r4[${MULTILIB_USEDEP}]
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ sdlgfx? ( media-libs/sdl-gfx )
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ >=sys-apps/sed-4
+ virtual/awk
+ cpu_flags_x86_mmx? ( dev-lang/nasm )
+"
+
+src_prepare() {
+ default
+
+ eautoreconf
+ sed -i -e '/ARCHFLAGS=/s:=.*:=:' configure
+}
+
+multilib_src_configure() {
+ [[ $(gcc-major-version) -eq 3 ]] && append-flags -mno-sse2
+
+ local myconf=(
+ --enable-compile-warnings
+ $(use_enable cpu_flags_x86_mmx simd-accel)
+ $(use_enable static-libs static)
+ --enable-largefile
+
+ $(use_with quicktime libquicktime)
+ $(use_with dv libdv)
+ $(use_with sdl libsdl)
+ --without-v4l
+ $(use_with sdl x)
+
+ # used by tools only
+ $(multilib_native_use_with gtk)
+ $(multilib_native_use_with png libpng)
+ $(multilib_native_use_with sdlgfx)
+ )
+
+ ECONF_SOURCE=${S} \
+ econf "${myconf[@]}"
+}
+
+multilib_src_compile() {
+ if multilib_is_native_abi; then
+ default
+ else
+ # avoid building programs
+ emake bin_PROGRAMS=
+ fi
+}
+
+multilib_src_test() {
+ # there are no tests at the moment, so it would just build
+ # all programs in non-native ABIs...
+ multilib_is_native_abi && default
+}
+
+multilib_src_install() {
+ if multilib_is_native_abi; then
+ default
+ else
+ emake DESTDIR="${D}" install \
+ bin_PROGRAMS=
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ dodoc mjpeg_howto.txt PLANS HINTS docs/FAQ.txt
+
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "mjpegtools installs user contributed scripts which require additional"
+ elog "dependencies not pulled in by the installation."
+ elog "These have to be installed manually."
+ elog "Currently known extra dpendencies are: ffmpeg, mencoder from mplayer,"
+ elog "parts of transcode, mpeg2dec from libmpeg2, sox, toolame, vcdimager, python."
+ fi
+}