summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrancesco Turco <fturco@fastmail.fm>2018-01-04 21:06:28 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-01-21 13:19:16 +0100
commitc499d61492f1ed792eb0726d614aa7f2dbf6bb7a (patch)
treef3b734b54569836431fd04e26ac909261450d072 /media-video/mkvtoolnix/mkvtoolnix-9999.ebuild
parentmedia-video/mkvtoolnix: sync live ebuidl (diff)
downloadgentoo-c499d61492f1ed792eb0726d614aa7f2dbf6bb7a.tar.gz
gentoo-c499d61492f1ed792eb0726d614aa7f2dbf6bb7a.tar.bz2
gentoo-c499d61492f1ed792eb0726d614aa7f2dbf6bb7a.zip
media-video/mkvtoolnix: update .desktop and mime databases
Bug: https://bugs.gentoo.org/643328
Diffstat (limited to 'media-video/mkvtoolnix/mkvtoolnix-9999.ebuild')
-rw-r--r--media-video/mkvtoolnix/mkvtoolnix-9999.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/media-video/mkvtoolnix/mkvtoolnix-9999.ebuild b/media-video/mkvtoolnix/mkvtoolnix-9999.ebuild
index d58ac973b2d3..bbf85f64514a 100644
--- a/media-video/mkvtoolnix/mkvtoolnix-9999.ebuild
+++ b/media-video/mkvtoolnix/mkvtoolnix-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit toolchain-funcs versionator multiprocessing
+inherit toolchain-funcs versionator multiprocessing xdg-utils
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://gitlab.com/mbunkus/mkvtoolnix.git"
@@ -109,3 +109,13 @@ src_install() {
einstalldocs
doman doc/man/*.1
}
+
+pkg_postrm() {
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}
+
+pkg_postinst() {
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}