summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2015-12-21 14:22:19 +0100
committerPatrick Lauer <patrick@gentoo.org>2015-12-21 14:22:19 +0100
commita601fdac8d2e2e637469e2e2c86dc65a38f50663 (patch)
tree6ba47b032185adbbaf98a07ffd525b00b8493327 /media-video/movit/movit-1.2.0.ebuild
parentdev-db/barman: Bump (diff)
downloadgentoo-a601fdac8d2e2e637469e2e2c86dc65a38f50663.tar.gz
gentoo-a601fdac8d2e2e637469e2e2c86dc65a38f50663.tar.bz2
gentoo-a601fdac8d2e2e637469e2e2c86dc65a38f50663.zip
media-video/movit: Bump
Package-Manager: portage-2.2.26
Diffstat (limited to 'media-video/movit/movit-1.2.0.ebuild')
-rw-r--r--media-video/movit/movit-1.2.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-video/movit/movit-1.2.0.ebuild b/media-video/movit/movit-1.2.0.ebuild
new file mode 100644
index 000000000000..08927148bea1
--- /dev/null
+++ b/media-video/movit/movit-1.2.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# no sane way to use OpenGL from within tests?
+RESTRICT="test"
+
+DESCRIPTION="Modern Video Toolkit"
+HOMEPAGE="http://movit.sesse.net/"
+# Tests need gtest, makefile unconditionally builds tests, so ... yey!
+SRC_URI="http://movit.sesse.net/${P}.tar.gz
+ https://googletest.googlecode.com/files/gtest-1.7.0.zip"
+LICENSE="GPL-2+"
+SLOT="0"
+
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/mesa
+ >=dev-cpp/eigen-3.2.0:3
+ media-libs/libepoxy
+ sci-libs/fftw
+ media-libs/libsdl2
+ "
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ GTEST_DIR="${WORKDIR}/gtest-1.7.0" emake
+}
+
+src_test() {
+ GTEST_DIR="${WORKDIR}/gtest-1.7.0" emake check
+}