summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-02-14 20:53:31 +0100
committerPacho Ramos <pacho@gentoo.org>2018-02-14 21:04:55 +0100
commit8dbb1b8af44280388f0a24d9cc83251b343b6a25 (patch)
tree993f0dc0f1e930b78469649504de8793276d34b9 /media-video/mplayer/mplayer-9999.ebuild
parentmedia-video/blinkensim: Drop directfb support (#642504) (diff)
downloadgentoo-8dbb1b8af44280388f0a24d9cc83251b343b6a25.tar.gz
gentoo-8dbb1b8af44280388f0a24d9cc83251b343b6a25.tar.bz2
gentoo-8dbb1b8af44280388f0a24d9cc83251b343b6a25.zip
media-video/mplayer: Drop directfb support (#642506), stop using deprecated eclasses
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'media-video/mplayer/mplayer-9999.ebuild')
-rw-r--r--media-video/mplayer/mplayer-9999.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/media-video/mplayer/mplayer-9999.ebuild b/media-video/mplayer/mplayer-9999.ebuild
index b75b7dbc479e..bc3255c47039 100644
--- a/media-video/mplayer/mplayer-9999.ebuild
+++ b/media-video/mplayer/mplayer-9999.ebuild
@@ -1,17 +1,17 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
EGIT_REPO_URI="git://git.videolan.org/ffmpeg.git"
ESVN_REPO_URI="svn://svn.mplayerhq.hu/mplayer/trunk"
-[[ ${PV} = *9999* ]] && SVN_ECLASS="subversion git-2" || SVN_ECLASS=""
+[[ ${PV} = *9999* ]] && SVN_ECLASS="subversion git-r3" || SVN_ECLASS=""
-inherit toolchain-funcs eutils flag-o-matic multilib base ${SVN_ECLASS}
+inherit toolchain-funcs flag-o-matic ${SVN_ECLASS}
IUSE="cpu_flags_x86_3dnow cpu_flags_x86_3dnowext a52 aalib +alsa altivec aqua bidi bl bluray
bs2b cddb +cdio cdparanoia cpudetection debug dga
-directfb doc dts dv dvb +dvd +dvdnav +enca +encode faac faad fbcon
+doc dts dv dvb +dvd +dvdnav +enca +encode faac faad fbcon
ftp gif ggi gsm +iconv ipv6 jack joystick jpeg kernel_linux ladspa
+libass libcaca libmpeg2 lirc live lzo mad md5sum +cpu_flags_x86_mmx cpu_flags_x86_mmxext mng mp3 nas
+network nut openal opengl +osdmenu oss png pnm pulseaudio pvr
@@ -69,7 +69,6 @@ RDEPEND+="
cdio? ( dev-libs/libcdio:0= dev-libs/libcdio-paranoia )
cdparanoia? ( !cdio? ( media-sound/cdparanoia ) )
dga? ( x11-libs/libXxf86dga )
- directfb? ( dev-libs/DirectFB )
dts? ( media-libs/libdca )
dv? ( media-libs/libdv )
dvb? ( virtual/linuxtv-dvb-headers )
@@ -238,6 +237,8 @@ src_unpack() {
}
src_prepare() {
+ default
+
local svf=snapshot_version
if [[ ${PV} = *9999* ]]; then
# Set SVN version manually
@@ -253,8 +254,6 @@ src_prepare() {
# fix path to bash executable in configure scripts
sed -i -e "1c\#!${EPREFIX}/bin/bash" configure version.sh || die
- base_src_prepare
-
# Use sane default for >=virtual/udev-197
sed -i -e '/default_dvd_device/s:/dev/dvd:/dev/cdrom:' configure || die
}
@@ -414,7 +413,7 @@ src_configure() {
################
# Video Output #
################
- uses="directfb md5sum sdl yuv4mpeg"
+ uses="md5sum sdl yuv4mpeg"
for i in ${uses}; do
use ${i} || myconf+=" --disable-${i}"
done
@@ -524,7 +523,8 @@ src_configure() {
}
src_compile() {
- base_src_compile
+ default
+
# Build only user-requested docs if they're available.
if use doc ; then
# select available languages from $LINGUAS