summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2018-03-11 15:51:27 +0300
committerMichael Palimaka <kensington@gentoo.org>2018-03-12 00:07:41 +1100
commit49e832ffa5becb353cbdc3f34c2e34fd40e0147a (patch)
treec4825b625b80142cdd09b7d32bf0558ac2df52bd /media-video/mpv
parentx11-misc/qt5ct: remove old (diff)
downloadgentoo-49e832ffa5becb353cbdc3f34c2e34fd40e0147a.tar.gz
gentoo-49e832ffa5becb353cbdc3f34c2e34fd40e0147a.tar.bz2
gentoo-49e832ffa5becb353cbdc3f34c2e34fd40e0147a.zip
media-video/mpv: update ffmpeg patch for 9999
Closes: https://bugs.gentoo.org/649908 Closes: https://github.com/gentoo/gentoo/pull/7421 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'media-video/mpv')
-rw-r--r--media-video/mpv/files/mpv-9999-make-ffmpeg-version-check-non-fatal.patch28
-rw-r--r--media-video/mpv/mpv-9999.ebuild2
2 files changed, 29 insertions, 1 deletions
diff --git a/media-video/mpv/files/mpv-9999-make-ffmpeg-version-check-non-fatal.patch b/media-video/mpv/files/mpv-9999-make-ffmpeg-version-check-non-fatal.patch
new file mode 100644
index 000000000000..1594617fba9a
--- /dev/null
+++ b/media-video/mpv/files/mpv-9999-make-ffmpeg-version-check-non-fatal.patch
@@ -0,0 +1,28 @@
+player: make ffmpeg/libav version check non-fatal
+
+We already enforce mpv rebuilds when ffmpeg/libav SONAME changes.
+
+diff --git a/player/main.c b/player/main.c
+index 5a3fe4c1b7..8cfbb09c56 100644
+--- a/player/main.c
++++ b/player/main.c
+@@ -429,13 +429,12 @@ int mp_initialize(struct MPContext *mpctx, char **options)
+ // Distro maintainers who patch this out should be aware that mpv
+ // intentionally ignores ABI in some places where it's not possible to
+ // get by without violating it.
+- print_libav_versions(mpctx->log, MSGL_FATAL);
+- MP_FATAL(mpctx, "\nmpv was compiled against a different version of "
+- "FFmpeg/Libav than the shared\nlibrary it is linked against. "
+- "This is most likely a broken build and could\nresult in "
+- "misbehavior and crashes.\n\nmpv does not support this "
+- "configuration and will not run - rebuild mpv instead.\n");
+- return -1;
++ print_libav_versions(mpctx->log, MSGL_WARN);
++ MP_WARN(mpctx, "\nmpv was compiled against a different version of "
++ "FFmpeg/Libav than the shared\nlibrary it is linked against. "
++ "This could result in misbehavior and crashes.\n\n"
++ "Upstream does not support this configuration.\n"
++ "Please rebuild mpv in case of any problems.\n");
+ }
+
+ if (!mpctx->playlist->first && !opts->player_idle_mode)
diff --git a/media-video/mpv/mpv-9999.ebuild b/media-video/mpv/mpv-9999.ebuild
index e273db3d080b..302641687d69 100644
--- a/media-video/mpv/mpv-9999.ebuild
+++ b/media-video/mpv/mpv-9999.ebuild
@@ -132,7 +132,7 @@ RDEPEND="${COMMON_DEPEND}
"
PATCHES=(
- "${FILESDIR}/${PN}-0.19.0-make-ffmpeg-version-check-non-fatal.patch"
+ "${FILESDIR}/${P}-make-ffmpeg-version-check-non-fatal.patch"
)
src_prepare() {