summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2017-01-28 18:48:40 +0300
committerDavid Seifert <soap@gentoo.org>2017-01-29 23:53:15 +0100
commita4a37fe3b5d941a9963c7917f22771116fe39182 (patch)
tree69e13365b73df61c3444ec163bc3e431634ff3cc /media-video/mpv
parentmedia-video/mpv: notify users about new OSC layout since 0.21.0 in 9999 (diff)
downloadgentoo-a4a37fe3b5d941a9963c7917f22771116fe39182.tar.gz
gentoo-a4a37fe3b5d941a9963c7917f22771116fe39182.tar.bz2
gentoo-a4a37fe3b5d941a9963c7917f22771116fe39182.zip
media-video/mpv: add C plugins support to 9999
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3718
Diffstat (limited to 'media-video/mpv')
-rw-r--r--media-video/mpv/metadata.xml1
-rw-r--r--media-video/mpv/mpv-9999.ebuild9
2 files changed, 6 insertions, 4 deletions
diff --git a/media-video/mpv/metadata.xml b/media-video/mpv/metadata.xml
index a272e218801f..7286b2afa3ee 100644
--- a/media-video/mpv/metadata.xml
+++ b/media-video/mpv/metadata.xml
@@ -19,6 +19,7 @@
<flag name="bs2b">Enable Bauer stereophonic-to-binaural headphone filter</flag>
<flag name="cdio">Enable CDDA support via <pkg>dev-libs/libcdio-paranoia</pkg></flag>
<flag name="cli">Build mpv CLI player</flag>
+ <flag name="cplugins">Enable C plugins support</flag>
<flag name="cuda">Enable hardware video decoding via Nvidia CUDA</flag>
<flag name="doc-pdf">Build documentation in pdf format</flag>
<flag name="drm">Enable Kernel Mode Setting / Direct Rendering Manager based video output</flag>
diff --git a/media-video/mpv/mpv-9999.ebuild b/media-video/mpv/mpv-9999.ebuild
index 145cb5b9153b..488ac52d26f2 100644
--- a/media-video/mpv/mpv-9999.ebuild
+++ b/media-video/mpv/mpv-9999.ebuild
@@ -28,10 +28,10 @@ DOCS+=( README.md )
# See Copyright in sources and Gentoo bug 506946. Waf is BSD, libmpv is ISC.
LICENSE="GPL-2+ BSD ISC"
SLOT="0"
-IUSE="+alsa aqua archive bluray cdda +cli coreaudio cuda doc drm dvb dvd +egl
- encode gbm +iconv jack jpeg lcms +libass libav libcaca libmpv +lua luajit
- openal +opengl oss pulseaudio raspberry-pi rubberband samba sdl selinux
- test tools +uchardet v4l vaapi vdpau vf-dlopen wayland +X xinerama
+IUSE="+alsa aqua archive bluray cdda +cli coreaudio cplugins cuda doc drm dvb
+ dvd +egl encode gbm +iconv jack jpeg lcms +libass libav libcaca libmpv +lua
+ luajit openal +opengl oss pulseaudio raspberry-pi rubberband samba sdl
+ selinux test tools +uchardet v4l vaapi vdpau vf-dlopen wayland +X xinerama
+xscreensaver +xv zsh-completion"
REQUIRED_USE="
@@ -172,6 +172,7 @@ src_configure() {
--enable-html-build
$(use_enable doc pdf-build)
+ $(use_enable cplugins)
$(use_enable vf-dlopen vf-dlopen-filters)
$(use_enable zsh-completion zsh-comp)
$(use_enable test)