summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2018-06-16 23:01:18 +0300
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2018-06-20 15:41:15 -0700
commitcbc6a61357dec99a5aaa74489fb62c60b3d8532e (patch)
tree845651990a94ef4e4c87ccfbe0e4a58721cf49a9 /media-video/mpv
parentmedia-video/mpv: add vulkan support to 9999 (diff)
downloadgentoo-cbc6a61357dec99a5aaa74489fb62c60b3d8532e.tar.gz
gentoo-cbc6a61357dec99a5aaa74489fb62c60b3d8532e.tar.bz2
gentoo-cbc6a61357dec99a5aaa74489fb62c60b3d8532e.zip
media-video/mpv: add vulkan support to 0.28.2
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'media-video/mpv')
-rw-r--r--media-video/mpv/mpv-0.28.2.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/media-video/mpv/mpv-0.28.2.ebuild b/media-video/mpv/mpv-0.28.2.ebuild
index 32fac3efe428..d43b6047c641 100644
--- a/media-video/mpv/mpv-0.28.2.ebuild
+++ b/media-video/mpv/mpv-0.28.2.ebuild
@@ -31,8 +31,8 @@ SLOT="0"
IUSE="+alsa aqua archive bluray cdda +cli coreaudio cplugins cuda doc drm dvb
dvd +egl encode gbm +iconv jack javascript jpeg lcms +libass libav libcaca
libmpv +lua luajit openal +opengl oss pulseaudio raspberry-pi rubberband
- samba sdl selinux test tools +uchardet v4l vaapi vdpau wayland +X +xv zlib
- zsh-completion"
+ samba sdl selinux test tools +uchardet v4l vaapi vdpau vulkan wayland +X
+ +xv zlib zsh-completion"
REQUIRED_USE="
|| ( cli libmpv )
@@ -50,6 +50,7 @@ REQUIRED_USE="
v4l? ( || ( alsa oss ) )
vaapi? ( || ( gbm X wayland ) )
vdpau? ( X )
+ vulkan? ( || ( X wayland ) )
wayland? ( egl )
X? ( egl? ( opengl ) )
xv? ( X )
@@ -96,6 +97,10 @@ COMMON_DEPEND="
v4l? ( media-libs/libv4l )
vaapi? ( x11-libs/libva:=[drm?,X?,wayland?] )
vdpau? ( x11-libs/libvdpau )
+ vulkan? (
+ media-libs/shaderc
+ media-libs/vulkan-loader[X?,wayland?]
+ )
wayland? (
>=dev-libs/wayland-1.6.0
>=x11-libs/libxkbcommon-0.3.0
@@ -234,10 +239,12 @@ src_configure() {
$(usex vaapi "$(use_enable gbm vaapi-drm)" '--disable-vaapi-drm')
$(use_enable libcaca caca)
$(use_enable jpeg)
+ $(use_enable vulkan shaderc)
$(use_enable raspberry-pi rpi)
$(usex libmpv "$(use_enable opengl plain-gl)" '--disable-plain-gl')
--disable-mali-fbdev # Only available in overlays.
$(usex opengl '' '--disable-gl')
+ $(use_enable vulkan)
# HWaccels:
# Automagic Video Toolbox HW acceleration. See Gentoo bug 577332.