summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-01 01:00:18 +0100
committerSam James <sam@gentoo.org>2021-10-01 01:00:39 +0100
commit95839274ef7c289570c1c7c7549f3ed5439b9b98 (patch)
treeb51afc5fffc292d5a61b584759d6feb6b5e1976b /media-video/pipewire
parentsci-libs/fplll: remove old "unused" fplll-5.3.2.ebuild. (diff)
downloadgentoo-95839274ef7c289570c1c7c7549f3ed5439b9b98.tar.gz
gentoo-95839274ef7c289570c1c7c7549f3ed5439b9b98.tar.bz2
gentoo-95839274ef7c289570c1c7c7549f3ed5439b9b98.zip
media-video/pipewire: add 0.3.38
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-video/pipewire')
-rw-r--r--media-video/pipewire/Manifest1
-rw-r--r--media-video/pipewire/files/pipewire-0.3.38-find-readline.patch36
-rw-r--r--media-video/pipewire/files/pipewire-0.3.38-fix-arm-build.patch18
-rw-r--r--media-video/pipewire/files/pipewire-0.3.38-libcamera-null-deref.patch70
-rw-r--r--media-video/pipewire/pipewire-0.3.38.ebuild290
-rw-r--r--media-video/pipewire/pipewire-9999.ebuild1
6 files changed, 416 insertions, 0 deletions
diff --git a/media-video/pipewire/Manifest b/media-video/pipewire/Manifest
index 3e2400ff6d73..a76808c01975 100644
--- a/media-video/pipewire/Manifest
+++ b/media-video/pipewire/Manifest
@@ -5,3 +5,4 @@ DIST pipewire-0.3.34.tar.gz 1682396 BLAKE2B 1a3524a833bde6facf637071f905bb0237f3
DIST pipewire-0.3.35.tar.gz 1704419 BLAKE2B 5c0debd19b29a9488be26125794f04e57e8b3cd3842654cb935decae18ffefc4137927d969448f60f1c1c2985d54db139fc3dcf07e36e81014021d63490096d8 SHA512 08a2e305fe4e9d3c3f4533c163b725dd32d26513e51a9f476bd18d6157ebf67e97e48b8df9595d45c81599f416e6b3f76e90df575dd460a8d26fe951db30e0f6
DIST pipewire-0.3.36.tar.gz 1708209 BLAKE2B 20fce0d7f88347fe594491d4fae7b6a8edee67ff7749f1a40b807a5d5094d792e61e3efd05dca2221f781c263e34ff0a50ad3c162231911d4b1d87704df6c775 SHA512 f0fc68ea005018b420a4f65a24dc9c85eb6263c24e66852a7ce2b03f966990d62487b388c7d73ff5adfc10c80c439b1200ae876e41d78f91db190036a1799a14
DIST pipewire-0.3.37.tar.gz 1716320 BLAKE2B ce98b28015de69a0c91953a4839d5f86a29cfa19e2058ba0a2476a75a03b782ae67239b418306e4ed7dab81fe7e77928a417b966ff3c72ac552006cea66e3218 SHA512 3f4cf1ac66117a56a7a264262e2e238a54060457da6a986bd9227f51cc7e8d1a8fd282aef8462c096819282c5baec22779d2025c2e1918bbfb3d6ff75829aea6
+DIST pipewire-0.3.38.tar.gz 1727371 BLAKE2B dac7f3e1992b9690195df1dbc04575d386d21d06d1727b004b851e300709b3707806b7b20d36c1e74225d91a2df5428c913376903b286592f87083857347e53e SHA512 c3c6c822bf4e5e77fed8d6ef09059d3e43195957692ab7baddc349af3d759d892a9af0e7802d389e2a9a15e5fece4c08ec963ac42df931233eec6057bad67eb6
diff --git a/media-video/pipewire/files/pipewire-0.3.38-find-readline.patch b/media-video/pipewire/files/pipewire-0.3.38-find-readline.patch
new file mode 100644
index 000000000000..6b56304f5d17
--- /dev/null
+++ b/media-video/pipewire/files/pipewire-0.3.38-find-readline.patch
@@ -0,0 +1,36 @@
+https://gitlab.freedesktop.org/pipewire/pipewire/-/commit/ddfbd684e78e2b8b9ad40bedb4612ea0197d231a.patch
+
+From: Joshua Strobl <joshua@streambits.io>
+Date: Thu, 30 Sep 2021 23:11:50 +0300
+Subject: [PATCH] Fix readline detection by allowing fallback to cc
+ find_library
+
+--- a/meson.build
++++ b/meson.build
+@@ -326,6 +326,11 @@ dbus_dep = dependency('dbus-1')
+ sdl_dep = dependency('sdl2', required : get_option('sdl2'))
+ summary({'SDL 2': sdl_dep.found()}, bool_yn: true, section: 'Misc dependencies')
+ readline_dep = dependency('readline', required : false)
++
++if not readline_dep.found()
++ readline_dep = cc.find_library('readline', required: false)
++endif
++
+ summary({'readline (for pw-cli)': readline_dep.found()}, bool_yn: true, section: 'Misc dependencies')
+ ncurses_dep = dependency('ncursesw', required : false)
+ sndfile_dep = dependency('sndfile', version : '>= 1.0.20', required : get_option('sndfile'))
+@@ -406,7 +411,12 @@ libinotify_dep = (build_machine.system() == 'freebsd'
+ : dependency('', required: false))
+
+ # On FreeBSD, libintl library is required for gettext
+-libintl_dep = cc.find_library('intl', required: false)
++libintl_dep = dependency('intl', required: false)
++
++if not libintl_dep.found()
++ libintl_dep = cc.find_library('intl', required: false)
++endif
++summary({'intl support': libintl_dep.found()}, bool_yn: true)
+
+ need_alsa = get_option('pipewire-alsa').enabled() or get_option('session-managers').contains('media-session')
+ alsa_dep = dependency('alsa', version : '>=1.1.7', required: need_alsa)
+GitLab
diff --git a/media-video/pipewire/files/pipewire-0.3.38-fix-arm-build.patch b/media-video/pipewire/files/pipewire-0.3.38-fix-arm-build.patch
new file mode 100644
index 000000000000..222aa58cce13
--- /dev/null
+++ b/media-video/pipewire/files/pipewire-0.3.38-fix-arm-build.patch
@@ -0,0 +1,18 @@
+https://gitlab.freedesktop.org/pipewire/pipewire/-/commit/f8817b439433798bd7217dc4ae72197887b0fc96.patch
+
+From: Wim Taymans <wtaymans@redhat.com>
+Date: Thu, 30 Sep 2021 11:12:27 +0200
+Subject: [PATCH] cpu: fix compilation on ARM
+
+--- a/spa/plugins/support/cpu-arm.c
++++ b/spa/plugins/support/cpu-arm.c
+@@ -80,7 +80,7 @@ arm_init(struct impl *impl)
+ int arch;
+
+ if (!(cpuinfo = get_cpuinfo())) {
+- spa_log_warn(impl->log, NAME " %p: Can't read cpuinfo", impl);
++ spa_log_warn(impl->log, "%p: Can't read cpuinfo", impl);
+ return 1;
+ }
+
+GitLab
diff --git a/media-video/pipewire/files/pipewire-0.3.38-libcamera-null-deref.patch b/media-video/pipewire/files/pipewire-0.3.38-libcamera-null-deref.patch
new file mode 100644
index 000000000000..beabd1a30291
--- /dev/null
+++ b/media-video/pipewire/files/pipewire-0.3.38-libcamera-null-deref.patch
@@ -0,0 +1,70 @@
+https://gitlab.freedesktop.org/pipewire/pipewire/-/commit/d71a10b7fa9b5c560485b6bbde409c10d3fdd114.patch
+
+From: Wim Taymans <wtaymans@redhat.com>
+Date: Thu, 30 Sep 2021 12:54:29 +0200
+Subject: [PATCH] libcamera: handle failure gracefully
+
+Don't try to access NULL pointers
+--- a/spa/plugins/libcamera/libcamera-client.c
++++ b/spa/plugins/libcamera/libcamera-client.c
+@@ -210,10 +210,10 @@ impl_init(const struct spa_handle_factory *factory,
+ SPA_DEVICE_CHANGE_MASK_PROPS;
+ this->info.flags = 0;
+
+- if(this->dev.camera == NULL) {
++ if(this->dev.camera == NULL)
+ this->dev.camera = (LibCamera*)newLibCamera();
++ if(this->dev.camera != NULL)
+ libcamera_set_log(this->dev.camera, this->dev.log);
+- }
+
+ return 0;
+ }
+--- a/spa/plugins/libcamera/libcamera-source.c
++++ b/spa/plugins/libcamera/libcamera-source.c
+@@ -994,10 +994,10 @@ impl_init(const struct spa_handle_factory *factory,
+ port->dev.log = this->log;
+ port->dev.fd = -1;
+
+- if(port->dev.camera == NULL) {
++ if(port->dev.camera == NULL)
+ port->dev.camera = (LibCamera*)newLibCamera();
++ if(port->dev.camera != NULL)
+ libcamera_set_log(port->dev.camera, port->dev.log);
+- }
+
+ if (info && (str = spa_dict_lookup(info, SPA_KEY_API_LIBCAMERA_PATH))) {
+ strncpy(this->props.device, str, 63);
+--- a/spa/plugins/libcamera/libcamera_wrapper.cpp
++++ b/spa/plugins/libcamera/libcamera_wrapper.cpp
+@@ -540,7 +540,8 @@ extern "C" {
+ }
+
+ void LibCamera::close() {
+- this->cam_->release();
++ if (this->cam_)
++ this->cam_->release();
+ }
+
+ void LibCamera::connect()
+@@ -775,6 +776,9 @@ extern "C" {
+ std::unique_ptr<CameraManager> cm = std::make_unique<CameraManager>();
+ LibCamera* camera = new LibCamera();
+
++ pthread_mutexattr_init(&attr);
++ pthread_mutex_init(&camera->lock, &attr);
++
+ ret = cm->start();
+ if (ret) {
+ deleteLibCamera(camera);
+@@ -794,9 +798,6 @@ extern "C" {
+ return nullptr;
+ }
+
+- pthread_mutexattr_init(&attr);
+- pthread_mutex_init(&camera->lock, &attr);
+-
+ camera->ring_buffer_init();
+
+ return camera;
+GitLab
diff --git a/media-video/pipewire/pipewire-0.3.38.ebuild b/media-video/pipewire/pipewire-0.3.38.ebuild
new file mode 100644
index 000000000000..9b2951c07937
--- /dev/null
+++ b/media-video/pipewire/pipewire-0.3.38.ebuild
@@ -0,0 +1,290 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit meson-multilib optfeature python-any-r1 systemd udev
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/${PN}/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://gitlab.freedesktop.org/${PN}/${PN}/-/archive/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="Multimedia processing graphs"
+HOMEPAGE="https://pipewire.org/"
+
+LICENSE="MIT LGPL-2.1+ GPL-2"
+SLOT="0/0.3"
+IUSE="bluetooth doc echo-cancel extra gstreamer jack-client jack-sdk pipewire-alsa systemd test v4l"
+
+# Once replacing system JACK libraries is possible, it's likely that
+# jack-client IUSE will need blocking to avoid users accidentally
+# configuring their systems to send PW sink output to the emulated
+# JACK's sink - doing so is likely to yield no audio, cause a CPU
+# cycles consuming loop (and may even cause GUI crashes)!
+
+REQUIRED_USE="jack-sdk? ( !jack-client )"
+
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ app-doc/xmltoman
+ >=dev-util/meson-0.59
+ virtual/pkgconfig
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep 'dev-python/docutils[${PYTHON_USEDEP}]')
+ doc? (
+ app-doc/doxygen
+ media-gfx/graphviz
+ )
+"
+RDEPEND="
+ acct-group/audio
+ media-libs/alsa-lib
+ sys-apps/dbus[${MULTILIB_USEDEP}]
+ sys-libs/readline:=
+ sys-libs/ncurses:=[unicode(+)]
+ virtual/libintl[${MULTILIB_USEDEP}]
+ virtual/libudev[${MULTILIB_USEDEP}]
+ bluetooth? (
+ media-libs/fdk-aac
+ media-libs/libldac
+ media-libs/libfreeaptx
+ media-libs/sbc
+ >=net-wireless/bluez-4.101:=
+ )
+ echo-cancel? ( media-libs/webrtc-audio-processing:0 )
+ extra? (
+ >=media-libs/libsndfile-1.0.20
+ )
+ gstreamer? (
+ >=dev-libs/glib-2.32.0:2
+ >=media-libs/gstreamer-1.10.0:1.0
+ media-libs/gst-plugins-base:1.0
+ )
+ jack-client? ( >=media-sound/jack2-1.9.10:2[dbus] )
+ jack-sdk? (
+ !media-sound/jack-audio-connection-kit
+ !media-sound/jack2
+ )
+ pipewire-alsa? (
+ >=media-libs/alsa-lib-1.1.7[${MULTILIB_USEDEP}]
+ !media-plugins/alsa-plugins[${MULTILIB_USEDEP},pulseaudio]
+ )
+ !pipewire-alsa? ( media-plugins/alsa-plugins[${MULTILIB_USEDEP},pulseaudio] )
+ systemd? ( sys-apps/systemd )
+ v4l? ( media-libs/libv4l )
+"
+
+DEPEND="${RDEPEND}"
+
+# Present RDEPEND that are currently always disabled due to the PW
+# code using them being required to be disabled by Gentoo guidelines
+# (i.e. developer binaries not meant for users) and unready code
+# media-video/ffmpeg:=
+# media-libs/libsdl2
+# >=media-libs/vulkan-loader-1.1.69
+#
+# Ditto for DEPEND
+# >=dev-util/vulkan-headers-1.1.69
+
+DOCS=( {README,INSTALL}.md NEWS )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.3.25-enable-failed-mlock-warning.patch
+ # Upstream
+ "${FILESDIR}"/${P}-fix-arm-build.patch
+ "${FILESDIR}"/${P}-libcamera-null-deref.patch # (we don't have it in ::gentoo but let's be nice)
+ "${FILESDIR}"/${P}-find-readline.patch # just in case
+)
+
+# limitsdfile related code taken from =sys-auth/realtime-base-0.1
+# with changes as necessary.
+limitsdfile=40-${PN}.conf
+
+python_check_deps() {
+ has_version -b "dev-python/docutils[${PYTHON_USEDEP}]"
+}
+
+src_prepare() {
+ default
+
+ if ! use systemd; then
+ # This can be applied non-conditionally but would make for a
+ # significantly worse user experience on systemd then.
+ eapply "${FILESDIR}"/${PN}-0.3.36-non-systemd-integration.patch
+ fi
+
+ einfo "Generating ${limitsdfile}"
+ cat > ${limitsdfile} <<- EOF || die
+ # Start of ${limitsdfile} from ${P}
+
+ @audio - memlock 256
+
+ # End of ${limitsdfile} from ${P}
+ EOF
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Ddocdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(meson_native_use_feature doc docs)
+ $(meson_native_enabled examples) # Disabling this implicitly disables -Dmedia-session
+ # Replaced upstream by -Dsession-managers=..., needs more work, bug #812809
+ # but default is same as before and right now, this is fatal with unreleased Meson.
+ #$(meson_native_enabled media-session)
+ $(meson_native_enabled man)
+ $(meson_feature test tests)
+ -Dinstalled_tests=disabled # Matches upstream; Gentoo never installs tests
+ $(meson_native_use_feature gstreamer)
+ $(meson_native_use_feature gstreamer gstreamer-device-provider)
+ $(meson_native_use_feature systemd)
+ -Dsystemd-system-service=disabled # Matches upstream
+ $(meson_native_use_feature systemd systemd-user-service)
+ $(meson_feature pipewire-alsa) # Allows integrating ALSA apps into PW graph
+ -Dspa-plugins=enabled
+ -Dalsa=enabled # Allows using kernel ALSA for sound I/O (-Dmedia-session depends on this)
+ -Daudiomixer=enabled # Matches upstream
+ -Daudioconvert=enabled # Matches upstream
+ $(meson_native_use_feature bluetooth bluez5)
+ $(meson_native_use_feature bluetooth bluez5-backend-hsp-native)
+ $(meson_native_use_feature bluetooth bluez5-backend-hfp-native)
+ $(meson_native_use_feature bluetooth bluez5-backend-ofono)
+ $(meson_native_use_feature bluetooth bluez5-backend-hsphfpd)
+ $(meson_native_use_feature bluetooth bluez5-codec-aac)
+ $(meson_native_use_feature bluetooth bluez5-codec-aptx)
+ $(meson_native_use_feature bluetooth bluez5-codec-ldac)
+ $(meson_native_use_feature echo-cancel echo-cancel-webrtc) #807889
+ -Dcontrol=enabled # Matches upstream
+ -Daudiotestsrc=enabled # Matches upstream
+ -Dffmpeg=disabled # Disabled by upstream and no major developments to spa/plugins/ffmpeg/ since May 2020
+ -Dpipewire-jack=enabled # Allows integrating JACK apps into PW graph
+ $(meson_native_use_feature jack-client jack) # Allows PW to act as a JACK client
+ $(meson_use jack-sdk jack-devel)
+ $(usex jack-sdk "-Dlibjack-path=${EPREFIX}/usr/$(get_libdir)" '')
+ -Dsupport=enabled # Miscellaneous/common plugins, such as null sink
+ -Devl=disabled # Matches upstream
+ -Dtest=disabled # fakesink and fakesource plugins
+ $(meson_native_use_feature v4l v4l2)
+ -Dlibcamera=disabled # libcamera is not in Portage tree
+ -Dvideoconvert=enabled # Matches upstream
+ -Dvideotestsrc=enabled # Matches upstream
+ -Dvolume=enabled # Matches upstream
+ -Dvulkan=disabled # Uses pre-compiled Vulkan compute shader to provide a CGI video source (dev thing; disabled by upstream)
+ $(meson_native_use_feature extra pw-cat)
+ -Dudev=enabled
+ -Dudevrulesdir="${EPREFIX}$(get_udevdir)/rules.d"
+ -Dsdl2=disabled # Controls SDL2 dependent code (currently only examples when -Dinstalled_tests=enabled which we never install)
+ $(meson_native_use_feature extra sndfile) # Enables libsndfile dependent code (currently only pw-cat)
+ )
+
+ meson_src_configure
+}
+
+multilib_src_install() {
+ # Our customs DOCS do not exist in multilib source directory
+ DOCS= meson_src_install
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ insinto /etc/security/limits.d
+ doins ${limitsdfile}
+
+ if use pipewire-alsa; then
+ dodir /etc/alsa/conf.d
+ # These will break if someone has /etc that is a symbol link to a subfolder! See #724222
+ # And the current dosym8 -r implementation is likely affected by the same issue, too.
+ dosym ../../../usr/share/alsa/alsa.conf.d/50-pipewire.conf /etc/alsa/conf.d/50-pipewire.conf
+ dosym ../../../usr/share/alsa/alsa.conf.d/99-pipewire-default.conf /etc/alsa/conf.d/99-pipewire-default.conf
+ fi
+
+ if ! use systemd; then
+ insinto /etc/xdg/autostart
+ newins "${FILESDIR}"/pipewire.desktop pipewire.desktop
+
+ exeinto /usr/libexec
+ newexe "${FILESDIR}"/pipewire-launcher.sh pipewire-launcher
+ fi
+}
+
+pkg_postinst() {
+ elog "It is recommended to raise RLIMIT_MEMLOCK to 256 for users"
+ elog "using PipeWire. Do it either manually or add yourself"
+ elog "to the 'audio' group:"
+ elog
+ elog " usermod -aG audio <youruser>"
+ elog
+
+ if ! use jack-sdk; then
+ elog "JACK emulation is incomplete and not all programs will work. PipeWire's"
+ elog "alternative libraries have been installed to a non-default location."
+ elog "To use them, put pw-jack <application> before every JACK application."
+ elog "When using pw-jack, do not run jackd/jackdbus. However, a virtual/jack"
+ elog "provider is still needed to compile the JACK applications themselves."
+ elog
+ fi
+
+ if use systemd; then
+ elog "To use PipeWire for audio, the user units must be manually enabled"
+ elog "by running this command as each user you use for desktop activities:"
+ elog
+ elog " systemctl --user enable --now pipewire.socket pipewire-pulse.socket"
+ elog
+ elog "When switching from PulseAudio, do not forget to disable PulseAudio likewise:"
+ elog
+ elog " systemctl --user disable --now pulseaudio.service pulseaudio.socket"
+ elog
+ elog "A reboot is recommended to avoid interferences from still running"
+ elog "PulseAudio daemon."
+ elog
+ elog "Both, new users and those upgrading, need to enable pipewire-media-session"
+ elog "for relevant users:"
+ elog
+ elog " systemctl --user enable --now pipewire-media-session.service"
+ elog
+ else
+ elog "This ebuild auto-enables PulseAudio replacement. Because of that, users"
+ elog "are recommended to edit: ${EROOT}/etc/pulse/client.conf and disable"
+ elog "autospawning of the original daemon by setting:"
+ elog
+ elog " autospawn = no"
+ elog
+ elog "Please note that the semicolon (;) must _NOT_ be at the beginning of the line!"
+ elog
+ elog "Alternatively, if replacing PulseAudio daemon is not desired, edit"
+ elog "${EROOT}/etc/pipewire/pipewire.conf by commenting out the relevant"
+ elog "command near the end of the file:"
+ elog
+ elog "#\"/usr/bin/pipewire\" = { args = \"-c pipewire-pulse.conf\" }"
+ elog
+ elog "NOTE:"
+ elog "Starting with PipeWire-0.3.30, this package is no longer installing its config"
+ elog "into ${EROOT}/etc/pipewire by default. In case you need to change"
+ elog "its config, please start by copying default config from ${EROOT}/usr/share/pipewire"
+ elog "and just override the sections you want to change."
+ fi
+
+ elog "For latest tips and tricks, troubleshooting information and documentation"
+ elog "in general, please refer to https://wiki.gentoo.org/wiki/PipeWire"
+ elog
+
+ optfeature_header "The following can be installed for optional runtime features:"
+ optfeature "restricted realtime capabilities via D-Bus" sys-auth/rtkit
+
+ if has_version 'net-misc/ofono' ; then
+ ewarn "Native backend has become default. Please disable oFono via:"
+ if systemd_is_booted ; then
+ ewarn "systemctl disable --now ofono"
+ else
+ ewarn "rc-update delete ofono"
+ fi
+ ewarn
+ fi
+}
diff --git a/media-video/pipewire/pipewire-9999.ebuild b/media-video/pipewire/pipewire-9999.ebuild
index 7725dfa300f5..b6c000cf8a53 100644
--- a/media-video/pipewire/pipewire-9999.ebuild
+++ b/media-video/pipewire/pipewire-9999.ebuild
@@ -47,6 +47,7 @@ RDEPEND="
acct-group/audio
media-libs/alsa-lib
sys-apps/dbus[${MULTILIB_USEDEP}]
+ sys-libs/readline:=
sys-libs/ncurses:=[unicode(+)]
virtual/libintl[${MULTILIB_USEDEP}]
virtual/libudev[${MULTILIB_USEDEP}]