summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/plasma-mediacenter
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/plasma-mediacenter')
-rw-r--r--media-video/plasma-mediacenter/Manifest1
-rw-r--r--media-video/plasma-mediacenter/metadata.xml8
-rw-r--r--media-video/plasma-mediacenter/plasma-mediacenter-1.3.0.ebuild53
3 files changed, 62 insertions, 0 deletions
diff --git a/media-video/plasma-mediacenter/Manifest b/media-video/plasma-mediacenter/Manifest
new file mode 100644
index 000000000000..2bafa20168af
--- /dev/null
+++ b/media-video/plasma-mediacenter/Manifest
@@ -0,0 +1 @@
+DIST plasma-mediacenter-1.3.0.tar.bz2 449835 SHA256 7ea3c50d9fa5499f50c8e00d9d23a12d7967a340dc53986ea1099669769e46ca SHA512 d20d9175c23fb2375eef72ed367b8f1337d9e26845935a7da8ea72195945f2cdfa466b72e8f0af70c4d1a767002971a6896d41cbf93f9cf87522d99952fed607 WHIRLPOOL 377ff000663f53e433cb161a4c7db5ea2c9088a39bd644ccec9dae35441a185e994097450e884f45714ddd2baa3fe0e1120f05abdeda7c500e49793b0dcb713f
diff --git a/media-video/plasma-mediacenter/metadata.xml b/media-video/plasma-mediacenter/metadata.xml
new file mode 100644
index 000000000000..2d94d9badf67
--- /dev/null
+++ b/media-video/plasma-mediacenter/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+ <use>
+ <flag name="nepomuk">Enable Nepomuk based semantic desktop support (deprecated)</flag>
+ </use>
+</pkgmetadata>
diff --git a/media-video/plasma-mediacenter/plasma-mediacenter-1.3.0.ebuild b/media-video/plasma-mediacenter/plasma-mediacenter-1.3.0.ebuild
new file mode 100644
index 000000000000..1173c2e4f2c7
--- /dev/null
+++ b/media-video/plasma-mediacenter/plasma-mediacenter-1.3.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DECLARATIVE_REQUIRED="always"
+OPENGL_REQUIRED="always"
+KDE_LINGUAS="bs ca ca@valencia cs da de el es fi fr gl hu it lv nl pl pt pt_BR sk sl sv tr uk zh_TW"
+inherit kde4-base
+
+DESCRIPTION="Unified media experience for any device capable of running KDE"
+HOMEPAGE="http://www.kde.org/ http://community.kde.org/Plasma/Plasma_Media_Center"
+
+if [[ ${KDE_BUILD_TYPE} != live ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.bz2"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE="debug nepomuk semantic-desktop"
+
+REQUIRED_USE="?? ( nepomuk semantic-desktop )"
+
+# bug 516686
+RESTRICT="test"
+
+RDEPEND="
+ $(add_kdebase_dep plasma-workspace)
+ dev-qt/qt-mobility[multimedia,qml]
+ media-libs/taglib
+ nepomuk? ( $(add_kdebase_dep nepomuk-core) )
+ semantic-desktop? ( $(add_kdebase_dep baloo) )
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+"
+
+S=${WORKDIR}/${PN}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package nepomuk NepomukCore)
+ $(cmake-utils_use_find_package semantic-desktop Baloo)
+ )
+
+ if ! use nepomuk && ! use semantic-desktop ; then
+ mycmakeargs+=( -DUSE_FILESYSTEM_MEDIA_SOURCE=ON )
+ fi
+
+ kde4-base_src_configure
+}