summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-03-14 14:24:32 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-03-14 14:30:36 +0100
commitc8db2349474da86a6cc649c5a33a672a9c09f870 (patch)
treebc4082dc73a0825ffe630298148e5731c529ea05 /media-video/popcorntime-bin
parentdev-python/python-lsp-server: add version 1.4.0 (diff)
downloadgentoo-c8db2349474da86a6cc649c5a33a672a9c09f870.tar.gz
gentoo-c8db2349474da86a6cc649c5a33a672a9c09f870.tar.bz2
gentoo-c8db2349474da86a6cc649c5a33a672a9c09f870.zip
media-video/popcorntime-bin: add version 0.4.7
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'media-video/popcorntime-bin')
-rw-r--r--media-video/popcorntime-bin/Manifest2
-rw-r--r--media-video/popcorntime-bin/popcorntime-bin-0.4.7.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/media-video/popcorntime-bin/Manifest b/media-video/popcorntime-bin/Manifest
index 10e67e0c2281..a6d3bbb181f6 100644
--- a/media-video/popcorntime-bin/Manifest
+++ b/media-video/popcorntime-bin/Manifest
@@ -1,2 +1,4 @@
DIST Popcorn-Time-0.4.6-amd64.deb 101425596 BLAKE2B 267cdad781702773b7241d8abd683062cbebe495802d0845e16028cd679344f6916ed9f15f4d14c00a73bae0ca92c377d02e5785bf098a407297ec7ae8b365bf SHA512 38feca591658794ccb0b91ea753c99a776195f2e746e1c5108114fccc88fa2290dd6955cd3d962f35f9653cbb2c48502bcd8c4ac2172cc5b83aa777fd3db6fb3
DIST Popcorn-Time-0.4.6-i386.deb 104385136 BLAKE2B 736808eb90e52d5703264cdb7e4c3a7e6458ceb608f122484c91ff51cb38ff21ae7f615a00aeab6b1688bab36fbf7acf2bb546b58be679d518715f4c1fc0513b SHA512 9b9321d2e3b1cbb37f290f7221b0611632bdacd7b3fac12a2e9400022d19e5b4f6fff87b969b62638f9a478e7bd0b04c6bd1e13699e812647af944d042443f2b
+DIST Popcorn-Time-0.4.7-amd64.deb 101720792 BLAKE2B d437bbc67e7520a59ba1b37dcf17e69e860fc47e2b492c7b3d3df4f1fe0fd848af3fed3962668c296509db5aaca168b48669a6765694195378d47e884d028668 SHA512 9d29bc7a541379b248abc7d4ac4711fa3e6ac2e9645f566d5fba24430b30f1b4c55a7a0ae652f2e57b56f547eda6564a8c0696432ac4cdd099828e0fd3ff010d
+DIST Popcorn-Time-0.4.7-i386.deb 104588216 BLAKE2B 83ce8dc4d64b03a3918cafca380904ce60078ee1ba317b09884bf1d32fa46ab5b00383d1c15d5d4b6e040609a996d8a4743ae94220209c47ae4ce9e300bf1ad2 SHA512 60270178d343870707ab6d6247321cc983e19e896e09a05d412189d4c22c449768f01d612029b23f2dc449819066fcc6f5cb176a78e08e57450088b8130fd963
diff --git a/media-video/popcorntime-bin/popcorntime-bin-0.4.7.ebuild b/media-video/popcorntime-bin/popcorntime-bin-0.4.7.ebuild
new file mode 100644
index 000000000000..6918fce89e42
--- /dev/null
+++ b/media-video/popcorntime-bin/popcorntime-bin-0.4.7.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit unpacker xdg
+
+DESCRIPTION="BitTorrent client that includes an integrated media player"
+HOMEPAGE="https://github.com/popcorn-official/popcorn-desktop"
+SRC_URI="
+ amd64? ( https://github.com/popcorn-official/popcorn-desktop/releases/download/v${PV}/Popcorn-Time-${PV}-amd64.deb )
+ x86? ( https://github.com/popcorn-official/popcorn-desktop/releases/download/v${PV}/Popcorn-Time-${PV}-i386.deb )
+"
+S="${WORKDIR}"
+
+KEYWORDS="-* ~amd64 ~x86"
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="
+ app-accessibility/at-spi2-core:2
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ net-print/cups
+ sys-apps/dbus
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXScrnSaver
+ x11-libs/libXtst
+ x11-libs/pango
+"
+
+QA_PREBUILT="opt/Popcorn-Time/*"
+
+src_install() {
+ mv "${S}"/* "${ED}" || die
+ dosym ../Popcorn-Time/Popcorn-Time /opt/bin/popcorntime
+}