summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-06-27 11:52:36 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-06-27 11:58:53 +0200
commit7467c77a73c01890b4619b7d70268a3f893ab1b2 (patch)
tree0aeef39ee9073d40f030387e0c9d24cbd283be72 /media-video/shotcut
parentprofiles: remove dev-libs/efl[pixman] use mask (diff)
downloadgentoo-7467c77a73c01890b4619b7d70268a3f893ab1b2.tar.gz
gentoo-7467c77a73c01890b4619b7d70268a3f893ab1b2.tar.bz2
gentoo-7467c77a73c01890b4619b7d70268a3f893ab1b2.zip
media-video/shotcut: 19.06.15 version bump, EAPI-7
Non-maintainer commit. Drop obsolete src_prepare phase, minor style fixes. Closes: https://bugs.gentoo.org/652260 Closes: https://bugs.gentoo.org/683684 Closes: https://github.com/gentoo/gentoo/pull/11978 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-video/shotcut')
-rw-r--r--media-video/shotcut/Manifest1
-rw-r--r--media-video/shotcut/shotcut-19.06.15.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/media-video/shotcut/Manifest b/media-video/shotcut/Manifest
index f213fcf7087c..dc303ceb79d8 100644
--- a/media-video/shotcut/Manifest
+++ b/media-video/shotcut/Manifest
@@ -1 +1,2 @@
DIST shotcut-19.01.24.tar.gz 4864498 BLAKE2B e76f38e2545bff176730f1287fbba35de9d82e11d5ea4b396e69e71f90dd09325aceae8ffefe6914e66e37c983415a28c4fcdeba14314e370b3220cc8399a6be SHA512 1026e0701dd7a0a5dc3bc5f9babe0f58c6d3a0871af7b09cfca8d71b4c3e370708103d6f78de1061505cd162ade3de0189c9dc085d51546e85bb472f38b0363d
+DIST shotcut-19.06.15.tar.gz 5066141 BLAKE2B ca140045b181287089486f8e7c857ddee29b41727cc9808f37b39118875927a46b0d80558403870b478d2e6b53aadb9acc6456b09560ec94d63c91a5b36bffba SHA512 bf1dbd1233f587ba33dff9c551cdaa22c0ca8bb389c79e817d3eb7af60834b47da2be29872c50125a93e152442a7f7afe8f76f353464334de399dda793d15591
diff --git a/media-video/shotcut/shotcut-19.06.15.ebuild b/media-video/shotcut/shotcut-19.06.15.ebuild
new file mode 100644
index 000000000000..d06301a297db
--- /dev/null
+++ b/media-video/shotcut/shotcut-19.06.15.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils xdg
+
+DESCRIPTION="A free, open source, cross-platform video editor"
+HOMEPAGE="https://www.shotcut.org/"
+SRC_URI="https://github.com/mltframework/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgraphicaleffects:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtopengl:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtquickcontrols:5[widgets]
+ dev-qt/qtsql:5
+ dev-qt/qtwebkit:5
+ dev-qt/qtwebsockets:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ media-libs/ladspa-sdk
+ media-libs/libsdl:0
+ media-libs/libvpx
+ >=media-libs/mlt-6.10.0-r1[ffmpeg,frei0r,qt5,sdl,xml]
+ media-libs/x264
+ media-plugins/frei0r-plugins
+ media-sound/lame
+ media-video/ffmpeg
+ virtual/jack
+"
+DEPEND="${RDEPEND}
+ dev-qt/qtconcurrent:5
+ dev-qt/qtx11extras:5
+"
+
+src_configure() {
+ eqmake5 PREFIX="${EPREFIX}/usr"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+}