summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-12-27 13:31:36 +0100
committerLars Wendler <polynomial-c@gentoo.org>2020-12-27 13:32:55 +0100
commit975fbf51be8a381b4261684e523f4400958f4378 (patch)
treeda6d35f311ecd79506271caa532974666536c455 /media-video/simplescreenrecorder
parentdev-python/jeepney: stable 0.6.0 for sparc (diff)
downloadgentoo-975fbf51be8a381b4261684e523f4400958f4378.tar.gz
gentoo-975fbf51be8a381b4261684e523f4400958f4378.tar.bz2
gentoo-975fbf51be8a381b4261684e523f4400958f4378.zip
media-video/simplescreenrecorder: Bump to version 0.4.3
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'media-video/simplescreenrecorder')
-rw-r--r--media-video/simplescreenrecorder/Manifest1
-rw-r--r--media-video/simplescreenrecorder/simplescreenrecorder-0.4.3.ebuild102
2 files changed, 103 insertions, 0 deletions
diff --git a/media-video/simplescreenrecorder/Manifest b/media-video/simplescreenrecorder/Manifest
index 36c69dc4bcac..c7bcb7952774 100644
--- a/media-video/simplescreenrecorder/Manifest
+++ b/media-video/simplescreenrecorder/Manifest
@@ -1 +1,2 @@
DIST simplescreenrecorder-0.4.2.tar.gz 1912151 BLAKE2B d8a4605a82e49693f94ecfac8853405a660a4528c3001961b1734d4387e49eeb4c91603929b3cd5d5b67a23a6ec839ace606b29666b916960f10322e6ec1b452 SHA512 60b0127d7f82f294e5a8f015363e37a10b5492089a0178b07a5e383c7e4b857102ed2bda7a95e3c67293a255f892481aeaf4037c583320d68d463637348ed7f7
+DIST simplescreenrecorder-0.4.3.tar.gz 1918958 BLAKE2B 9d0e07255c7345d8752a8f49fd2e7947db4058c6e6bdbe1239955f96f06543eff24b207bcd049d07eb7d3d5815ad5f1c77721e1fa139f940b1deb3b3da7a46e0 SHA512 c930045d6763bdb026cee80fe82aa0e973de7a1bd92bce9650c5cae627f5d8f8d913f260024410a41170081c8eda61c1aea346bc2d9740b8dc169a3952b3bfd0
diff --git a/media-video/simplescreenrecorder/simplescreenrecorder-0.4.3.ebuild b/media-video/simplescreenrecorder/simplescreenrecorder-0.4.3.ebuild
new file mode 100644
index 000000000000..8331e3404184
--- /dev/null
+++ b/media-video/simplescreenrecorder/simplescreenrecorder-0.4.3.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib flag-o-matic xdg
+
+DESCRIPTION="A Simple Screen Recorder"
+HOMEPAGE="https://www.maartenbaert.be/simplescreenrecorder"
+LICENSE="GPL-3"
+PKGNAME="ssr"
+if [[ ${PV} = 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/MaartenBaert/${PKGNAME}.git"
+ EGIT_BOOTSTRAP=""
+else
+ SRC_URI="https://github.com/MaartenBaert/${PKGNAME}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PKGNAME}-${PV}"
+fi
+
+SLOT="0"
+IUSE="+asm jack mp3 pulseaudio theora v4l vorbis vpx x264"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ media-libs/alsa-lib:0=
+ media-libs/libglvnd[${MULTILIB_USEDEP},X]
+ media-video/ffmpeg[vorbis?,vpx?,x264?,mp3?,theora?]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXext
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
+ x11-libs/libXi
+ x11-libs/libXinerama
+ virtual/glu[${MULTILIB_USEDEP}]
+ v4l? ( media-libs/libv4l )
+ jack? ( virtual/jack )
+ pulseaudio? ( media-sound/pulseaudio )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-qt/linguist-tools:5"
+
+pkg_pretend() {
+ if [[ "${ABI}" == amd64 ]]; then
+ elog "You may want to add USE flag 'abi_x86_32' when running a 64bit system"
+ elog "When added 32bit GLInject libraries are also included. This is"
+ elog "required if you want to use OpenGL recording on 32bit applications."
+ elog
+ fi
+
+ if has_version media-video/ffmpeg[x264] && has_version media-libs/x264[10bit] ; then
+ ewarn
+ ewarn "media-libs/x264 is currently built with 10bit useflag."
+ ewarn "This is known to prevent simplescreenrecorder from recording x264 videos"
+ ewarn "correctly. Please build media-libs/x264 without 10bit if you want to "
+ ewarn "record videos with x264."
+ ewarn
+ fi
+}
+
+pkg_setup() {
+ # QT requires -fPIC. Compile fails otherwise.
+ # Recently removed from the default compile options upstream
+ # https://github.com/MaartenBaert/ssr/commit/25fe1743058f0d1f95f6fbb39014b6ac146b5180
+ append-flags -fPIC
+}
+
+src_prepare() {
+ # required because xdg.eclass overrides default cmake_src_prepare
+ cmake_src_prepare
+}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DENABLE_JACK_METADATA="$(multilib_native_usex jack)"
+ -DENABLE_X86_ASM="$(usex asm)"
+ -DWITH_PULSEAUDIO="$(multilib_native_usex pulseaudio)"
+ -DWITH_JACK="$(multilib_native_usex jack)"
+ -DWITH_GLINJECT="true"
+ -DWITH_V4L2="$(usex v4l)"
+ )
+
+ if multilib_is_native_abi ; then
+ mycmakeargs+=(
+ -DENABLE_32BIT_GLINJECT="false"
+ -DWITH_QT5="true"
+ )
+ else
+ mycmakeargs+=(
+ # https://bugs.gentoo.org/660438
+ -DCMAKE_INSTALL_LIB32DIR="$(get_libdir)"
+ -DENABLE_32BIT_GLINJECT="true"
+ -DWITH_SIMPLESCREENRECORDER="false"
+ )
+ fi
+
+ cmake_src_configure
+}