summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/subtitlecomposer
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/subtitlecomposer')
-rw-r--r--media-video/subtitlecomposer/Manifest1
-rw-r--r--media-video/subtitlecomposer/metadata.xml9
-rw-r--r--media-video/subtitlecomposer/subtitlecomposer-0.5.6.ebuild46
3 files changed, 56 insertions, 0 deletions
diff --git a/media-video/subtitlecomposer/Manifest b/media-video/subtitlecomposer/Manifest
new file mode 100644
index 000000000000..abb90606fdbf
--- /dev/null
+++ b/media-video/subtitlecomposer/Manifest
@@ -0,0 +1 @@
+DIST subtitlecomposer-0.5.6.tar.gz 1489710 SHA256 f55f3330e72a9a9f19f00674651d7d4c6cd7e19993a14d1deedfa6d34737cf0f SHA512 f06f25d746870886669a66875d4d772e10d18136b9107c2f7d23f177ff3979785b7f73a7e723139fe1757298ef7b0a791a95f40fe585ab3239c82d71d2ab4db0 WHIRLPOOL 0aa86a1a58d7a4f2551774725655223ae2847337ea877db11aff01da55af3be31e941d09fa68468924b47db359b584ee0d9c3d1939e350b7b023a264f9a27010
diff --git a/media-video/subtitlecomposer/metadata.xml b/media-video/subtitlecomposer/metadata.xml
new file mode 100644
index 000000000000..d76e08856ffd
--- /dev/null
+++ b/media-video/subtitlecomposer/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+ <herd>kde</herd>
+ <upstream>
+ <remote-id type="github">maxrd2/subtitlecomposer</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-video/subtitlecomposer/subtitlecomposer-0.5.6.ebuild b/media-video/subtitlecomposer/subtitlecomposer-0.5.6.ebuild
new file mode 100644
index 000000000000..1fcf238199f4
--- /dev/null
+++ b/media-video/subtitlecomposer/subtitlecomposer-0.5.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_LINGUAS="bg cs de el es fr hu pl pt_BR ru sr sr@latin uk"
+KDE_LINGUAS_LIVE_OVERRIDE="true"
+inherit kde4-base
+
+DESCRIPTION="Text-based subtitles editor"
+HOMEPAGE="https://github.com/maxrd2/subtitlecomposer"
+SRC_URI="https://github.com/maxrd2/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="amd64 x86"
+SLOT="4"
+IUSE="debug gstreamer unicode xine"
+
+RDEPEND="
+ media-libs/phonon[qt4]
+ gstreamer? ( media-libs/gstreamer:0.10 )
+ unicode? ( dev-libs/icu:= )
+ xine? ( media-libs/xine-lib )
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with gstreamer GStreamer)
+ $(cmake-utils_use_with unicode ICU)
+ $(cmake-utils_use_with xine)
+ )
+ kde4-base_src_configure
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ echo
+ elog "Some example scripts provided by ${PV} require dev-lang/ruby"
+ elog "or dev-lang/python to be installed."
+ echo
+}