summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/subtitleeditor/subtitleeditor-0.41.1-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/subtitleeditor/subtitleeditor-0.41.1-r1.ebuild')
-rw-r--r--media-video/subtitleeditor/subtitleeditor-0.41.1-r1.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/media-video/subtitleeditor/subtitleeditor-0.41.1-r1.ebuild b/media-video/subtitleeditor/subtitleeditor-0.41.1-r1.ebuild
new file mode 100644
index 000000000000..7b161619fbde
--- /dev/null
+++ b/media-video/subtitleeditor/subtitleeditor-0.41.1-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 versionator flag-o-matic
+
+DESCRIPTION="GTK+2 subtitle editing tool"
+HOMEPAGE="http://home.gna.org/subtitleeditor/"
+SRC_URI="http://download.gna.org/${PN}/$(get_version_component_range 1-2)/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug nls opengl"
+
+RDEPEND="
+ app-text/iso-codes
+ dev-cpp/cairomm
+ >=dev-cpp/gtkmm-2.14:2.4
+ >=dev-cpp/glibmm-2.16.3:2
+ dev-libs/glib:2
+ dev-libs/libsigc++:2
+ >=dev-cpp/libxmlpp-2.20:2.6
+ >=app-text/enchant-1.4
+ >=dev-cpp/gstreamermm-0.10.6:0.10
+ media-libs/gstreamer:0.10
+ media-libs/gst-plugins-base:0.10
+ >=media-libs/gst-plugins-good-0.10:0.10
+ >=media-plugins/gst-plugins-meta-0.10-r2:0.10
+ >=media-plugins/gst-plugins-pango-0.10:0.10
+ >=media-plugins/gst-plugins-xvideo-0.10:0.10
+ x11-libs/gtk+:2
+ virtual/libintl
+ opengl? (
+ >=dev-cpp/gtkglextmm-1.2:1.0
+ virtual/opengl )
+"
+# gst-plugins-pango needed for text overlay
+# gst-plugins-xvideo needed for video output
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Get textoverlay working with gstreamermm 0.10.11
+ epatch "${FILESDIR}"/${PN}-0.41.0-textoverlay.patch
+
+ # Prevent crash when generating keyframes with gstreamermm 0.10.11
+ epatch "${FILESDIR}"/${PN}-0.41.0-keyframe-generation.patch
+
+ # Fix typing/editing subtitle, bug #536246
+ epatch "${FILESDIR}"/${PN}-0.41.0-subtitle-edition.patch
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ export GST_REGISTRY="${T}/home/registry.cache.xml"
+
+ # Avoid using --enable-debug as it mocks with CXXFLAGS and LDFLAGS
+ use debug && append-flags -DDEBUG
+
+ gnome2_src_configure \
+ --disable-debug \
+ $(use_enable nls) \
+ $(use_enable opengl gl)
+}