summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/vamps
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/vamps')
-rw-r--r--media-video/vamps/Manifest1
-rw-r--r--media-video/vamps/files/vamps-0.99.2-premature-eof.patch46
-rw-r--r--media-video/vamps/metadata.xml11
-rw-r--r--media-video/vamps/vamps-0.99.2-r1.ebuild31
-rw-r--r--media-video/vamps/vamps-0.99.2.ebuild26
5 files changed, 115 insertions, 0 deletions
diff --git a/media-video/vamps/Manifest b/media-video/vamps/Manifest
new file mode 100644
index 000000000000..9038dbaf133b
--- /dev/null
+++ b/media-video/vamps/Manifest
@@ -0,0 +1 @@
+DIST vamps-0.99.2.tar.gz 47062 SHA256 9bac71441db55c04a642c786d6427efdb65aa27f4b1719ffa34ebc3869572694
diff --git a/media-video/vamps/files/vamps-0.99.2-premature-eof.patch b/media-video/vamps/files/vamps-0.99.2-premature-eof.patch
new file mode 100644
index 000000000000..48340498d9bc
--- /dev/null
+++ b/media-video/vamps/files/vamps-0.99.2-premature-eof.patch
@@ -0,0 +1,46 @@
+--- vamps-0.99.2/vamps/vamps.c.orig 2006-04-15 08:00:07.000000000 -0400
++++ vamps-0.99.2/vamps/vamps.c 2007-01-26 06:54:27.000000000 -0500
+@@ -18,6 +18,9 @@
+ //
+ // Revision history (latest first):
+ //
++// 2007/01/26: V0.99.3: Fixed assumptions in lock() which do not hold for pipes.
++// This cures the "Premature EOF" problem.
++//
+ // 2006/04/15: V0.99.2: Fixed some signed/unsigned issues which caused compiler
+ // warnings on some platforms. No funtional changes.
+ //
+@@ -396,13 +399,24 @@
+ rhwp = rptr + avail;
+ }
+
+- n = read (0, rhwp, RBUF_SIZE - avail);
+-
+- if (n % SECT_SIZE)
+- fatal ("Premature EOF");
+-
+- rhwp += n;
+- bytes_read += n;
++ while (avail < size)
++ {
++ // read; reads from an open pipe will return any non-zero amount of data
++ // (not necessarily the amount we wanted!)
++ n = read (0, rhwp, RBUF_SIZE - avail);
++ if (!n)
++ {
++ if (avail % SECT_SIZE)
++ // we got an EOF and only a partial sector
++ fatal ("Premature EOF");
++ break;
++ }
++ else if (n == -1)
++ fatal ("Read from stdin: %s", strerror (errno));
++ rhwp += n;
++ bytes_read += n;
++ avail += n;
++ }
+
+ return !n;
+ }
+
+
diff --git a/media-video/vamps/metadata.xml b/media-video/vamps/metadata.xml
new file mode 100644
index 000000000000..d769aab5e32c
--- /dev/null
+++ b/media-video/vamps/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+ <maintainer>
+ <email>media-video@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">vamps</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-video/vamps/vamps-0.99.2-r1.ebuild b/media-video/vamps/vamps-0.99.2-r1.ebuild
new file mode 100644
index 000000000000..2152bed8bc6f
--- /dev/null
+++ b/media-video/vamps/vamps-0.99.2-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Very fast requantisizing tool for backup DVDs"
+HOMEPAGE="http://vamps.sourceforge.net/"
+SRC_URI="mirror://sourceforge/vamps/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+DEPEND=">=media-libs/libdvdread-0.9.4"
+
+RDEPEND="${DEPEND}
+ >=media-video/dvdauthor-0.6.10"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}/${P}-premature-eof.patch"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dobin vamps/vamps play_cell/play_cell || die "install failed"
+}
diff --git a/media-video/vamps/vamps-0.99.2.ebuild b/media-video/vamps/vamps-0.99.2.ebuild
new file mode 100644
index 000000000000..785b4b6573f7
--- /dev/null
+++ b/media-video/vamps/vamps-0.99.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Very fast requantisizing tool for backup DVDs"
+HOMEPAGE="http://vamps.sourceforge.net/"
+SRC_URI="mirror://sourceforge/vamps/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+DEPEND=">=media-libs/libdvdread-0.9.4"
+
+RDEPEND="${DEPEND}
+ >=media-video/dvdauthor-0.6.10"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dobin vamps/vamps play_cell/play_cell || die "install failed"
+}