summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2017-06-21 20:41:02 +0900
committerBenda Xu <heroxbd@gentoo.org>2017-07-03 17:29:27 +0900
commit3c66501c3f92db9282eb4741d7f0de85813172fe (patch)
tree554ff485a02bc9c341cf49583190bc8e43410071 /media-video/vlc
parentdev-ruby/net-ssh: fix slot dependency warning (diff)
downloadgentoo-3c66501c3f92db9282eb4741d7f0de85813172fe.tar.gz
gentoo-3c66501c3f92db9282eb4741d7f0de85813172fe.tar.bz2
gentoo-3c66501c3f92db9282eb4741d7f0de85813172fe.zip
media-video/vlc: add Prefix support.
Bug: 612516 Credit: WGH Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'media-video/vlc')
-rw-r--r--media-video/vlc/vlc-2.2.4-r1.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/media-video/vlc/vlc-2.2.4-r1.ebuild b/media-video/vlc/vlc-2.2.4-r1.ebuild
index 053118f3d865..94e5b998c298 100644
--- a/media-video/vlc/vlc-2.2.4-r1.ebuild
+++ b/media-video/vlc/vlc-2.2.4-r1.ebuild
@@ -21,13 +21,13 @@ MY_PV="${MY_PV/-beta/-test}"
MY_P="${PN}-${MY_PV}"
DESCRIPTION="VLC media player - Video player and streamer"
-HOMEPAGE="https://www.videolan.org/vlc/"
+HOMEPAGE="http://www.videolan.org/vlc/"
if [[ ${PV} = *9999 ]] ; then # Live ebuild
SRC_URI=""
elif [[ "${MY_P}" == "${P}" ]]; then
- SRC_URI="https://download.videolan.org/pub/videolan/${PN}/${PV}/${P}.tar.xz"
+ SRC_URI="http://download.videolan.org/pub/videolan/${PN}/${PV}/${P}.tar.xz"
else
- SRC_URI="https://download.videolan.org/pub/videolan/testing/${MY_P}/${MY_P}.tar.xz"
+ SRC_URI="http://download.videolan.org/pub/videolan/testing/${MY_P}/${MY_P}.tar.xz"
fi
LICENSE="LGPL-2.1 GPL-2"
@@ -307,7 +307,7 @@ src_configure() {
local myconf
# Compatibility fix for Samba 4.
- use samba && append-cppflags "-I/usr/include/samba-4.0"
+ use samba && append-cppflags "-I${EPREFIX}/usr/include/samba-4.0"
# We need to disable -fstack-check if use >=gcc 4.8.0.
# See bug #499996
@@ -315,10 +315,10 @@ src_configure() {
# Needs libresid-builder from libsidplay:2 which is in another directory...
# FIXME!
- append-ldflags "-L/usr/$(get_libdir)/sidplay/builders/"
+ append-ldflags "-L${EPREFIX}/usr/$(get_libdir)/sidplay/builders/"
if use truetype || use projectm ; then
- local dejavu="/usr/share/fonts/dejavu/"
+ local dejavu="${EPREFIX}/usr/share/fonts/dejavu/"
myconf="--with-default-font=${dejavu}/DejaVuSans.ttf \
--with-default-font-family=Sans \
--with-default-monospace-font=${dejavu}/DejaVuSansMono.ttf
@@ -339,7 +339,7 @@ src_configure() {
econf \
${myconf} \
--enable-vlc \
- --docdir=/usr/share/doc/${PF} \
+ --docdir='$(datarootdir)'/doc/${PF} \
--disable-dependency-tracking \
--disable-optimizations \
--disable-update-check \