summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-02-14 18:24:34 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-14 19:36:12 +0100
commit9607ad118cce6fd7564b1eca0b14395cfc976cfe (patch)
tree0ccc421293db567decb070bcb08c2db017fa81fb /media-video/vlc
parentdev-qt: Drop Qt 5.11.1 (diff)
downloadgentoo-9607ad118cce6fd7564b1eca0b14395cfc976cfe.tar.gz
gentoo-9607ad118cce6fd7564b1eca0b14395cfc976cfe.tar.bz2
gentoo-9607ad118cce6fd7564b1eca0b14395cfc976cfe.zip
media-video/vlc: Switch from gnome2-utils to xdg
Package-Manager: Portage-2.3.60, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-video/vlc')
-rw-r--r--media-video/vlc/vlc-3.0.6.ebuild16
-rw-r--r--media-video/vlc/vlc-3.0.9999.ebuild16
-rw-r--r--media-video/vlc/vlc-9999.ebuild16
3 files changed, 15 insertions, 33 deletions
diff --git a/media-video/vlc/vlc-3.0.6.ebuild b/media-video/vlc/vlc-3.0.6.ebuild
index 9e6623d04fc5..c73110b818f1 100644
--- a/media-video/vlc/vlc-3.0.6.ebuild
+++ b/media-video/vlc/vlc-3.0.6.ebuild
@@ -12,7 +12,7 @@ if [[ ${PV} = *9999 ]] ; then
else
EGIT_REPO_URI="https://git.videolan.org/git/vlc.git"
fi
- SCM="git-r3"
+ inherit git-r3
else
if [[ ${MY_P} = ${P} ]] ; then
SRC_URI="https://download.videolan.org/pub/videolan/${PN}/${PV}/${P}.tar.xz"
@@ -21,7 +21,7 @@ else
fi
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 -sparc ~x86 ~x86-fbsd"
fi
-inherit autotools flag-o-matic gnome2-utils toolchain-funcs virtualx xdg-utils ${SCM}
+inherit autotools flag-o-matic toolchain-funcs virtualx xdg
DESCRIPTION="Media player and framework with support for most multimedia files and streaming"
HOMEPAGE="https://www.videolan.org/vlc/"
@@ -237,7 +237,7 @@ DOCS=( AUTHORS THANKS NEWS README doc/fortunes.txt )
S="${WORKDIR}/${MY_P}"
src_prepare() {
- default
+ xdg_src_prepare # bug 608256
has_version '>=net-libs/libupnp-1.8.0' && \
eapply "${FILESDIR}"/${PN}-2.2.8-libupnp-slot-1.8.patch
@@ -436,8 +436,6 @@ src_configure() {
# FIXME: Needs libresid-builder from libsidplay:2 which is in another directory...
append-ldflags "-L/usr/$(get_libdir)/sidplay/builders/"
- xdg_environment_reset # bug 608256
-
if use truetype || use bidi; then
myeconfargs+=( --enable-freetype )
else
@@ -481,9 +479,7 @@ pkg_postinst() {
ewarn "If you do not do it, vlc will take a long time to load."
fi
- gnome2_icon_cache_update
- xdg_mimeinfo_database_update
- xdg_desktop_database_update
+ xdg_pkg_postinst
}
pkg_postrm() {
@@ -491,7 +487,5 @@ pkg_postrm() {
rm /usr/$(get_libdir)/vlc/plugins/plugins.dat || die "Failed to rm plugins.dat"
fi
- gnome2_icon_cache_update
- xdg_mimeinfo_database_update
- xdg_desktop_database_update
+ xdg_pkg_postrm
}
diff --git a/media-video/vlc/vlc-3.0.9999.ebuild b/media-video/vlc/vlc-3.0.9999.ebuild
index ebea92479e02..0d0926c14c31 100644
--- a/media-video/vlc/vlc-3.0.9999.ebuild
+++ b/media-video/vlc/vlc-3.0.9999.ebuild
@@ -12,7 +12,7 @@ if [[ ${PV} = *9999 ]] ; then
else
EGIT_REPO_URI="https://git.videolan.org/git/vlc.git"
fi
- SCM="git-r3"
+ inherit git-r3
else
if [[ ${MY_P} = ${P} ]] ; then
SRC_URI="https://download.videolan.org/pub/videolan/${PN}/${PV}/${P}.tar.xz"
@@ -21,7 +21,7 @@ else
fi
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 -sparc ~x86 ~x86-fbsd"
fi
-inherit autotools flag-o-matic gnome2-utils toolchain-funcs virtualx xdg-utils ${SCM}
+inherit autotools flag-o-matic toolchain-funcs virtualx xdg
DESCRIPTION="Media player and framework with support for most multimedia files and streaming"
HOMEPAGE="https://www.videolan.org/vlc/"
@@ -240,7 +240,7 @@ DOCS=( AUTHORS THANKS NEWS README doc/fortunes.txt )
S="${WORKDIR}/${MY_P}"
src_prepare() {
- default
+ xdg_src_prepare # bug 608256
has_version '>=net-libs/libupnp-1.8.0' && \
eapply "${FILESDIR}"/${PN}-2.2.8-libupnp-slot-1.8.patch
@@ -444,8 +444,6 @@ src_configure() {
# FIXME: Needs libresid-builder from libsidplay:2 which is in another directory...
append-ldflags "-L/usr/$(get_libdir)/sidplay/builders/"
- xdg_environment_reset # bug 608256
-
if use truetype || use bidi; then
myeconfargs+=( --enable-freetype )
else
@@ -489,9 +487,7 @@ pkg_postinst() {
ewarn "If you do not do it, vlc will take a long time to load."
fi
- gnome2_icon_cache_update
- xdg_mimeinfo_database_update
- xdg_desktop_database_update
+ xdg_pkg_postinst
}
pkg_postrm() {
@@ -499,7 +495,5 @@ pkg_postrm() {
rm /usr/$(get_libdir)/vlc/plugins/plugins.dat || die "Failed to rm plugins.dat"
fi
- gnome2_icon_cache_update
- xdg_mimeinfo_database_update
- xdg_desktop_database_update
+ xdg_pkg_postrm
}
diff --git a/media-video/vlc/vlc-9999.ebuild b/media-video/vlc/vlc-9999.ebuild
index 7246c78556aa..4fbc7e4b60e2 100644
--- a/media-video/vlc/vlc-9999.ebuild
+++ b/media-video/vlc/vlc-9999.ebuild
@@ -12,7 +12,7 @@ if [[ ${PV} = *9999 ]] ; then
else
EGIT_REPO_URI="https://git.videolan.org/git/vlc.git"
fi
- SCM="git-r3"
+ inherit git-r3
else
if [[ ${MY_P} = ${P} ]] ; then
SRC_URI="https://download.videolan.org/pub/videolan/${PN}/${PV}/${P}.tar.xz"
@@ -21,7 +21,7 @@ else
fi
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 -sparc ~x86 ~x86-fbsd"
fi
-inherit autotools flag-o-matic gnome2-utils toolchain-funcs virtualx xdg-utils ${SCM}
+inherit autotools flag-o-matic toolchain-funcs virtualx xdg
DESCRIPTION="Media player and framework with support for most multimedia files and streaming"
HOMEPAGE="https://www.videolan.org/vlc/"
@@ -243,7 +243,7 @@ DOCS=( AUTHORS THANKS NEWS README doc/fortunes.txt )
S="${WORKDIR}/${MY_P}"
src_prepare() {
- default
+ xdg_src_prepare # bug 608256
has_version '>=net-libs/libupnp-1.8.0' && \
eapply "${FILESDIR}"/${P}-libupnp-slot-1.8.patch
@@ -445,8 +445,6 @@ src_configure() {
# FIXME: Needs libresid-builder from libsidplay:2 which is in another directory...
append-ldflags "-L/usr/$(get_libdir)/sidplay/builders/"
- xdg_environment_reset # bug 608256
-
if use truetype || use bidi; then
myeconfargs+=( --enable-freetype )
else
@@ -490,9 +488,7 @@ pkg_postinst() {
ewarn "If you do not do it, vlc will take a long time to load."
fi
- gnome2_icon_cache_update
- xdg_mimeinfo_database_update
- xdg_desktop_database_update
+ xdg_pkg_postinst
}
pkg_postrm() {
@@ -500,7 +496,5 @@ pkg_postrm() {
rm /usr/libexec/vlc/plugins/plugins.dat || die "Failed to rm plugins.dat"
fi
- gnome2_icon_cache_update
- xdg_mimeinfo_database_update
- xdg_desktop_database_update
+ xdg_pkg_postrm
}