summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-02-10 19:46:58 +0100
committerSam James <sam@gentoo.org>2023-02-17 05:21:07 +0000
commitc79b32b61b3faab133ff22da56b55f7ae6e089bd (patch)
tree3a9e723dfa2e1f9b3745cf9469644134cc627c16 /media-video/vlc
parentmedia-gfx/blender: Update live ebuild source URLs (diff)
downloadgentoo-c79b32b61b3faab133ff22da56b55f7ae6e089bd.tar.gz
gentoo-c79b32b61b3faab133ff22da56b55f7ae6e089bd.tar.bz2
gentoo-c79b32b61b3faab133ff22da56b55f7ae6e089bd.zip
media-video/vlc: remove unused patches
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/29537 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-video/vlc')
-rw-r--r--media-video/vlc/files/vlc-3.0.14-fix-live-address-api.patch53
-rw-r--r--media-video/vlc/files/vlc-3.0.17.3-dav1d-1.0.0.patch78
-rw-r--r--media-video/vlc/files/vlc-3.0.17.4-gcc13.patch20
3 files changed, 0 insertions, 151 deletions
diff --git a/media-video/vlc/files/vlc-3.0.14-fix-live-address-api.patch b/media-video/vlc/files/vlc-3.0.14-fix-live-address-api.patch
deleted file mode 100644
index 2d6f86f0aba6..000000000000
--- a/media-video/vlc/files/vlc-3.0.14-fix-live-address-api.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-Needed for https://bugs.gentoo.org/795798 and
-https://code.videolan.org/videolan/vlc/-/issues/25473
-
-From 94845266b705dc9de7921408531b9d7704f4458f Mon Sep 17 00:00:00 2001
-From: Dominic Mayers <dominic.mayers@meditationstudies.org>
-Date: Sun, 28 Mar 2021 04:37:54 -0400
-Subject: [PATCH] Get addr by ref. from getConnectionEndpointAddress.
-
-Fixes issue #25473 in code.videolan.org. The maintainers of live555 changed
-connectionEndpointAddresss to getConnectionEndpointAddress, which now provides
-the address value by reference. Before, connectionEndpointAddresss returned
-the value. So, in modules/access/live555.cpp, we must first get the value and
-then pass it to IsMulticastAddress. The code will not compile with the recent
-live555 unless we also modify modules/access/Makefile.am - a different patch.
----
- modules/access/live555.cpp | 7 +++++--
- 1 file changed, 5 insertions(+), 2 deletions(-)
-
-diff --git a/modules/access/live555.cpp b/modules/access/live555.cpp
-index 01c535ca5b..95e15e35d9 100644
---- a/modules/access/live555.cpp
-+++ b/modules/access/live555.cpp
-@@ -60,6 +60,7 @@
- #include <liveMedia.hh>
- #include <liveMedia_version.hh>
- #include <Base64.hh>
-+#include <NetAddress.hh>
-
- extern "C" {
- #include "../access/mms/asf.h" /* Who said ugly ? */
-@@ -727,7 +728,8 @@ static int SessionsSetup( demux_t *p_demux )
- unsigned const thresh = 200000; /* RTP reorder threshold .2 second (default .1) */
- const char *p_sess_lang = NULL;
- const char *p_lang;
--
-+ struct sockaddr_storage addr;
-+
- b_rtsp_tcp = var_CreateGetBool( p_demux, "rtsp-tcp" ) ||
- var_GetBool( p_demux, "rtsp-http" );
- i_client_port = var_InheritInteger( p_demux, "rtp-client-port" );
-@@ -850,7 +852,8 @@ static int SessionsSetup( demux_t *p_demux )
- if( !p_sys->b_multicast )
- {
- /* We need different rollover behaviour for multicast */
-- p_sys->b_multicast = IsMulticastAddress( sub->connectionEndpointAddress() );
-+ sub->getConnectionEndpointAddress(addr);
-+ p_sys->b_multicast = IsMulticastAddress( addr );
- }
-
- tk = (live_track_t*)malloc( sizeof( live_track_t ) );
---
-2.25.1
-
diff --git a/media-video/vlc/files/vlc-3.0.17.3-dav1d-1.0.0.patch b/media-video/vlc/files/vlc-3.0.17.3-dav1d-1.0.0.patch
deleted file mode 100644
index deb748cdba92..000000000000
--- a/media-video/vlc/files/vlc-3.0.17.3-dav1d-1.0.0.patch
+++ /dev/null
@@ -1,78 +0,0 @@
-https://code.videolan.org/videolan/vlc/-/merge_requests/1618.patch
-https://bugs.gentoo.org/835787
-
-From 0efdfe8799b0100f41c5b8d6e1b43451001386cb Mon Sep 17 00:00:00 2001
-From: Steve Lhomme <robux4@ycbcr.xyz>
-Date: Fri, 18 Mar 2022 11:42:49 +0100
-Subject: [PATCH 1/2] dav1d: fix compilation with (upcoming) dav1d 1.0
-
-(cherry picked from commit dbf45cea2a8abdfbef897b8a71f3eb782bb1b712) (edited)
-edited:
-- 3.0 has the 128 pixels padding elsewhere
-- 3.0 has an extra parameter for add_integer_with_range()
-- 3.0 was setting i_extra_picture_buffers further down in the code
-- 3.0 uses 16 threads max
-
-Signed-off-by: Steve Lhomme <robux4@ycbcr.xyz>
---- a/modules/codec/dav1d.c
-+++ b/modules/codec/dav1d.c
-@@ -63,10 +63,16 @@ vlc_module_begin ()
- set_category(CAT_INPUT)
- set_subcategory(SUBCAT_INPUT_VCODEC)
-
-+#if DAV1D_API_VERSION_MAJOR >= 6
-+ add_integer_with_range("dav1d-thread-frames", 0, 0, DAV1D_MAX_THREADS,
-+ THREAD_FRAMES_TEXT, THREAD_FRAMES_LONGTEXT, false)
-+ add_obsolete_string("dav1d-thread-tiles") // unused with dav1d 1.0
-+#else
- add_integer_with_range("dav1d-thread-frames", 0, 0, DAV1D_MAX_FRAME_THREADS,
- THREAD_FRAMES_TEXT, THREAD_FRAMES_LONGTEXT, false)
- add_integer_with_range("dav1d-thread-tiles", 0, 0, DAV1D_MAX_TILE_THREADS,
- THREAD_TILES_TEXT, THREAD_TILES_LONGTEXT, false)
-+#endif
- vlc_module_end ()
-
- /*****************************************************************************
-@@ -294,6 +300,11 @@ static int OpenDecoder(vlc_object_t *p_this)
- return VLC_ENOMEM;
-
- dav1d_default_settings(&p_sys->s);
-+#if DAV1D_API_VERSION_MAJOR >= 6
-+ p_sys->s.n_threads = var_InheritInteger(p_this, "dav1d-thread-frames");
-+ if (p_sys->s.n_threads == 0)
-+ p_sys->s.n_threads = (i_core_count < 16) ? i_core_count : 16;
-+#else
- p_sys->s.n_tile_threads = var_InheritInteger(p_this, "dav1d-thread-tiles");
- if (p_sys->s.n_tile_threads == 0)
- p_sys->s.n_tile_threads =
-@@ -303,6 +314,7 @@ static int OpenDecoder(vlc_object_t *p_this)
- p_sys->s.n_frame_threads = var_InheritInteger(p_this, "dav1d-thread-frames");
- if (p_sys->s.n_frame_threads == 0)
- p_sys->s.n_frame_threads = (i_core_count < 16) ? i_core_count : 16;
-+#endif
- p_sys->s.allocator.cookie = dec;
- p_sys->s.allocator.alloc_picture_callback = NewPicture;
- p_sys->s.allocator.release_picture_callback = FreePicture;
-@@ -313,12 +325,20 @@ static int OpenDecoder(vlc_object_t *p_this)
- return VLC_EGENERIC;
- }
-
-+#if DAV1D_API_VERSION_MAJOR >= 6
-+ msg_Dbg(p_this, "Using dav1d version %s with %d threads",
-+ dav1d_version(), p_sys->s.n_threads);
-+
-+ dec->i_extra_picture_buffers = (p_sys->s.n_threads - 1);
-+#else
- msg_Dbg(p_this, "Using dav1d version %s with %d/%d frame/tile threads",
- dav1d_version(), p_sys->s.n_frame_threads, p_sys->s.n_tile_threads);
-
-+ dec->i_extra_picture_buffers = (p_sys->s.n_frame_threads - 1);
-+#endif
-+
- dec->pf_decode = Decode;
- dec->pf_flush = FlushDecoder;
-- dec->i_extra_picture_buffers = (p_sys->s.n_frame_threads - 1);
-
- dec->fmt_out.video.i_width = dec->fmt_in.video.i_width;
- dec->fmt_out.video.i_height = dec->fmt_in.video.i_height;
-GitLab
diff --git a/media-video/vlc/files/vlc-3.0.17.4-gcc13.patch b/media-video/vlc/files/vlc-3.0.17.4-gcc13.patch
deleted file mode 100644
index 374cd5ada0ac..000000000000
--- a/media-video/vlc/files/vlc-3.0.17.4-gcc13.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-https://code.videolan.org/robUx4/vlc/-/commit/6fca76ebd76bf8fce9b111e31bda64015cdc770f
-https://bugs.gentoo.org/875785
-
-From 6fca76ebd76bf8fce9b111e31bda64015cdc770f Mon Sep 17 00:00:00 2001
-From: Johannes Kauffmann <johanneskauffmann@hotmail.com>
-Date: Mon, 11 Jul 2022 19:35:57 +0000
-Subject: [PATCH] demux: dash: include cstdint, needed for uint64_t
-
-Fixes #27077.
---- a/modules/demux/dash/mpd/TemplatedUri.hpp
-+++ b/modules/demux/dash/mpd/TemplatedUri.hpp
-@@ -21,6 +21,7 @@
- #ifndef TEMPLATEDURI_HPP
- #define TEMPLATEDURI_HPP
-
-+#include <cstdint>
- #include <string>
-
- namespace dash
-GitLab