summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/xine-ui
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/xine-ui')
-rw-r--r--media-video/xine-ui/Manifest3
-rw-r--r--media-video/xine-ui/files/xine-ui-0.99.8-readline-6.3.patch33
-rw-r--r--media-video/xine-ui/metadata.xml14
-rw-r--r--media-video/xine-ui/xine-ui-0.99.7.ebuild94
-rw-r--r--media-video/xine-ui/xine-ui-0.99.8.ebuild94
-rw-r--r--media-video/xine-ui/xine-ui-0.99.9.ebuild93
6 files changed, 331 insertions, 0 deletions
diff --git a/media-video/xine-ui/Manifest b/media-video/xine-ui/Manifest
new file mode 100644
index 000000000000..958bc8bff6b9
--- /dev/null
+++ b/media-video/xine-ui/Manifest
@@ -0,0 +1,3 @@
+DIST xine-ui-0.99.7.tar.xz 1752328 SHA256 9d8cdfd1c5c84251d6978765b059adf57099ff6c447f3e4b59066c8563f66bc4 SHA512 6070d28cb3f5bb816b1f218d07c5e0001e71069dfc6b6c761b95960f095736923a6e83a97dfab88d93688c1029a7c1d30dc4a2327e2c8481b3b06cb7cc837c1f WHIRLPOOL 7b7b87b56029c11d3ea1036420dca09e730370294659cadc0e5937cd36383e84a941f89bd69535566ffc8cd639aa21ea439ba1e82b1f46fa6211ecf7cc4a09f1
+DIST xine-ui-0.99.8.tar.xz 1758372 SHA256 1ac5a9fc8dbf81f12a8677108bf2b623e70d7adbb83b83912b9cdf00bc78b2a7 SHA512 a2d11b0c512b9d485e0bbe418b36fb5fd52fe1a9c68cdb865771fc580b30bff513825f3e24ef85a902669c2c1ea8947512dd9abe4c12fdef94b8852cc8588da3 WHIRLPOOL c7d67f94422dfdbd609b3e2d880134a2e2d414981d229870157c10f5c54928101336f83f70d6c56c8da238fd25933b4490958e379d2d0a64721553f3fd7d6638
+DIST xine-ui-0.99.9.tar.xz 1759568 SHA256 8dd180219f546a7be0a5651370996b95b3a38ec97bf01b57d2bd1cb966e591a2 SHA512 575b20a19c5740ba0336af9dea0a1bc15d23b7471379b9d72aeb585e23f95b336368b96a28d4804726507f059dc431cc3f9adfd8b615b08c0e67b65287c2b6c7 WHIRLPOOL 7bce787c8718e057a33af2ad33efc2ab1ed4358181f2b626e871f79c396b6b900ccf3631a302463f93951199eeae19887fb2c7d4a5eddf137c85664b99424b8a
diff --git a/media-video/xine-ui/files/xine-ui-0.99.8-readline-6.3.patch b/media-video/xine-ui/files/xine-ui-0.99.8-readline-6.3.patch
new file mode 100644
index 000000000000..3799975d0afb
--- /dev/null
+++ b/media-video/xine-ui/files/xine-ui-0.99.8-readline-6.3.patch
@@ -0,0 +1,33 @@
+http://bugs.gentoo.org/show_bug.cgi?id=504208
+
+Fix building with readline >= 6.3 API (see network.c change)
+Fix another crash on exit (see main.c change)
+
+patches/debian-changes from xine-ui_0.99.8-2.debian.tar.xz at http://packages.debian.org/xine-ui
+
+--- src/xitk/main.c
++++ src/xitk/main.c
+@@ -1255,8 +1255,10 @@ static void event_listener(void *user_da
+ gGui->mixer.volume_level = (aevent->left + aevent->right) / 2;
+ if(gGui->mixer.method == SOUND_CARD_MIXER) {
+ gGui->mixer.mute = aevent->mute;
+- xitk_slider_set_pos(panel->mixer.slider, gGui->mixer.volume_level);
+- xitk_checkbox_set_state(panel->mixer.mute, gGui->mixer.mute);
++ if (panel) {
++ xitk_slider_set_pos(panel->mixer.slider, gGui->mixer.volume_level);
++ xitk_checkbox_set_state(panel->mixer.mute, gGui->mixer.mute);
++ }
+ }
+ }
+ break;
+--- src/xitk/network.c
++++ src/xitk/network.c
+@@ -1255,7 +1255,7 @@ int main(int argc, char **argv) {
+ rl_readline_name = PROGNAME;
+ rl_set_prompt(session.prompt);
+ rl_initialize();
+- rl_attempted_completion_function = (CPPFunction *)completion_function;
++ rl_attempted_completion_function = completion_function;
+
+ signal(SIGPIPE, SIG_IGN);
+
diff --git a/media-video/xine-ui/metadata.xml b/media-video/xine-ui/metadata.xml
new file mode 100644
index 000000000000..4f92b9f020b8
--- /dev/null
+++ b/media-video/xine-ui/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+ <maintainer>
+ <email>media-video@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="vdr">Enables Video Disk Recorder support</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">xine</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-video/xine-ui/xine-ui-0.99.7.ebuild b/media-video/xine-ui/xine-ui-0.99.7.ebuild
new file mode 100644
index 000000000000..d411c47b1dff
--- /dev/null
+++ b/media-video/xine-ui/xine-ui-0.99.7.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit fdo-mime gnome2-utils
+
+DESCRIPTION="Xine movie player"
+HOMEPAGE="http://xine.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xine/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc ppc64 x86 ~x86-fbsd"
+IUSE="aalib curl debug libcaca lirc nls readline vdr X xinerama"
+
+RDEPEND="|| ( app-arch/tar app-arch/libarchive )
+ media-libs/libpng:0
+ >=media-libs/xine-lib-1.2[aalib?,libcaca?]
+ virtual/jpeg
+ aalib? ( media-libs/aalib )
+ curl? ( >=net-misc/curl-7.10.2 )
+ libcaca? ( media-libs/libcaca )
+ lirc? ( app-misc/lirc )
+ nls? ( virtual/libintl )
+ readline? ( =sys-libs/readline-6.2* )
+ X? (
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXft
+ x11-libs/libXrender
+ x11-libs/libXScrnSaver
+ x11-libs/libXtst
+ x11-libs/libXv
+ x11-libs/libXxf86vm
+ xinerama? ( x11-libs/libXinerama )
+ )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ X? (
+ x11-libs/libXt
+ x11-proto/inputproto
+ x11-proto/xf86vidmodeproto
+ xinerama? ( x11-proto/xineramaproto )
+ )
+ virtual/pkgconfig"
+
+src_prepare() {
+ rm -f misc/xine-bugreport
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable xinerama) \
+ $(use_enable lirc) \
+ $(use_enable vdr vdr-keys) \
+ --disable-nvtvsimple \
+ $(use_enable debug) \
+ $(use_with X x) \
+ $(use_with readline) \
+ $(use_with curl) \
+ $(use_with aalib) \
+ $(use_with libcaca caca) \
+ --without-fb
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ docdir="/usr/share/doc/${PF}" \
+ docsdir="/usr/share/doc/${PF}" \
+ install
+
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}
diff --git a/media-video/xine-ui/xine-ui-0.99.8.ebuild b/media-video/xine-ui/xine-ui-0.99.8.ebuild
new file mode 100644
index 000000000000..88071fa01363
--- /dev/null
+++ b/media-video/xine-ui/xine-ui-0.99.8.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils fdo-mime gnome2-utils
+
+DESCRIPTION="Xine movie player"
+HOMEPAGE="http://xine.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xine/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="aalib curl debug libcaca lirc nls readline vdr X xinerama"
+
+RDEPEND="|| ( app-arch/tar app-arch/libarchive )
+ media-libs/libpng:0=
+ >=media-libs/xine-lib-1.2:=[aalib?,libcaca?]
+ virtual/jpeg:0
+ aalib? ( media-libs/aalib:= )
+ curl? ( >=net-misc/curl-7.10.2:= )
+ libcaca? ( media-libs/libcaca:= )
+ lirc? ( app-misc/lirc:= )
+ nls? ( virtual/libintl )
+ readline? ( >=sys-libs/readline-6.2:= )
+ X? (
+ x11-libs/libICE:=
+ x11-libs/libSM:=
+ x11-libs/libX11:=
+ x11-libs/libXext:=
+ x11-libs/libXft:=
+ x11-libs/libXrender:=
+ x11-libs/libXScrnSaver:=
+ x11-libs/libXtst:=
+ x11-libs/libXv:=
+ x11-libs/libXxf86vm:=
+ xinerama? ( x11-libs/libXinerama:= )
+ )"
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.18.3 )
+ X? (
+ x11-libs/libXt
+ x11-proto/inputproto
+ x11-proto/xf86vidmodeproto
+ xinerama? ( x11-proto/xineramaproto )
+ )
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-readline-6.3.patch
+ rm -f misc/xine-bugreport
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable xinerama) \
+ $(use_enable lirc) \
+ $(use_enable vdr vdr-keys) \
+ --disable-nvtvsimple \
+ $(use_enable debug) \
+ $(use_with X x) \
+ $(use_with readline) \
+ $(use_with curl) \
+ $(use_with aalib) \
+ $(use_with libcaca caca) \
+ --without-fb
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ docdir="/usr/share/doc/${PF}" \
+ docsdir="/usr/share/doc/${PF}" \
+ install
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}
diff --git a/media-video/xine-ui/xine-ui-0.99.9.ebuild b/media-video/xine-ui/xine-ui-0.99.9.ebuild
new file mode 100644
index 000000000000..8440263e45b7
--- /dev/null
+++ b/media-video/xine-ui/xine-ui-0.99.9.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit fdo-mime gnome2-utils
+
+DESCRIPTION="Xine movie player"
+HOMEPAGE="http://xine.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xine/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc ppc64 x86 ~x86-fbsd"
+IUSE="aalib curl debug libcaca lirc nls readline vdr X xinerama"
+
+RDEPEND="|| ( app-arch/tar app-arch/libarchive )
+ media-libs/libpng:0=
+ >=media-libs/xine-lib-1.2:=[aalib?,libcaca?]
+ virtual/jpeg:0
+ aalib? ( media-libs/aalib:= )
+ curl? ( >=net-misc/curl-7.10.2:= )
+ libcaca? ( media-libs/libcaca:= )
+ lirc? ( app-misc/lirc:= )
+ nls? ( virtual/libintl )
+ readline? ( >=sys-libs/readline-6.2:= )
+ X? (
+ x11-libs/libICE:=
+ x11-libs/libSM:=
+ x11-libs/libX11:=
+ x11-libs/libXext:=
+ x11-libs/libXft:=
+ x11-libs/libXrender:=
+ x11-libs/libXScrnSaver:=
+ x11-libs/libXtst:=
+ x11-libs/libXv:=
+ x11-libs/libXxf86vm:=
+ xinerama? ( x11-libs/libXinerama:= )
+ )"
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.18.3 )
+ X? (
+ x11-libs/libXt
+ x11-proto/inputproto
+ x11-proto/xf86vidmodeproto
+ xinerama? ( x11-proto/xineramaproto )
+ )
+ virtual/pkgconfig"
+
+src_prepare() {
+ rm -f misc/xine-bugreport
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable xinerama) \
+ $(use_enable lirc) \
+ $(use_enable vdr vdr-keys) \
+ --disable-nvtvsimple \
+ $(use_enable debug) \
+ $(use_with X x) \
+ $(use_with readline) \
+ $(use_with curl) \
+ $(use_with aalib) \
+ $(use_with libcaca caca) \
+ --without-fb
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ docdir="/usr/share/doc/${PF}" \
+ docsdir="/usr/share/doc/${PF}" \
+ install
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}