summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2019-10-23 19:58:53 +0300
committerJoonas Niilola <juippis@gentoo.org>2019-10-23 19:58:53 +0300
commitbeae54aa090caf6f225fac2e0f692a9f6fe809c5 (patch)
tree545c2e8afab92fac21efe8d5e22c6cbcd45f9162 /media-video/yle-dl
parentapp-admin/mcelog: bump to 165 (diff)
downloadgentoo-beae54aa090caf6f225fac2e0f692a9f6fe809c5.tar.gz
gentoo-beae54aa090caf6f225fac2e0f692a9f6fe809c5.tar.bz2
gentoo-beae54aa090caf6f225fac2e0f692a9f6fe809c5.zip
media-video/yle-dl: bump to 20191022
Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-video/yle-dl')
-rw-r--r--media-video/yle-dl/Manifest1
-rw-r--r--media-video/yle-dl/yle-dl-20191022.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/media-video/yle-dl/Manifest b/media-video/yle-dl/Manifest
index 495895597be6..0d262fba3f17 100644
--- a/media-video/yle-dl/Manifest
+++ b/media-video/yle-dl/Manifest
@@ -1 +1,2 @@
DIST yle-dl-20190614.tar.gz 83579 BLAKE2B 9117ab32d3e037f22cc209d3686e23d14802438f77203f08e102901d825c06e7c332d1f6ca33bce3af3d4042e9c543fec60e261153be8ab738b038cc1cf4069b SHA512 6a4bfdb93229f48580d8acf742e1e253aa3da79f84ecc3886c32757ddc46608795c58cd02cb0aaa2f7d42188456eac50a243b815baa3752ac6a1b12b9632109c
+DIST yle-dl-20191022.tar.gz 84694 BLAKE2B bfeab9c5220931b8af5eae94b0f5377d21f6b6fb7b21c5f7bc5360a69e7185b8f1e052a584460187cfdd04d68295a20cb895e749af43c1de4ffd7fcd7bfc3875 SHA512 2d7c6d7f8e60cb8fd54fc04dcf73caf5022e3c65ab78f002c280950184fb2458f88f6934b62c0afaeaf30864b5cc47b1ef9c2a58d2855c5111a563cd195095be
diff --git a/media-video/yle-dl/yle-dl-20191022.ebuild b/media-video/yle-dl/yle-dl-20191022.ebuild
new file mode 100644
index 000000000000..281cc2da933d
--- /dev/null
+++ b/media-video/yle-dl/yle-dl-20191022.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5..6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Download media files from Yle Areena"
+HOMEPAGE="http://aajanki.github.io/yle-dl/"
+SRC_URI="https://github.com/aajanki/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="libav php test +youtube-dl"
+
+# Requires an active internet connection during tests
+RESTRICT="test"
+
+RDEPEND="
+ !libav? ( media-video/ffmpeg )
+ >=dev-python/attrs-18.1.0[${PYTHON_USEDEP}]
+ <=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/configargparse-0.13.0[${PYTHON_USEDEP}]
+ dev-python/future[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/mini-amf[${PYTHON_USEDEP}]
+ dev-python/progress[${PYTHON_USEDEP}]
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ net-misc/wget
+ php? (
+ dev-lang/php:*[bcmath,cli,curl,simplexml]
+ >=dev-libs/openssl-1.0.2:0=
+ media-video/rtmpdump
+ )
+ youtube-dl? ( net-misc/youtube-dl[${PYTHON_USEDEP}] )
+"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( COPYING ChangeLog README.fi README.md yledl.conf.sample )
+
+src_prepare() {
+ default
+
+ # Gentoo doesn't ship pycryptodomex with pycryptodome
+ sed -i 's/pycryptodomex/pycryptodome/g' setup.py || die
+}
+
+python_test() {
+ # For tests to run succesfully, you need to disable network stricting
+ # feature first.
+ # FEATURES="-network-sandbox test" emerge -a yle-dl
+ esetup.py test
+}
+
+pkg_postinst() {
+ einfo "Sample configuration file has been installed in "
+ einfo " /usr/share/doc/yle-dl-2.37/yledl.conf.sample.bz2"
+}