summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-05-23 11:09:07 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-05-23 11:09:34 +0200
commit3fc97f728cf9805bf2845d4c7633c0c063d77692 (patch)
tree70ff41248e1bdb95fa910cbb29c409ea16d78132 /media-video
parentnet-misc/connman: fix EPREFIX typo (diff)
downloadgentoo-3fc97f728cf9805bf2845d4c7633c0c063d77692.tar.gz
gentoo-3fc97f728cf9805bf2845d4c7633c0c063d77692.tar.bz2
gentoo-3fc97f728cf9805bf2845d4c7633c0c063d77692.zip
media-video/dvdauthor: Fixed build with imagemagick-7 (bug #610574).
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'media-video')
-rw-r--r--media-video/dvdauthor/dvdauthor-0.7.2-r1.ebuild5
-rw-r--r--media-video/dvdauthor/files/dvdauthor-0.7.2-imagemagick7.patch37
2 files changed, 42 insertions, 0 deletions
diff --git a/media-video/dvdauthor/dvdauthor-0.7.2-r1.ebuild b/media-video/dvdauthor/dvdauthor-0.7.2-r1.ebuild
index 035baec13122..b279738dca1f 100644
--- a/media-video/dvdauthor/dvdauthor-0.7.2-r1.ebuild
+++ b/media-video/dvdauthor/dvdauthor-0.7.2-r1.ebuild
@@ -30,6 +30,11 @@ DOCS=( AUTHORS ChangeLog README TODO )
src_prepare() {
default
+
+ if has_version '>=media-gfx/imagemagick-7.0.1.0' ; then
+ eapply "${FILESDIR}/${PN}-0.7.2-imagemagick7.patch"
+ fi
+
if use graphicsmagick ; then
sed -i -e 's:ExportImagePixels:dIsAbLeAuToMaGiC&:' configure \
|| die
diff --git a/media-video/dvdauthor/files/dvdauthor-0.7.2-imagemagick7.patch b/media-video/dvdauthor/files/dvdauthor-0.7.2-imagemagick7.patch
new file mode 100644
index 000000000000..9f9e3a0b3016
--- /dev/null
+++ b/media-video/dvdauthor/files/dvdauthor-0.7.2-imagemagick7.patch
@@ -0,0 +1,37 @@
+--- dvdauthor/src/subgen-image.c
++++ dvdauthor/src/subgen-image.c
+@@ -30,7 +30,7 @@
+
+ #if defined(HAVE_MAGICK) || defined(HAVE_GMAGICK)
+ #include <stdarg.h>
+-#include <magick/api.h>
++#include <MagickWand/MagickWand.h>
+ #else
+ #include <png.h>
+ #endif
+@@ -181,7 +181,8 @@
+ unsigned long magickver;
+ unsigned char amask;
+
+- GetExceptionInfo(&ei);
++ ExceptionInfo *exception_info;
++ exception_info = AcquireExceptionInfo();
+ ii=CloneImageInfo(NULL);
+ strcpy(ii->filename,s->fname);
+ im=ReadImage(ii,&ei);
+@@ -1098,13 +1099,13 @@
+ void image_init()
+ {
+ #if defined(HAVE_MAGICK) || defined(HAVE_GMAGICK)
+- InitializeMagick(NULL);
++ MagickCoreGenesis("", MagickFalse);
+ #endif
+ }
+
+ void image_shutdown()
+ {
+ #if defined(HAVE_MAGICK) || defined(HAVE_GMAGICK)
+- DestroyMagick();
++ MagickCoreTerminus();
+ #endif
+ }