summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-12-27 20:45:14 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-12-27 20:46:31 +0100
commit4dc990e3540588bf665141010d82b921bd5f4920 (patch)
tree38396fa057ea18810e5c00617022ce4e7ba64ebe /media-video
parentdev-python/coverage: Stabilize 6.2 x86, #830119 (diff)
downloadgentoo-4dc990e3540588bf665141010d82b921bd5f4920.tar.gz
gentoo-4dc990e3540588bf665141010d82b921bd5f4920.tar.bz2
gentoo-4dc990e3540588bf665141010d82b921bd5f4920.zip
media-video/popcorntime-bin: add new package
Closes: https://bugs.gentoo.org/525000 Closes: https://bugs.gentoo.org/601594 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/popcorntime-bin/Manifest2
-rw-r--r--media-video/popcorntime-bin/metadata.xml12
-rw-r--r--media-video/popcorntime-bin/popcorntime-bin-0.4.6.ebuild53
3 files changed, 67 insertions, 0 deletions
diff --git a/media-video/popcorntime-bin/Manifest b/media-video/popcorntime-bin/Manifest
new file mode 100644
index 000000000000..10e67e0c2281
--- /dev/null
+++ b/media-video/popcorntime-bin/Manifest
@@ -0,0 +1,2 @@
+DIST Popcorn-Time-0.4.6-amd64.deb 101425596 BLAKE2B 267cdad781702773b7241d8abd683062cbebe495802d0845e16028cd679344f6916ed9f15f4d14c00a73bae0ca92c377d02e5785bf098a407297ec7ae8b365bf SHA512 38feca591658794ccb0b91ea753c99a776195f2e746e1c5108114fccc88fa2290dd6955cd3d962f35f9653cbb2c48502bcd8c4ac2172cc5b83aa777fd3db6fb3
+DIST Popcorn-Time-0.4.6-i386.deb 104385136 BLAKE2B 736808eb90e52d5703264cdb7e4c3a7e6458ceb608f122484c91ff51cb38ff21ae7f615a00aeab6b1688bab36fbf7acf2bb546b58be679d518715f4c1fc0513b SHA512 9b9321d2e3b1cbb37f290f7221b0611632bdacd7b3fac12a2e9400022d19e5b4f6fff87b969b62638f9a478e7bd0b04c6bd1e13699e812647af944d042443f2b
diff --git a/media-video/popcorntime-bin/metadata.xml b/media-video/popcorntime-bin/metadata.xml
new file mode 100644
index 000000000000..070ec4672d4b
--- /dev/null
+++ b/media-video/popcorntime-bin/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="github">popcorn-official/popcorn-desktop</remote-id>
+ <bugs-to>https://github.com/popcorn-official/popcorn-desktop/issues</bugs-to>
+ </upstream>
+ <maintainer type="person">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/media-video/popcorntime-bin/popcorntime-bin-0.4.6.ebuild b/media-video/popcorntime-bin/popcorntime-bin-0.4.6.ebuild
new file mode 100644
index 000000000000..a2ae70050632
--- /dev/null
+++ b/media-video/popcorntime-bin/popcorntime-bin-0.4.6.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit unpacker xdg
+
+DESCRIPTION="BitTorrent client that includes an integrated media player"
+HOMEPAGE="https://github.com/popcorn-official/popcorn-desktop"
+SRC_URI="
+ amd64? ( https://github.com/popcorn-official/popcorn-desktop/releases/download/v0.4.6/Popcorn-Time-${PV}-amd64.deb )
+ x86? ( https://github.com/popcorn-official/popcorn-desktop/releases/download/v0.4.6/Popcorn-Time-${PV}-i386.deb )
+"
+
+KEYWORDS="-* ~amd64 ~x86"
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="
+ app-accessibility/at-spi2-core:2
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ net-print/cups
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXScrnSaver
+ x11-libs/libXtst
+ x11-libs/pango
+"
+
+QA_PREBUILT="/opt/Popcorn-Time/*"
+
+S="${WORKDIR}"
+
+src_install() {
+ mv "${S}"/* "${ED}" || die
+ dosym ../Popcorn-Time/Popcorn-Time /opt/bin/popcorntime
+}